summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/npth')
-rw-r--r--dev-libs/npth/npth-1.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-libs/npth/npth-1.3.ebuild b/dev-libs/npth/npth-1.3.ebuild
index 6e8ba3061681..23ad1eb43ef6 100644
--- a/dev-libs/npth/npth-1.3.ebuild
+++ b/dev-libs/npth/npth-1.3.ebuild
@@ -1,18 +1,25 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
+inherit libtool
+
DESCRIPTION="New GNU Portable Threads Library"
HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
+src_prepare() {
+ default
+ elibtoolize # for Solaris shared library
+}
+
src_configure() {
econf $(use_enable static-libs static)
}