summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-7.2.11.ebuild')
-rw-r--r--dev-lang/php/php-7.2.11.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/php/php-7.2.11.ebuild b/dev-lang/php/php-7.2.11.ebuild
index 761d9460704b..818e210d1a58 100644
--- a/dev-lang/php/php-7.2.11.ebuild
+++ b/dev-lang/php/php-7.2.11.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic eapi7-ver systemd
+inherit flag-o-matic eapi7-ver systemd autotools
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -224,6 +224,11 @@ src_prepare() {
sed -i "s~^include=.*$~include=${PHP_INI_DIR}/fpm.d/*.conf~" \
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
+
+ # Bug 669566 - necessary so that build tools are updated for commands like pecl
+ # Force rebuilding aclocal.m4
+ rm -f aclocal.m4 || die "failed to remove aclocal.m4 in src_prepare"
+ eautoreconf
}
src_configure() {