summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r2.ebuild')
-rw-r--r--dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r2.ebuild b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..6838bf02f21b
--- /dev/null
+++ b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Compatible alternative to the JDK serialization API"
+HOMEPAGE="http://jbossmarshalling.jboss.org/"
+SRC_URI="http://download.jboss.org/jbossmarshalling/${P}.CR9-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+CDEPEND="
+ dev-java/jboss-modules:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7"
+
+JAVA_GENTOO_CLASSPATH="jboss-modules"