summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gkeyfile-sharp')
-rw-r--r--dev-dotnet/gkeyfile-sharp/Manifest1
-rw-r--r--dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1.ebuild34
-rw-r--r--dev-dotnet/gkeyfile-sharp/metadata.xml9
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-dotnet/gkeyfile-sharp/Manifest b/dev-dotnet/gkeyfile-sharp/Manifest
new file mode 100644
index 000000000000..1bc418004756
--- /dev/null
+++ b/dev-dotnet/gkeyfile-sharp/Manifest
@@ -0,0 +1 @@
+DIST gkeyfile-sharp-0.1.tar.gz 19862 SHA256 21a8a7ebfd4cbc2495d2f917426768550fe9dc2dead0e570541dc6a33f181c3d SHA512 056bf88b8e1e4032be5d082f4f9fcb1eb00df0294cec6edea8117539b5f5c29fddf41b26a43ff7fadc370d10f0e53add968dfa4bd7763f130e140f45b7c21e9d WHIRLPOOL 91a3410a8a702cb54b0746c5ccb90ba3740b13ffab74f7f95bb0a8a1ed5f1b82d998a5eaa80a5c4f02bcd623338cec91e12d3ba3f4109aa14ec9adb2752ce3b9
diff --git a/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1.ebuild b/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1.ebuild
new file mode 100644
index 000000000000..50fa17c63e9f
--- /dev/null
+++ b/dev-dotnet/gkeyfile-sharp/gkeyfile-sharp-0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools mono
+
+DESCRIPTION="C# binding for gkeyfile"
+HOMEPAGE="http://launchpad.net/gkeyfile-sharp http://github.com/mono/gkeyfile-sharp"
+SRC_URI="http://github.com/mono/${PN}/tarball/GKEYFILE_SHARP_0_1 -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-dotnet/glib-sharp-2.12.9
+ >=dev-dotnet/gtk-sharp-gapi-1.9"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS
+}
diff --git a/dev-dotnet/gkeyfile-sharp/metadata.xml b/dev-dotnet/gkeyfile-sharp/metadata.xml
new file mode 100644
index 000000000000..de3b398a7b73
--- /dev/null
+++ b/dev-dotnet/gkeyfile-sharp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <upstream>
+ <remote-id type="github">mono/gkeyfile-sharp</remote-id>
+ <remote-id type="launchpad">gkeyfile-sharp</remote-id>
+ </upstream>
+</pkgmetadata>