summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/utimer')
-rw-r--r--app-misc/utimer/Manifest1
-rw-r--r--app-misc/utimer/metadata.xml18
-rw-r--r--app-misc/utimer/utimer-0.4.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/utimer/Manifest b/app-misc/utimer/Manifest
new file mode 100644
index 000000000000..2dadde178f9b
--- /dev/null
+++ b/app-misc/utimer/Manifest
@@ -0,0 +1 @@
+DIST utimer-0.4.tar.gz 144408 SHA256 07a9d28e15155a10b7e6b22af05c84c878d95be782b6b0afaadec2f7884aa0f7 SHA512 f1a375de4b4b5b0f478e208e055badb12a49524137cbd9626238bc5fc35cf3576e7a7c66759dd00a061d12dc7a0ad3ee6974abc8213f5f6f8e22c50eb2901032 WHIRLPOOL ca76a257ae83f8197c84dea7bae0ddaabc3847e82d1f868fd92fec65340cdc317582d553a912897d3743c9f913559018467ea40274a4e3dc26e5b3a9a47710c3
diff --git a/app-misc/utimer/metadata.xml b/app-misc/utimer/metadata.xml
new file mode 100644
index 000000000000..eaebd024bbfc
--- /dev/null
+++ b/app-misc/utimer/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<maintainer>
+<email>lavi.kfir@gmail.com</email>
+<name>Kfir Lavi</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-misc/utimer/utimer-0.4.ebuild b/app-misc/utimer/utimer-0.4.ebuild
new file mode 100644
index 000000000000..9feea5d8b5c3
--- /dev/null
+++ b/app-misc/utimer/utimer-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="A command line timer and stopwatch"
+HOMEPAGE="http://utimer.codealpha.net/utimer"
+SRC_URI="http://utimer.codealpha.net/dl.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug nls"
+
+DEPEND=">=dev-libs/glib-2.18.2
+ >=dev-util/intltool-0.40.5"
+RDEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=
+ if use debug; then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+ econf ${myconf} $(use_enable nls)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "failed to install"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}