summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/joe/files/joe-4.3-tinfo.patch30
-rw-r--r--app-editors/joe/joe-4.3-r1.ebuild (renamed from app-editors/joe/joe-4.3.ebuild)9
2 files changed, 38 insertions, 1 deletions
diff --git a/app-editors/joe/files/joe-4.3-tinfo.patch b/app-editors/joe/files/joe-4.3-tinfo.patch
new file mode 100644
index 000000000000..fd259e183fd0
--- /dev/null
+++ b/app-editors/joe/files/joe-4.3-tinfo.patch
@@ -0,0 +1,30 @@
+# HG changeset patch
+# User Lars Wendler <polynomial-c@gentoo.org>
+# Date 1473084371 -7200
+# Mon Sep 05 16:06:11 2016 +0200
+# Node ID ae8afbceeed4e446a63ad3111291a98d1390ade2
+# Parent 57c0a14aedcb8eef82d5828721b55aac02847ee7
+configure.ac: search for ncurses' tinfo library if available
+
+ncurses can be built to split out the lowlevel terminfo library
+from ncurses library. In this case there's a libtinfo.so file
+alongside the usual libncurses*.so files.
+This patch adds tinfo to AC_SEARCH_LIBS when ncurses support
+is enabled. Without this patch configure silently fails to find
+tgetflag and thus does not link to ncurses at all.
+I've tested this change on both, ncurses with separate tinfo lib
+and ncurses without separate tinfo lib and in both cases joe
+successfully links against ncurses.
+
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,7 +39,7 @@
+ curses=$enableval, curses=yes)
+
+ if test "$curses" = "yes"; then
+- search_libs="ncurses curses"
++ search_libs="tinfo ncurses curses"
+ fi
+
+ AC_ARG_ENABLE(termcap,
diff --git a/app-editors/joe/joe-4.3.ebuild b/app-editors/joe/joe-4.3-r1.ebuild
index c1aed9e73d33..446ac94c11d8 100644
--- a/app-editors/joe/joe-4.3.ebuild
+++ b/app-editors/joe/joe-4.3-r1.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit autotools
+
DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
HOMEPAGE="https://sourceforge.net/projects/joe-editor/"
SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
@@ -14,19 +16,24 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-
IUSE="xterm"
DEPEND=">=sys-libs/ncurses-5.2-r2:0="
-RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
+RDEPEND="${DEPEND}
+ xterm? ( >=x11-terms/xterm-239 )"
DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
+PATCHES=( "${FILESDIR}/${PN}-4.3-tinfo.patch" )
+
src_prepare() {
default
# Enable xterm mouse support in the rc files
if use xterm; then
cd "${S}"/rc || die
+ local i
for i in *rc*.in; do
sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die
done
fi
+ eautoreconf
}
pkg_postinst() {