summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-7.4.1583.ebuild')
-rw-r--r--app-editors/vim/vim-7.4.1583.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/app-editors/vim/vim-7.4.1583.ebuild b/app-editors/vim/vim-7.4.1583.ebuild
index d0e5706af1cf..d711d5e20a50 100644
--- a/app-editors/vim/vim-7.4.1583.ebuild
+++ b/app-editors/vim/vim-7.4.1583.ebuild
@@ -271,19 +271,7 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
- # We've got to call make test from within testdir, since the Makefiles
- # don't pass through our VIMPROG argument
- cd "${S}"/src/testdir
-
- # Test 49 won't work inside a portage environment
- einfo "Test 49 isn't sandbox-friendly, so it will be skipped."
- sed -i 's~test49.out~~g' Makefile
-
- # We don't want to rebuild vim before running the tests
- sed -i 's,: \$(VIMPROG),: ,' Makefile
-
- # Don't try to do the additional GUI test
- emake -j1 VIMPROG=../vim nongui
+ emake -j1 -C src/testdir nongui
}
# Make convenience symlinks, hopefully without stepping on toes. Some