summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gobby/gobby-0.4.13.ebuild')
-rw-r--r--app-editors/gobby/gobby-0.4.13.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/gobby/gobby-0.4.13.ebuild b/app-editors/gobby/gobby-0.4.13.ebuild
new file mode 100644
index 000000000000..5ada8e9de361
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="avahi gnome"
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/obby-0.4.6[avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --with-gtksourceview2 \
+ $(use_with gnome)
+}
+
+src_install() {
+ default
+ domenu contrib/gobby.desktop
+}