summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/scute/scute-1.5.0.ebuild')
-rw-r--r--app-crypt/scute/scute-1.5.0.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-crypt/scute/scute-1.5.0.ebuild b/app-crypt/scute/scute-1.5.0.ebuild
index 85adede2192a..9403b7ae9644 100644
--- a/app-crypt/scute/scute-1.5.0.ebuild
+++ b/app-crypt/scute/scute-1.5.0.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit ltprune
+EAPI=7
DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
HOMEPAGE="http://www.scute.org/"
@@ -12,18 +10,17 @@ SRC_URI="mirror://gnupg/scute/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
# configure script try to check the version of gpgsm and gpg-agent when
# non-crosscompiling so we need to have them as build-time dependency as
# well as runtime. Require a version of gnupg that is patched to have
# gpgsm-gencert.sh working (as that's what the documentation describe).
-DEPEND="
- >=dev-libs/libgpg-error-1.4
- >=dev-libs/libassuan-2.0.0
- >=app-crypt/pinentry-0.7.0
+BDEPEND=">=app-crypt/pinentry-0.7.0
>=app-crypt/gnupg-2.0.17-r1[smartcard]"
-RDEPEND="${DEPEND}"
+DEPEND=">=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0"
+RDEPEND="${DEPEND}
+ ${BDEPEND}"
src_configure() {
econf \
@@ -33,5 +30,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files --modules
+ find "${D}" -name '*.la' -delete || die
}