summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/diakonos/Manifest3
-rw-r--r--app-editors/diakonos/diakonos-0.9.4-r1.ebuild16
-rw-r--r--app-editors/diakonos/diakonos-0.9.7.ebuild37
-rw-r--r--eclass/python-utils-r1.eclass3
-rw-r--r--media-libs/mesa/mesa-21.3.4.ebuild2
-rw-r--r--media-sound/flacon/Manifest1
-rw-r--r--media-sound/flacon/flacon-5.5.1.ebuild4
-rw-r--r--media-sound/flacon/flacon-8.2.0.ebuild83
-rw-r--r--sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch50
-rw-r--r--sys-devel/mold/mold-1.0.1-r1.ebuild (renamed from sys-devel/mold/mold-1.0.1.ebuild)4
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.10.92.ebuild3
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.15.15.ebuild2
-rw-r--r--x11-libs/libva/libva-2.13.0-r2.ebuild2
-rw-r--r--x11-terms/tilda/Manifest1
-rw-r--r--x11-terms/tilda/tilda-1.5.4.ebuild32
15 files changed, 228 insertions, 15 deletions
diff --git a/app-editors/diakonos/Manifest b/app-editors/diakonos/Manifest
index 045292cca7c5..c7c6071fb661 100644
--- a/app-editors/diakonos/Manifest
+++ b/app-editors/diakonos/Manifest
@@ -1 +1,2 @@
-DIST diakonos-0.9.4.tar.bz2 102282 BLAKE2B f8625d87924815e816c2f5a07e5c1d35df4df6126531caf5c98a9fdcb20eb9543c028363344a3c20f2f8a0335fa9d071b168640d9bd4738b1d51737bcc548c12 SHA512 8aab6173c40b9a182853977ed7631c391a10d3339918fa96866da8c9fa8e36e40f1c5093465c734a9ce36a69c5d994d6b2d1c0306f1e57bff708fd7a64a62db7
+DIST diakonos-0.9.4.tar.gz 126301 BLAKE2B 197d32968053fe8b68f7e9909619f9be6548d1a32545d32c7cd4a9501f2df2635178ce681e6f77e9a1e0ea7f22fe80eed116239a1df655f3e3567e435d29dbad SHA512 c4737fa1de42549745b606bd881fbe7cff1e46517084142c10fe2a7076f25a6f7418d7aefbc569e3647bbdd04a185f07866021c24161f1675f11ecddde5d654c
+DIST diakonos-0.9.7.tar.gz 129807 BLAKE2B 26c3a72a00e1d41b4a7b2916b37024658d7607ac657d4f71a12b939830578d7939a4f9f4c3886693eae9eeaf91bfe1abe055be7bcc7681619448e298acb5c546 SHA512 ec23d93ed6871d18b6a91e02bc6916ac667ca773be5f093a68fffa5c9cbe89b123e80b18762c8649620eda23b1b9ba582a5236eb9eaefc0e22a411390cd30c73
diff --git a/app-editors/diakonos/diakonos-0.9.4-r1.ebuild b/app-editors/diakonos/diakonos-0.9.4-r1.ebuild
index 74fbd1888407..081eff7e66f0 100644
--- a/app-editors/diakonos/diakonos-0.9.4-r1.ebuild
+++ b/app-editors/diakonos/diakonos-0.9.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,8 +8,8 @@ USE_RUBY="ruby26 ruby27 ruby30"
inherit ruby-ng
DESCRIPTION="A Linux editor for the masses"
-HOMEPAGE="http://diakonos.pist0s.ca"
-SRC_URI="http://diakonos.pist0s.ca/archives/${P}.tar.bz2"
+HOMEPAGE="https://git.sr.ht/~pistos/diakonos"
+SRC_URI="https://github.com/Pistos/diakonos/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -21,8 +21,12 @@ ruby_add_rdepend "dev-ruby/curses"
ruby_add_bdepend "doc? ( dev-ruby/yard )
test? ( dev-ruby/bacon )"
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib spec/*.rb spec/*/*.rb || die
+}
+
each_ruby_install() {
- ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${P} || die "install failed"
+ ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${PF} || die "install failed"
}
all_ruby_install() {
@@ -31,7 +35,3 @@ all_ruby_install() {
dodoc -r doc/*
fi
}
-
-each_ruby_test() {
- ${RUBY} -S bacon -Ilib spec/*.rb spec/*/*.rb || die
-}
diff --git a/app-editors/diakonos/diakonos-0.9.7.ebuild b/app-editors/diakonos/diakonos-0.9.7.ebuild
new file mode 100644
index 000000000000..b656965ff4e8
--- /dev/null
+++ b/app-editors/diakonos/diakonos-0.9.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-ng
+
+DESCRIPTION="A Linux editor for the masses"
+HOMEPAGE="https://git.sr.ht/~pistos/diakonos"
+SRC_URI="https://github.com/Pistos/diakonos/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/curses"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rspec )"
+
+each_ruby_test() {
+ ${RUBY} -S rspec -Ilib spec/*.rb spec/*/*.rb || die
+}
+
+each_ruby_install() {
+ ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${PF} || die "install failed"
+}
+
+all_ruby_install() {
+ if use doc; then
+ rake docs || die
+ dodoc -r doc/*
+ fi
+}
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index aece257e8cba..85de8cb92182 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -1250,7 +1250,8 @@ build_sphinx() {
sed -i -e 's:^intersphinx_mapping:disabled_&:' \
"${dir}"/conf.py || die
# not all packages include the Makefile in pypi tarball
- sphinx-build -b html -d "${dir}"/_build/doctrees "${dir}" \
+ "${EPYTHON}" -m sphinx.cmd.build \
+ -b html -d "${dir}"/_build/doctrees "${dir}" \
"${dir}"/_build/html || die
HTML_DOCS+=( "${dir}/_build/html/." )
diff --git a/media-libs/mesa/mesa-21.3.4.ebuild b/media-libs/mesa/mesa-21.3.4.ebuild
index 6b273886b9d3..23157aa51f22 100644
--- a/media-libs/mesa/mesa-21.3.4.ebuild
+++ b/media-libs/mesa/mesa-21.3.4.ebuild
@@ -17,7 +17,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://archive.mesa3d.org/${MY_P}.tar.xz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="MIT"
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index 481e306c2b87..a862fd500a7f 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1 +1,2 @@
DIST flacon-5.5.1.tar.gz 2336502 BLAKE2B 524fe5fa28126f56452515ca1ce1572343dad8b06c28fc8e3a22a11e9ad8f3a51a25b3c19ddd29a7e3c658f1d7fb3316a2554a12a4ba3dd22370fc1394d38022 SHA512 36900b011135b61cf3cc1f05d94f852fc7e127972f3fed09e0fb7e66fec944ed1c3bfc61307494aff87c2fe24e16479605043a79e0634bc23940d01fc337c6c1
+DIST flacon-8.2.0.tar.gz 3757221 BLAKE2B dff0dc849c326a53ad167efea3106ca2d057121081822a821f2daa4cc2140a858960f1b4cdc2935f3e569aac25c25ceece2d171056788b9f541355c540457550 SHA512 9799c1a27426a2f67d782f15a3a1d210c5dc61b00b30b9c4143047a243f2d46cb0eb651c18919fa1ac2a8fdc2f54c83ec2e0b46a00254c908230e7ffb34965bc
diff --git a/media-sound/flacon/flacon-5.5.1.ebuild b/media-sound/flacon/flacon-5.5.1.ebuild
index ffc3d5f7fc6e..34c20012e82c 100644
--- a/media-sound/flacon/flacon-5.5.1.ebuild
+++ b/media-sound/flacon/flacon-5.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -62,7 +62,7 @@ src_configure() {
}
src_test() {
- virtx "${BUILD_DIR}/tests/${PN}_test"
+ virtx "${BUILD_DIR}/tests/${PN}_test" || die
}
pkg_postinst() {
diff --git a/media-sound/flacon/flacon-8.2.0.ebuild b/media-sound/flacon/flacon-8.2.0.ebuild
new file mode 100644
index 000000000000..c0da6cdb1ab8
--- /dev/null
+++ b/media-sound/flacon/flacon-8.2.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests require lots of disk space
+CHECKREQS_DISK_BUILD=10G
+inherit check-reqs cmake optfeature virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ virtual/pkgconfig
+ dev-qt/linguist-tools:5
+ media-libs/taglib
+"
+RDEPEND="
+ app-i18n/uchardet
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? (
+ dev-qt/qttest:5
+ media-libs/flac
+ media-sound/mac
+ media-sound/shntool
+ media-sound/ttaenc
+ media-sound/wavpack
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test" || die
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} optionally supports formats listed below."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch b/sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch
new file mode 100644
index 000000000000..429e55cc51a9
--- /dev/null
+++ b/sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch
@@ -0,0 +1,50 @@
+From cea6a569afa544826c91fda7ef0f9941f50c9459 Mon Sep 17 00:00:00 2001
+From: Rui Ueyama <ruiu@cs.stanford.edu>
+Date: Wed, 12 Jan 2022 16:31:04 +0900
+Subject: [PATCH] [ELF] Remove "GNU gold" from the --version string
+
+That substring was introduced in de7ba9014f9d9d70b9173c4bfac6c3433186ba49
+to appease Gentoo's dev-libs/jansson-2.13.1-r1 package. But I think I
+shouldn't done that from the beginning to avoid the sitaution of the
+"User-Agent" string of the web browser, which everybody claims they
+are Mozilla, AppleWebKit, Chrome and Safari simultaneously.
+---
+ main.cc | 4 ++--
+ test/elf/version.sh | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/main.cc b/main.cc
+index 38a41cdf..8831f7f2 100644
+--- a/main.cc
++++ b/main.cc
+@@ -26,10 +26,10 @@ std::string_view errno_string() {
+
+ #ifdef GIT_HASH
+ const std::string mold_version =
+- "mold " MOLD_VERSION " (" GIT_HASH "; compatible with GNU ld and GNU gold)";
++ "mold " MOLD_VERSION " (" GIT_HASH "; compatible with GNU ld)";
+ #else
+ const std::string mold_version =
+- "mold " MOLD_VERSION " (compatible with GNU ld and GNU gold)";
++ "mold " MOLD_VERSION " (compatible with GNU ld)";
+ #endif
+
+ void cleanup() {
+diff --git a/test/elf/version.sh b/test/elf/version.sh
+index ae52b504..4ca576ef 100755
+--- a/test/elf/version.sh
++++ b/test/elf/version.sh
+@@ -10,10 +10,10 @@ mold="$(pwd)/mold"
+ t=out/test/elf/$testname
+ mkdir -p $t
+
+-"$mold" -v | grep -q 'mold .*compatible with GNU ld and GNU gold'
+-"$mold" --version | grep -q 'mold .*compatible with GNU ld and GNU gold'
++"$mold" -v | grep -q 'mold .*compatible with GNU ld'
++"$mold" --version | grep -q 'mold .*compatible with GNU ld'
+
+-"$mold" -V | grep -q 'mold .*compatible with GNU ld and GNU gold'
++"$mold" -V | grep -q 'mold .*compatible with GNU ld'
+ "$mold" -V | grep -q elf_x86_64
+ "$mold" -V | grep -q elf_i386
+
diff --git a/sys-devel/mold/mold-1.0.1.ebuild b/sys-devel/mold/mold-1.0.1-r1.ebuild
index 9751b231a53f..e0cd2503b621 100644
--- a/sys-devel/mold/mold-1.0.1.ebuild
+++ b/sys-devel/mold/mold-1.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,8 @@ RDEPEND=">=dev-cpp/tbb-2021.4.0:=
)"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-no-gold-in-version.patch" )
+
src_prepare() {
default
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.92.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.92.ebuild
index 2a033bf8c0ea..98f0c8eaf074 100644
--- a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.92.ebuild
+++ b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.92.ebuild
@@ -76,6 +76,9 @@ src_prepare() {
cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
biendian=true
;;
+ hppa)
+ return
+ ;;
ppc)
# assume powermac/powerbook defconfig
# we still package.use.force savedconfig
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.15.15.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.15.15.ebuild
index 3da5419311e1..03539a92d62e 100644
--- a/sys-kernel/gentoo-kernel/gentoo-kernel-5.15.15.ebuild
+++ b/sys-kernel/gentoo-kernel/gentoo-kernel-5.15.15.ebuild
@@ -75,6 +75,8 @@ src_prepare() {
cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
biendian=true
;;
+ hppa)
+ ;;
ppc)
# assume powermac/powerbook defconfig
# we still package.use.force savedconfig
diff --git a/x11-libs/libva/libva-2.13.0-r2.ebuild b/x11-libs/libva/libva-2.13.0-r2.ebuild
index 0b4713a7d2b3..d79b9a0e29da 100644
--- a/x11-libs/libva/libva-2.13.0-r2.ebuild
+++ b/x11-libs/libva/libva-2.13.0-r2.ebuild
@@ -18,7 +18,7 @@ else
# To simplify updates, portage use tarballs without pre-build 'configure'
# which are always available.
SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"
diff --git a/x11-terms/tilda/Manifest b/x11-terms/tilda/Manifest
index d3c3f650a476..61d79a84567e 100644
--- a/x11-terms/tilda/Manifest
+++ b/x11-terms/tilda/Manifest
@@ -1 +1,2 @@
DIST tilda-1.5.2.tar.gz 485261 BLAKE2B 2ce0059ad695ac3e920cf8e40841b850967ff1e05b88a1c527b7154112c88a3435b66d0f31b882b6fdaf0dee038b7a7e6ab0401184ab701bed8d23d44a2856d8 SHA512 5f950696626005d6f8711fe1403313b36f065796ac07946e9782997aaf67a4bfdb3bfa5e37889bff95d77655d3546100a48327bfa175aa24c39a28685ee0306a
+DIST tilda-1.5.4.tar.gz 485611 BLAKE2B beced68e0712fdc3f4f46a1d839a87e91ecf7e84dec500908efa510d7b43d0c0bf6b5e296c3df255ea462cf08f5107aa324d5a0a6abb134917a054366912a068 SHA512 6982a14a89d148c04e08df0c7566ea7b3e340252fa1a3e434450443f7464e6805caee46afda9b385633a4b9c22d2f2d283641082a1e009f301c3a1bf508c3b29
diff --git a/x11-terms/tilda/tilda-1.5.4.ebuild b/x11-terms/tilda/tilda-1.5.4.ebuild
new file mode 100644
index 000000000000..8a62f1c1038e
--- /dev/null
+++ b/x11-terms/tilda/tilda-1.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse:=
+ gnome-base/libglade
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ append-cflags -std=c99
+ eautoreconf
+}