summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r1.ebuild2
-rw-r--r--dev-libs/nanomsg/nanomsg-1.1.5.ebuild2
-rw-r--r--dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild2
-rw-r--r--dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild2
-rw-r--r--dev-python/ws4py/ws4py-0.5.1-r1.ebuild2
-rw-r--r--eclass/python-utils-r1.eclass4
-rwxr-xr-xeclass/tests/python-utils-r1.sh16
-rw-r--r--media-tv/tvnamer/tvnamer-2.5.ebuild2
-rw-r--r--net-analyzer/sarg/sarg-2.4.0.ebuild2
-rw-r--r--net-proxy/torsocks/torsocks-2.3.0.ebuild4
-rw-r--r--profiles/base/package.use.force1
-rw-r--r--profiles/base/use.stable.mask7
-rw-r--r--profiles/desc/python_single_target.desc3
-rw-r--r--profiles/desc/python_targets.desc1
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.7_rc7.ebuild40
16 files changed, 77 insertions, 14 deletions
diff --git a/app-emacs/pymacs/pymacs-0.26-r1.ebuild b/app-emacs/pymacs/pymacs-0.26-r1.ebuild
index 4cf124e76ef2..c1468a077be2 100644
--- a/app-emacs/pymacs/pymacs-0.26-r1.ebuild
+++ b/app-emacs/pymacs/pymacs-0.26-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc"
BDEPEND="doc? (
diff --git a/dev-libs/nanomsg/nanomsg-1.1.5.ebuild b/dev-libs/nanomsg/nanomsg-1.1.5.ebuild
index 6dc699b6e733..06f2ea0e6c57 100644
--- a/dev-libs/nanomsg/nanomsg-1.1.5.ebuild
+++ b/dev-libs/nanomsg/nanomsg-1.1.5.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/nanomsg/nanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/5.0.0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
IUSE="doc static-libs"
DEPEND="doc? ( dev-ruby/asciidoctor )"
diff --git a/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild b/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild
index a2bc293f2095..c12a006c9b36 100644
--- a/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild
+++ b/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
inherit distutils-r1
diff --git a/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild b/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild
index 4b2690e43f55..e62156a7b6eb 100644
--- a/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild
+++ b/dev-python/tvdb_api/tvdb_api-2.0-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
index 3e590bb7984c..8fa2990a4f6a 100644
--- a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 arm ~x86"
+ KEYWORDS="amd64 arm ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 4af710da363b..1067d2367aba 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -41,7 +41,7 @@ inherit toolchain-funcs
_PYTHON_ALL_IMPLS=(
pypy3
python2_7
- python3_6 python3_7 python3_8
+ python3_6 python3_7 python3_8 python3_9
)
readonly _PYTHON_ALL_IMPLS
@@ -77,7 +77,7 @@ _python_impl_supported() {
# keep in sync with _PYTHON_ALL_IMPLS!
# (not using that list because inline patterns shall be faster)
case "${impl}" in
- python2_7|python3_[678]|pypy3)
+ python2_7|python3_[6789]|pypy3)
return 0
;;
jython2_7|pypy|pypy1_[89]|pypy2_0|python2_[56]|python3_[12345])
diff --git a/eclass/tests/python-utils-r1.sh b/eclass/tests/python-utils-r1.sh
index 192c1183e800..86b87ec173d4 100755
--- a/eclass/tests/python-utils-r1.sh
+++ b/eclass/tests/python-utils-r1.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -115,6 +115,20 @@ fi
test_var PYTHON_PKG_DEP python3_8 '*dev-lang/python*:3.8'
test_var PYTHON_SCRIPTDIR python3_8 /usr/lib/python-exec/python3.8
+test_var EPYTHON python3_9 python3.9
+test_var PYTHON python3_9 /usr/bin/python3.9
+if [[ -x /usr/bin/python3.9 ]]; then
+ abiflags=$(/usr/bin/python3.9 -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS"))')
+ test_var PYTHON_SITEDIR python3_9 "/usr/lib/python3.9/site-packages"
+ test_var PYTHON_INCLUDEDIR python3_9 "/usr/include/python3.9${abiflags}"
+ test_var PYTHON_LIBPATH python3_9 "/usr/lib*/libpython3.9${abiflags}$(get_libname)"
+ test_var PYTHON_CONFIG python3_9 "/usr/bin/python3.9${abiflags}-config"
+ test_var PYTHON_CFLAGS python3_9 "*-I/usr/include/python3.9*"
+ test_var PYTHON_LIBS python3_9 "*-lpython3.9*"
+fi
+test_var PYTHON_PKG_DEP python3_9 '*dev-lang/python*:3.9'
+test_var PYTHON_SCRIPTDIR python3_9 /usr/lib/python-exec/python3.9
+
test_var EPYTHON pypy3 pypy3
test_var PYTHON pypy3 /usr/bin/pypy3
if [[ -x /usr/bin/pypy3 ]]; then
diff --git a/media-tv/tvnamer/tvnamer-2.5.ebuild b/media-tv/tvnamer/tvnamer-2.5.ebuild
index ab7b93611eb4..71fde5142b53 100644
--- a/media-tv/tvnamer/tvnamer-2.5.ebuild
+++ b/media-tv/tvnamer/tvnamer-2.5.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE=""
RDEPEND=">=dev-python/tvdb_api-1.10_pre[${PYTHON_USEDEP}]"
diff --git a/net-analyzer/sarg/sarg-2.4.0.ebuild b/net-analyzer/sarg/sarg-2.4.0.ebuild
index 6fbc48405afe..e43d5055db4d 100644
--- a/net-analyzer/sarg/sarg-2.4.0.ebuild
+++ b/net-analyzer/sarg/sarg-2.4.0.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://sourceforge.net/projects/sarg/"
SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc ~x86"
SLOT="0"
IUSE="bzip2 doublecheck +gd +glob ldap lzma pcre zlib"
diff --git a/net-proxy/torsocks/torsocks-2.3.0.ebuild b/net-proxy/torsocks/torsocks-2.3.0.ebuild
index 185229c5cf7e..b160a25fa0d1 100644
--- a/net-proxy/torsocks/torsocks-2.3.0.ebuild
+++ b/net-proxy/torsocks/torsocks-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/dgoulet/torsocks/archive/v${MY_PV}.tar.gz -> ${MY_PF
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm ~x86"
IUSE="static-libs"
# We do not depend on tor which might be running on a different box
diff --git a/profiles/base/package.use.force b/profiles/base/package.use.force
index 713a937d8c76..d266201073f1 100644
--- a/profiles/base/package.use.force
+++ b/profiles/base/package.use.force
@@ -127,6 +127,7 @@ dev-lang/python-exec python_targets_python2_7
dev-lang/python-exec python_targets_python3_6
dev-lang/python-exec python_targets_python3_7
dev-lang/python-exec python_targets_python3_8
+dev-lang/python-exec python_targets_python3_9
dev-lang/python-exec python_targets_pypy3
# Zac Medico <zmedico@gentoo.org> (2010-10-20)
diff --git a/profiles/base/use.stable.mask b/profiles/base/use.stable.mask
index 3d7804a385c6..a8422351f10a 100644
--- a/profiles/base/use.stable.mask
+++ b/profiles/base/use.stable.mask
@@ -1,9 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Michał Górny <mgorny@gentoo.org> (2020-05-25)
+# Python 3.9 is not yet stable.
+python_targets_python3_9
+python_single_target_python3_9
+
# Sergei Trofimovich <slyfox@gentoo.org> (2020-04-13)
# dev-vcs/darcs (dev-lang/ghc) has no stable keywords.
darcs
diff --git a/profiles/desc/python_single_target.desc b/profiles/desc/python_single_target.desc
index 6f8f16d8d04f..8101fce1ec74 100644
--- a/profiles/desc/python_single_target.desc
+++ b/profiles/desc/python_single_target.desc
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors.
+# Copyright 1999-2020 Gentoo Authors.
# Distributed under the terms of the GNU General Public License v2
# This file contains descriptions of PYTHON_SINGLE_TARGET USE_EXPAND flags.
@@ -7,4 +7,5 @@ python2_7 - Build for Python 2.7 only
python3_6 - Build for Python 3.6 only
python3_7 - Build for Python 3.7 only
python3_8 - Build for Python 3.8 only
+python3_9 - Build for Python 3.9 only
pypy3 - Build for PyPy3 only
diff --git a/profiles/desc/python_targets.desc b/profiles/desc/python_targets.desc
index 7823e2baa42f..da103c797788 100644
--- a/profiles/desc/python_targets.desc
+++ b/profiles/desc/python_targets.desc
@@ -7,4 +7,5 @@ python2_7 - Build with Python 2.7
python3_6 - Build with Python 3.6
python3_7 - Build with Python 3.7
python3_8 - Build with Python 3.8
+python3_9 - Build with Python 3.9
pypy3 - Build with PyPy3
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index bd49f72734fe..29f1f2baecf7 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.7-rc3.patch 40283173 BLAKE2B c8f85c4a52156d6590f60464ceba4144fa7562
DIST patch-5.7-rc4.patch 40402513 BLAKE2B 26fa667e2e82320e77de13700dce3886ee489db699499eec84292a0afbfa6da020ef8bf68993ae555854a935172c50d059e9f424f45ba3a628fafe0c1cde2d15 SHA512 da1f23765c7b5ef0a35b5de736e95446d7c96a5771346d5fbded526d2c46bc5c8387f7601ed92eebb29cb4c1614f39c1360d94666d2b0c0869b0bb22cd68ee5e
DIST patch-5.7-rc5.patch 40659677 BLAKE2B 0239c4ad1f98d474437ef1d8b80f19d52bd4bf1a162da8672a036adc10b35c77bc55ed76846716bdf377b8dab47c91fb4e786bdf76fae94bac3eedff49dcc3c6 SHA512 9160d419bbad331504178882197ba3680a38b01f638182631f169ec76130eaebae0a96a8370c74199159ebac5ce65cd369ea9d608621bbe6f9ce4005f37c4693
DIST patch-5.7-rc6.patch 40941449 BLAKE2B bda4907916ae77783683f40b06baa98af3f5472d911d5b28161f12367f7fc091d0a94ae1c7a6849a9c82074a417250827924e240809846918b859225e684f36b SHA512 ec835559a4d9873037f1287b85a454d4da8f890a80d24407d859d1f3d112808685f81b71c12828cc7ba558fd45d430d9f091773d0df1a5d48467fe9a5129a823
+DIST patch-5.7-rc7.patch 41149748 BLAKE2B 41a557a282a4285e6b76e59f66e76c8286b5d904cb78aefd71c7a1d3ecea729f2c10e0f4e89827cf726eba7ccd6966ec2c528f6183c3147b3707f24b5bdbceee SHA512 f659ffc71ea8c50f37716d2e894c39b927f97ae071e423abf8804bcdaf856444ade2c645aefbb9e4dd8012810050a1555945cc8d8b9f49949ebf0f1eefcf9905
diff --git a/sys-kernel/git-sources/git-sources-5.7_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.7_rc7.ebuild
new file mode 100644
index 000000000000..73b080b1d066
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.7_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.6"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}