summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyzmq/pyzmq-26.0.0.ebuild7
-rw-r--r--eclass/distutils-r1.eclass49
-rw-r--r--sys-kernel/git-sources/Manifest2
-rw-r--r--sys-kernel/git-sources/git-sources-6.9_rc4.ebuild2
4 files changed, 54 insertions, 6 deletions
diff --git a/dev-python/pyzmq/pyzmq-26.0.0.ebuild b/dev-python/pyzmq/pyzmq-26.0.0.ebuild
index e360778f49ba..2107def1855c 100644
--- a/dev-python/pyzmq/pyzmq-26.0.0.ebuild
+++ b/dev-python/pyzmq/pyzmq-26.0.0.ebuild
@@ -54,10 +54,9 @@ distutils_enable_tests pytest
# dev-python/myst-parser
src_configure() {
- export ZMQ_DRAFT_API=$(usex drafts '1' '0')
-
- # TODO: remove this when we update the eclass
- export SKBUILD_INSTALL_STRIP=false
+ DISTUTILS_ARGS=(
+ -DZMQ_DRAFT_API="$(usex drafts)"
+ )
}
src_test() {
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 7a314673a90b..a67122a59a33 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -448,6 +448,15 @@ unset -f _distutils_set_globals
# An array containing options to be passed to the build system.
# Supported by a subset of build systems used by the eclass.
#
+# For maturin, the arguments will be passed as `maturin build`
+# arguments.
+#
+# For meson-python, the arguments will be passed as `meson setup`
+# arguments.
+#
+# For scikit-build-core, the arguments will be passed as `cmake`
+# options (e.g. `-DFOO=BAR` form should be used).
+#
# For setuptools, the arguments will be passed as first parameters
# to setup.py invocations (via esetup.py), as well as to the PEP517
# backend. For future compatibility, only global options should be used
@@ -1406,6 +1415,46 @@ distutils_pep517_install() {
EOF
)
;;
+ scikit-build-core)
+ # TODO: split out the config/toolchain logic from cmake.eclass
+ # for now, we copy the most important bits
+ local CMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE:-RelWithDebInfo}
+ cat >> "${BUILD_DIR}"/config.cmake <<- _EOF_ || die
+ set(CMAKE_ASM_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_ASM-ATT_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_C_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_CXX_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_Fortran_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_EXE_LINKER_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_MODULE_LINKER_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_SHARED_LINKER_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ set(CMAKE_STATIC_LINKER_FLAGS_${CMAKE_BUILD_TYPE^^} "" CACHE STRING "")
+ _EOF_
+
+ # hack around CMake ignoring CPPFLAGS
+ local -x CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ local -x CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}"
+
+ local cmake_args=(
+ "-C${BUILD_DIR}/config.cmake"
+ "${DISTUTILS_ARGS[@]}"
+ )
+
+ # NB: we need to pass strings for boolean fields
+ # https://github.com/scikit-build/scikit-build-core/issues/707
+ config_settings=$(
+ "${EPYTHON}" - "${cmake_args[@]}" <<-EOF || die
+ import json
+ import sys
+ print(json.dumps({
+ "cmake.args": ";".join(sys.argv[1:]),
+ "cmake.build-type": "${CMAKE_BUILD_TYPE}",
+ "cmake.verbose": "true",
+ "install.strip": "false",
+ }))
+ EOF
+ )
+ ;;
setuptools)
if in_iuse debug && use debug; then
local -x SETUPTOOLS_RUST_CARGO_PROFILE=dev
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index f38d3d5a0b96..674eba8f5eac 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,2 @@
-DIST linux-6.8.tar.xz 142502100 BLAKE2B c6f17f816cea16e629f63e9379b98888713f57b2c5173306926471f139a9d612a0c74e119341f8075390e55e203d787d9edeb4ad5a064b18870f6f0f7ffaafb2 SHA512 5c4eb4aa1d3f7d1ea01c0f7ddeadacdece6e144fd4bdfc16b2b925d3e10dc04de3a6db69320b79a96c3560052616f001d2c09e7a1bb4f7b731e2380a7ecce068
+DIST linux-6.7.tar.xz 141406528 BLAKE2B cecdbd19905e43e485ab73b352ced18b37f2a138c97a6956cadcda5d3d271001117dc1cf896b166ff019fc7f405f9539e2ed0d6112b0890efb04d182adf4fd0e SHA512 de06de556191614bd9daf077ae239360352a402bab407748e67f1e5108c92fd933e451707840ab22fe0f9976db3d1e1b60ca9d41cf894f015ca09b3f652b74ad
DIST patch-6.9-rc4.patch 97385879 BLAKE2B 3e3a0020a0269a1a5b8509f0807e90b2c4a68dc959cba08b7f9074f561ea62f37880d176240d51b663c706c57b7edd95b22c7d62115fd1ff0328d524d3756e44 SHA512 642f01cac43ba541eb0899a6121d92d99239f7360cab2e3683e955b593f3ce5a12b6d149e0da19ef0bf0e23105cb7c334a00bedafe99e647245d786246d5a50d
diff --git a/sys-kernel/git-sources/git-sources-6.9_rc4.ebuild b/sys-kernel/git-sources/git-sources-6.9_rc4.ebuild
index 7068b44f8f6d..ca760a458b08 100644
--- a/sys-kernel/git-sources/git-sources-6.9_rc4.ebuild
+++ b/sys-kernel/git-sources/git-sources-6.9_rc4.ebuild
@@ -7,7 +7,7 @@ K_NOUSENAME="yes"
K_NOSETEXTRAVERSION="yes"
K_NOUSEPR="yes"
K_SECURITY_UNSUPPORTED="1"
-K_BASE_VER="6.8"
+K_BASE_VER="6.7"
K_EXP_GENPATCHES_NOUSE="1"
K_FROM_GIT="yes"
K_NODRYRUN="yes"