summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index e646ee963668..238ca161ff34 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ RDEPEND="
sys-apps/diffutils
sys-apps/file
sys-apps/portage
- sys-apps/util-linux"
+ || ( sys-apps/util-linux app-misc/getopt )"
BDEPEND="
sys-apps/help2man
test? ( ${RDEPEND} )"
@@ -34,6 +34,8 @@ src_configure() {
$(meson_use test)
)
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
meson_src_configure
}