summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild
index 8fd1209bd490..269cb352cf1f 100644
--- a/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild
+++ b/app-crypt/dieharder/dieharder-3.31.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,6 +37,10 @@ pkg_setup() {
)
}
+src_configure() {
+ econf --disable-static
+}
+
src_compile() {
emake -j1
use doc && emake -C manual
@@ -53,4 +57,6 @@ src_install() {
dodoc dieharder/README dieharder/NOTES
docinto "libdieharder"
dodoc libdieharder/README libdieharder/NOTES
+
+ find "${ED}" -name '*.la' -delete || die
}