summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/distutils-r1.eclass10
-rw-r--r--eclass/python-utils-r1.eclass64
-rw-r--r--media-gfx/cropgui/cropgui-0.1.1-r3.ebuild4
-rw-r--r--media-gfx/cropgui/cropgui-0.2.ebuild2
-rw-r--r--media-gfx/cropgui/cropgui-9999.ebuild2
-rw-r--r--net-im/err/err-1.7.1-r1.ebuild4
-rw-r--r--net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild4
-rw-r--r--net-p2p/pybitmessage/pybitmessage-0.4.3-r1.ebuild4
-rw-r--r--net-p2p/pybitmessage/pybitmessage-0.4.3.ebuild4
-rw-r--r--net-p2p/pybitmessage/pybitmessage-0.4.4.ebuild4
-rw-r--r--net-p2p/pybitmessage/pybitmessage-9999.ebuild4
-rw-r--r--sys-libs/libapparmor/libapparmor-2.10.ebuild2
-rw-r--r--sys-libs/libsmbios/libsmbios-2.2.28.ebuild4
-rw-r--r--sys-libs/libsmbios/libsmbios-2.3.0-r1.ebuild2
14 files changed, 52 insertions, 62 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 7965e9106a49..e8de5ad6c4eb 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -588,9 +588,11 @@ distutils-r1_python_install_all() {
if declare -p EXAMPLES &>/dev/null; then
[[ ${EAPI} != [45] ]] && die "EXAMPLES are banned in EAPI ${EAPI}"
- local INSDESTTREE=/usr/share/doc/${PF}/examples
- doins -r "${EXAMPLES[@]}"
- docompress -x "${INSDESTTREE}"
+ (
+ docinto examples
+ dodoc -r "${EXAMPLES[@]}"
+ )
+ docompress -x "/usr/share/doc/${PF}/examples"
fi
_DISTUTILS_DEFAULT_CALLED=1
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 9488966a9941..468eff126ef3 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -651,32 +651,23 @@ python_optimize() {
done
}
-# @ECLASS-VARIABLE: python_scriptroot
-# @DEFAULT_UNSET
+# @FUNCTION: python_scriptinto
+# @USAGE: <new-path>
# @DESCRIPTION:
-# The current script destination for python_doscript(). The path
-# is relative to the installation root (${ED}).
+# Set the directory to which files passed to python_doexe(),
+# python_doscript(), python_newexe() and python_newscript()
+# are going to be installed. The new value needs to be relative
+# to the installation root (${ED}).
#
-# When unset, ${DESTTREE}/bin (/usr/bin by default) will be used.
-#
-# Can be set indirectly through the python_scriptinto() function.
+# If not set explicitly, the directory defaults to /usr/bin.
#
# Example:
# @CODE
# src_install() {
-# local python_scriptroot=${GAMES_BINDIR}
+# python_scriptinto /usr/sbin
# python_foreach_impl python_doscript foo
# }
# @CODE
-
-# @FUNCTION: python_scriptinto
-# @USAGE: <new-path>
-# @DESCRIPTION:
-# Set the current scriptroot. The new value will be stored
-# in the 'python_scriptroot' environment variable. The new value need
-# be relative to the installation root (${ED}).
-#
-# Alternatively, you can set the variable directly.
python_scriptinto() {
debug-print-function ${FUNCNAME} "${@}"
@@ -686,7 +677,7 @@ python_scriptinto() {
# @FUNCTION: python_doexe
# @USAGE: <files>...
# @DESCRIPTION:
-# Install the given executables into current python_scriptroot,
+# Install the given executables into the executable install directory,
# for the current Python implementation (${EPYTHON}).
#
# The executable will be wrapped properly for the Python implementation,
@@ -703,7 +694,7 @@ python_doexe() {
# @FUNCTION: python_newexe
# @USAGE: <path> <new-name>
# @DESCRIPTION:
-# Install the given executable into current python_scriptroot,
+# Install the given executable into the executable install directory,
# for the current Python implementation (${EPYTHON}).
#
# The executable will be wrapped properly for the Python implementation,
@@ -718,7 +709,7 @@ python_newexe() {
die "python_do* and python_new* helpers are banned in EAPIs older than 4."
fi
- local wrapd=${python_scriptroot:-${DESTTREE}/bin}
+ local wrapd=${python_scriptroot:-/usr/bin}
local f=${1}
local newfn=${2}
@@ -746,7 +737,7 @@ python_newexe() {
# @FUNCTION: python_doscript
# @USAGE: <files>...
# @DESCRIPTION:
-# Install the given scripts into current python_scriptroot,
+# Install the given scripts into the executable install directory,
# for the current Python implementation (${EPYTHON}).
#
# All specified files must start with a 'python' shebang. The shebang
@@ -769,7 +760,7 @@ python_doscript() {
# @FUNCTION: python_newscript
# @USAGE: <path> <new-name>
# @DESCRIPTION:
-# Install the given script into current python_scriptroot
+# Install the given script into the executable install directory
# for the current Python implementation (${EPYTHON}), and name it
# <new-name>.
#
@@ -790,30 +781,27 @@ python_newscript() {
python_newexe "${@}"
}
-# @ECLASS-VARIABLE: python_moduleroot
-# @DEFAULT_UNSET
+# @FUNCTION: python_moduleinto
+# @USAGE: <new-path>
# @DESCRIPTION:
-# The current module root for python_domodule(). The path can be either
-# an absolute system path (it must start with a slash, and ${ED} will be
-# prepended to it) or relative to the implementation's site-packages directory
-# (then it must start with a non-slash character).
+# Set the Python module install directory for python_domodule().
+# The <new-path> can either be an absolute target system path (in which
+# case it needs to start with a slash, and ${ED} will be prepended to
+# it) or relative to the implementation's site-packages directory
+# (then it must not start with a slash).
#
-# When unset, the modules will be installed in the site-packages root.
-#
-# Can be set indirectly through the python_moduleinto() function.
+# When not set explicitly, the modules are installed to the top
+# site-packages directory.
#
# Example:
# @CODE
# src_install() {
-# local python_moduleroot=bar
+# python_moduleinto bar
# # installs ${PYTHON_SITEDIR}/bar/baz.py
# python_foreach_impl python_domodule baz.py
# }
# @CODE
-# @FUNCTION: python_moduleinto
-# @USAGE: <new-path>
-# @DESCRIPTION:
# Set the current module root. The new value will be stored
# in the 'python_moduleroot' environment variable. The new value need
# be relative to the site-packages root.
@@ -828,8 +816,8 @@ python_moduleinto() {
# @FUNCTION: python_domodule
# @USAGE: <files>...
# @DESCRIPTION:
-# Install the given modules (or packages) into the current
-# python_moduleroot. The list can mention both modules (files)
+# Install the given modules (or packages) into the current Python module
+# installation directory. The list can mention both modules (files)
# and packages (directories). All listed files will be installed
# for all enabled implementations, and compiled afterwards.
#
diff --git a/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild b/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild
index d942d5245540..eecb991b98e2 100644
--- a/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild
+++ b/media-gfx/cropgui/cropgui-0.1.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -45,7 +45,7 @@ install_cropgui_wrapper() {
}
src_install() {
- local python_moduleroot="${PN}"
+ python_moduleinto "${PN}"
python_foreach_impl install_cropgui_wrapper
domenu "${PN}.desktop"
diff --git a/media-gfx/cropgui/cropgui-0.2.ebuild b/media-gfx/cropgui/cropgui-0.2.ebuild
index 912767d9ac15..7197fbb88860 100644
--- a/media-gfx/cropgui/cropgui-0.2.ebuild
+++ b/media-gfx/cropgui/cropgui-0.2.ebuild
@@ -44,7 +44,7 @@ install_cropgui_wrapper() {
}
src_install() {
- local python_moduleroot="${PN}"
+ python_moduleinto "${PN}"
python_foreach_impl install_cropgui_wrapper
domenu "${PN}.desktop"
diff --git a/media-gfx/cropgui/cropgui-9999.ebuild b/media-gfx/cropgui/cropgui-9999.ebuild
index ac8de05757e9..7294532973f8 100644
--- a/media-gfx/cropgui/cropgui-9999.ebuild
+++ b/media-gfx/cropgui/cropgui-9999.ebuild
@@ -42,7 +42,7 @@ install_cropgui_wrapper() {
}
src_install() {
- local python_moduleroot="${PN}"
+ python_moduleinto "${PN}"
python_foreach_impl install_cropgui_wrapper
domenu "${PN}.desktop"
diff --git a/net-im/err/err-1.7.1-r1.ebuild b/net-im/err/err-1.7.1-r1.ebuild
index 158cc5b670c5..92f8103abf82 100644
--- a/net-im/err/err-1.7.1-r1.ebuild
+++ b/net-im/err/err-1.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -86,7 +86,7 @@ python_install() {
# Upstream requires images to be in site-packages directory,
# but does not install them at all!
if use qt4; then
- local python_moduleroot=errbot
+ python_moduleinto errbot
python_domodule errbot/*.svg
fi
}
diff --git a/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild b/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild
index 294d83eb0e4b..41a564948a3c 100644
--- a/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild
+++ b/net-p2p/pybitmessage/pybitmessage-0.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -41,7 +41,7 @@ src_install () {
touch src/__init__.py || die
install_python() {
- local python_moduleroot=${PN}
+ python_moduleinto ${PN}
python_domodule src/*
sed \
-e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
diff --git a/net-p2p/pybitmessage/pybitmessage-0.4.3-r1.ebuild b/net-p2p/pybitmessage/pybitmessage-0.4.3-r1.ebuild
index 590563099109..a301784045c4 100644
--- a/net-p2p/pybitmessage/pybitmessage-0.4.3-r1.ebuild
+++ b/net-p2p/pybitmessage/pybitmessage-0.4.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -42,7 +42,7 @@ src_install () {
touch src/__init__.py || die
install_python() {
- local python_moduleroot=${PN}
+ python_moduleinto ${PN}
python_domodule src/*
sed \
-e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
diff --git a/net-p2p/pybitmessage/pybitmessage-0.4.3.ebuild b/net-p2p/pybitmessage/pybitmessage-0.4.3.ebuild
index 245d6fce20df..cc21cd0b6b68 100644
--- a/net-p2p/pybitmessage/pybitmessage-0.4.3.ebuild
+++ b/net-p2p/pybitmessage/pybitmessage-0.4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -41,7 +41,7 @@ src_install () {
touch src/__init__.py || die
install_python() {
- local python_moduleroot=${PN}
+ python_moduleinto ${PN}
python_domodule src/*
sed \
-e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
diff --git a/net-p2p/pybitmessage/pybitmessage-0.4.4.ebuild b/net-p2p/pybitmessage/pybitmessage-0.4.4.ebuild
index 782c2ced4640..417dba2899da 100644
--- a/net-p2p/pybitmessage/pybitmessage-0.4.4.ebuild
+++ b/net-p2p/pybitmessage/pybitmessage-0.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -42,7 +42,7 @@ src_install () {
touch src/__init__.py || die
install_python() {
- local python_moduleroot=${PN}
+ python_moduleinto ${PN}
python_domodule src/*
sed \
-e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
diff --git a/net-p2p/pybitmessage/pybitmessage-9999.ebuild b/net-p2p/pybitmessage/pybitmessage-9999.ebuild
index b994ca0be33f..de77f5df75c5 100644
--- a/net-p2p/pybitmessage/pybitmessage-9999.ebuild
+++ b/net-p2p/pybitmessage/pybitmessage-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,7 +40,7 @@ src_install () {
touch src/__init__.py || die
install_python() {
- local python_moduleroot=${PN}
+ python_moduleinto ${PN}
python_domodule src/*
sed \
-e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
diff --git a/sys-libs/libapparmor/libapparmor-2.10.ebuild b/sys-libs/libapparmor/libapparmor-2.10.ebuild
index 27712a36999d..98389569bc66 100644
--- a/sys-libs/libapparmor/libapparmor-2.10.ebuild
+++ b/sys-libs/libapparmor/libapparmor-2.10.ebuild
@@ -81,7 +81,7 @@ src_install() {
pushd "${BUILD_DIR}"/swig/python > /dev/null
distutils-r1_src_install
- python_moduleroot=LibAppArmor
+ python_moduleinto LibAppArmor
python_foreach_impl python_domodule __init__.py
popd > /dev/null
fi
diff --git a/sys-libs/libsmbios/libsmbios-2.2.28.ebuild b/sys-libs/libsmbios/libsmbios-2.2.28.ebuild
index ff0f7971baca..56616702c6ef 100644
--- a/sys-libs/libsmbios/libsmbios-2.2.28.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.2.28.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -67,7 +67,7 @@ src_install() {
rmdir "${D}libsmbios_c" "${D}usr/share/smbios-utils"
rm -rf "${D}etc"
else
- local python_scriptroot="/usr/sbin"
+ python_scriptinto /usr/sbin
python_doscript "${D}"/usr/sbin/smbios-{lcd-brightness,passwd,rbu-bios-update,sys-info,token-ctl,wakeup-ctl,wireless-ctl}
fi
diff --git a/sys-libs/libsmbios/libsmbios-2.3.0-r1.ebuild b/sys-libs/libsmbios/libsmbios-2.3.0-r1.ebuild
index 08e83cb58e4e..1a5f971da32b 100644
--- a/sys-libs/libsmbios/libsmbios-2.3.0-r1.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.3.0-r1.ebuild
@@ -65,7 +65,7 @@ src_install() {
emake install DESTDIR="${D}"
if use python ; then
- local python_scriptroot="/usr/sbin"
+ python_scriptinto /usr/sbin
python_doscript "${ED%/}"/usr/sbin/smbios-{{keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,rbu-bios-update,sys-info}
fi