summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tomli/Manifest1
-rw-r--r--dev-python/tomli/tomli-1.2.2-r1.ebuild36
-rw-r--r--eclass/distutils-r1.eclass2
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/tomli/Manifest b/dev-python/tomli/Manifest
index cfc848795383..785588630253 100644
--- a/dev-python/tomli/Manifest
+++ b/dev-python/tomli/Manifest
@@ -1,2 +1,3 @@
DIST tomli-1.2.1.gh.tar.gz 122701 BLAKE2B d0280bb81a6e931a175c6ef2c58b4f36b1237f99a73331cbb95f98b9e68a98a4c6a635aa12751ac46492c2b1a06a821f1ae70cd0c36f268998488e824f3e577c SHA512 34f9529b137331b0ae03ac99170b3f6509847356594be14166bae306ea4fbbddff808ffe0c48d05434f72d223a2f35b511675217053029d287725b7142fbd089
+DIST tomli-1.2.2-py3-none-any.whl.zip 12118 BLAKE2B ae1dbc14e3c7c79240a327f3fb622c16aeba561274aedc93957549d838fcb2b6ed5889f8c28344a4cc9dbb52eacd6b9dc53aeff8f08642a8abeed2dd67c989a1 SHA512 fb9452663a46760ea442f2f06ad2f60b094368680dae315c2386457041f3ac5399c196ceec0524d432442ec72158c2d95bfa5d0cc288163b4eb1d6a07a62ae36
DIST tomli-1.2.2.gh.tar.gz 123150 BLAKE2B b07527a2a83615030037867c6011440a3814cbe265e8a760cca08e324954dbf7d1a393bc900559ddfc1bcbe1911f758948051823d9ef830ee05abb2539374dff SHA512 460ad8ae9a342d82ef12911c0d0e246c1434a5d40d898e91f6c05bf37b7bf9921da05e004c36907d623a797a7a215c1c3faf3f9a2b940f3867b142847a188605
diff --git a/dev-python/tomli/tomli-1.2.2-r1.ebuild b/dev-python/tomli/tomli-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..d05ada7dc1af
--- /dev/null
+++ b/dev-python/tomli/tomli-1.2.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+ -> ${P}-py3-none-any.whl.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ app-arch/unzip
+ test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_install() {
+ python_domodule tomli "${WORKDIR}"/*.dist-info
+}
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 3513a74c4db4..46253759b1dc 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -610,6 +610,8 @@ _distutils-r1_disable_ez_setup() {
# @DESCRIPTION:
# Generate setup.py for pyproject.toml if requested.
_distutils-r1_handle_pyproject_toml() {
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
+
if [[ ! -f setup.py && -f pyproject.toml ]]; then
if [[ ${DISTUTILS_USE_SETUPTOOLS} != pyproject.toml ]]; then
eerror "No setup.py found but pyproject.toml is present. In order to enable"