summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/BitVector/BitVector-3.5.0.ebuild5
-rw-r--r--dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild5
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.27.12.ebuild2
-rw-r--r--dev-python/ajsonrpc/ajsonrpc-1.2.0.ebuild3
-rw-r--r--dev-python/aniso8601/aniso8601-9.0.1-r1.ebuild21
-rw-r--r--dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild29
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild16
-rw-r--r--dev-python/argh/argh-0.26.2-r3.ebuild29
-rw-r--r--dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild2
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.5.1.ebuild13
-rw-r--r--dev-python/asteval/asteval-0.9.26.ebuild2
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.4.ebuild8
-rw-r--r--dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild2
-rw-r--r--dev-python/zope-hookable/zope-hookable-5.1.0.ebuild2
-rw-r--r--dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.1-r2.ebuild2
15 files changed, 117 insertions, 24 deletions
diff --git a/dev-python/BitVector/BitVector-3.5.0.ebuild b/dev-python/BitVector/BitVector-3.5.0.ebuild
index f55f024cf238..15e2e2f9a775 100644
--- a/dev-python/BitVector/BitVector-3.5.0.ebuild
+++ b/dev-python/BitVector/BitVector-3.5.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
diff --git a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
index ec77d48706e2..3b724023f8ae 100644
--- a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
+++ b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
diff --git a/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild b/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild
index 0314e035bd9b..e77867c450d2 100644
--- a/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild
+++ b/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
diff --git a/dev-python/ajsonrpc/ajsonrpc-1.2.0.ebuild b/dev-python/ajsonrpc/ajsonrpc-1.2.0.ebuild
index 8b0a83075bdb..f2e894750fbd 100644
--- a/dev-python/ajsonrpc/ajsonrpc-1.2.0.ebuild
+++ b/dev-python/ajsonrpc/ajsonrpc-1.2.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Async JSON-RPC 2.0 protocol + server powered by asyncio"
diff --git a/dev-python/aniso8601/aniso8601-9.0.1-r1.ebuild b/dev-python/aniso8601/aniso8601-9.0.1-r1.ebuild
new file mode 100644
index 000000000000..f979167cba93
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-9.0.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
diff --git a/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..ceb39bf7b7df
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
+ # pypi tars don't include tests and github repo is missing release tags,
+ # so only enabling tests for 9999 at this time
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
index d678863551e3..ceb39bf7b7df 100644
--- a/dev-python/ansicolor/ansicolor-9999.ebuild
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
# pypi tars don't include tests and github repo is missing release tags,
# so only enabling tests for 9999 at this time
- distutils_enable_tests pytest
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,3 +25,5 @@ HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansico
LICENSE="Apache-2.0"
SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/dev-python/argh/argh-0.26.2-r3.ebuild b/dev-python/argh/argh-0.26.2-r3.ebuild
new file mode 100644
index 000000000000..c5f41e33c34b
--- /dev/null
+++ b/dev-python/argh/argh-0.26.2-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="https://pythonhosted.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.9-msgs.patch"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild b/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild
index 117a0c622869..2bb33f22881a 100644
--- a/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild
+++ b/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="Low-level CFFI bindings for the Argon2 password hashing library"
diff --git a/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild b/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
index 5c86d5eeda76..c8557a4efc04 100644
--- a/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
+++ b/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
@@ -4,15 +4,20 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
-HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
-# pypi tarball does not have tests
-SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/wbond/asn1crypto/
+ https://pypi.org/project/asn1crypto/
+"
+SRC_URI="
+ https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
diff --git a/dev-python/asteval/asteval-0.9.26.ebuild b/dev-python/asteval/asteval-0.9.26.ebuild
index ce77acf316e6..753aecd981d7 100644
--- a/dev-python/asteval/asteval-0.9.26.ebuild
+++ b/dev-python/asteval/asteval-0.9.26.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Evaluator of Python expression using ast module"
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.4.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.4.ebuild
index 91515a83ee60..c1603924e233 100644
--- a/dev-python/asyncstdlib/asyncstdlib-3.10.4.ebuild
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.4.ebuild
@@ -4,17 +4,19 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="The missing async toolbox"
HOMEPAGE="
https://github.com/maxfischer2781/asyncstdlib/
- https://pypi.org/project/asyncstdlib/"
+ https://pypi.org/project/asyncstdlib/
+"
SRC_URI="
https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild
index 64c907c487d0..5c779791734f 100644
--- a/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild
+++ b/dev-python/zope-deprecation/zope-deprecation-4.4.0-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
diff --git a/dev-python/zope-hookable/zope-hookable-5.1.0.ebuild b/dev-python/zope-hookable/zope-hookable-5.1.0.ebuild
index 73a0c150b9ed..a717053655ff 100644
--- a/dev-python/zope-hookable/zope-hookable-5.1.0.ebuild
+++ b/dev-python/zope-hookable/zope-hookable-5.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
diff --git a/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.1-r2.ebuild b/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.1-r2.ebuild
index cbb4c9fa189c..a598245d5c23 100644
--- a/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.1-r2.ebuild
+++ b/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.1-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1