summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-8.0.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 73786d315f9d..b4c9835f540c 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,2 +1,3 @@
DIST python-slugify-7.0.0.gh.tar.gz 13257 BLAKE2B 6d50fd25ac89caed3a970f4cce786d9b61de68386fc183659c0d884877edc934e121ad07316259af08deb61a30ac33f0076a90b2d5a650dfb113e6b6416addfe SHA512 c22743a28ffb273546541eaf59d2a7beb9070a7f81e504acaf73d220c2be83a87d02012b5841076539ba6bae5778dd47309ee7ceef9f8479c993dda6b3e09837
DIST python-slugify-8.0.0.gh.tar.gz 13322 BLAKE2B 146b04d75aa1aefa0a28824c2c3dd3f323ddfd49dbaafc82a9d9401de8fbdea25793c833e17b4a04cfc646fa371a0a10c40011be870fef573a8f0f8977671d26 SHA512 24d9309873c5bd625a9301b3a7844c7a1f3d2adb5faad9e49563446e33ab08f3d984c6692fb36885fdc363bee8c86252092ea0fc8f1b70152cff3365db37fd82
+DIST python-slugify-8.0.1.gh.tar.gz 13574 BLAKE2B 24fe3dc74f2a867e81bfbb9eac4a1db59a185ddfaf0f2f80cb50d5f06b2061ce28d23ba09ffd214dba26563d1ef37900d016d75dde7a7c35fa756cf49f51b9c2 SHA512 721089244c90f784e49259ee70caa0908d8523c2cf42c8fd57804a73017a815311a9cc9981c1f70a8c2f7cd7e01d77eedf8f9bd3c9d5c55ac4d5f72dbe512b34
diff --git a/dev-python/python-slugify/python-slugify-8.0.1.ebuild b/dev-python/python-slugify/python-slugify-8.0.1.ebuild
new file mode 100644
index 000000000000..e80db8044cf6
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-8.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest