summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flake8/flake8-6.1.0.ebuild2
-rw-r--r--dev-python/mccabe/mccabe-0.7.0.ebuild2
-rw-r--r--eclass/toolchain-funcs.eclass21
3 files changed, 3 insertions, 22 deletions
diff --git a/dev-python/flake8/flake8-6.1.0.ebuild b/dev-python/flake8/flake8-6.1.0.ebuild
index 2a55f96bbc9d..bba7b6815ba8 100644
--- a/dev-python/flake8/flake8-6.1.0.ebuild
+++ b/dev-python/flake8/flake8-6.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
diff --git a/dev-python/mccabe/mccabe-0.7.0.ebuild b/dev-python/mccabe/mccabe-0.7.0.ebuild
index e494bad6bcb8..f226517744e6 100644
--- a/dev-python/mccabe/mccabe-0.7.0.ebuild
+++ b/dev-python/mccabe/mccabe-0.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 26b7a0772ca6..e28f6148ddc1 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -534,9 +534,9 @@ tc-ld-force-bfd() {
ewarn "Forcing usage of the BFD linker"
# Set up LD to point directly to bfd if it's available.
+ local ld=$(tc-getLD "$@")
# We need to extract the first word in case there are flags appended
# to its value (like multilib), bug #545218.
- local ld=$(tc-getLD "$@")
local bfd_ld="${ld%% *}.bfd"
local path_ld=$(type -P "${bfd_ld}" 2>/dev/null)
[[ -e ${path_ld} ]] && export LD=${bfd_ld}
@@ -545,25 +545,6 @@ tc-ld-force-bfd() {
if tc-is-gcc || tc-is-clang ; then
export LDFLAGS="${LDFLAGS} -fuse-ld=bfd"
fi
-
- if false ; then
- # TODO: Clean this up, or is it useful for when the compiler can't
- # be detected or for rubbish shims? Might be helpful for cases like
- # when porting to new linker which GCC doesn't yet recognise (less
- # of a problem for Clang as it accepts absolute paths), like was
- # the case for mold.
- #
- # <=gcc-4.7 and <=clang-3.4 require some coercion.
- # Only works if bfd exists.
- if [[ -e ${path_ld} ]] ; then
- local d="${T}/bfd-linker"
- mkdir -p "${d}"
- ln -sf "${path_ld}" "${d}"/ld
- export LDFLAGS="${LDFLAGS} -B${d}"
- else
- die "unable to locate a BFD linker"
- fi
- fi
}
# @FUNCTION: _tc-has-openmp