summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-22.6.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 1151d6b0ba7c..72e1f49e703b 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,2 +1,3 @@
DIST black-22.1.0.tar.gz 1161720 BLAKE2B d74cbdd39dc1576583cee57089cb6d75a338f2d6640697adda79d38d02eeb51664049dca934d5014761d0fd4080ca2f40a3ea10c30e40bde9fe6af6c178b202c SHA512 9b97a3b32ecebebeb61ea581784a9b2215540c20533097fe87d5ef3c046dbe7c2ab8f2f21d1884cbe0ddd458434f17eb9b540764f955385873e6fdef86c3014c
DIST black-22.3.0.tar.gz 1154456 BLAKE2B c89b43722839748dff0ce60debb684cd8eeae5ef5fb7e080f6b0031412381d7be121ce62ad252a67fa7930726243680a4bf183417611617be5af39722164289d SHA512 fc44576b93a6e158f625ad5444247f6a59a1ebcc7f0c73ed40d557a9a865457b297eabd492f01999e51ee3e5c3fa83f3d6e3c10937ecaa8c1d36f7541736d2e4
+DIST black-22.6.0.gh.tar.gz 1165070 BLAKE2B ce2eef529e230954a13913063dbb9000fa13f4debb2e5ed33605e8efe5c6d62fc1b3c0b7847c26ad931b9becae43fa23b15701a1672c1e056f729810020cc282 SHA512 72e4b4dfc69436e4dbee5a75ea72a1be69a26dc37a5e4d7edfb84d62736f0e0aba8d14420f3069798b568bd8ba916e8850f0c958afc9b6134ee8832e54d3dc4c
diff --git a/dev-python/black/black-22.6.0.ebuild b/dev-python/black/black-22.6.0.ebuild
new file mode 100644
index 000000000000..2136bb8644c5
--- /dev/null
+++ b/dev-python/black/black-22.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+SRC_URI="
+ https://github.com/psf/black/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" "dev-python/aiohttp dev-python/aiohttp-cors"
+}