summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild15
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild15
2 files changed, 24 insertions, 6 deletions
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
index c7003379c001..d2ca352cd24f 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
@@ -20,12 +20,21 @@ HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-libs/libev
+RDEPEND="
+ dev-libs/libev
net-dns/c-ares
net-misc/curl[http2,ssl]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_GTest=ON
+ -DCLANG_TIDY_EXE=OFF
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install
- dobin "${WORKDIR}/${P}_build/https_dns_proxy"
+ dobin "${BUILD_DIR}"/https_dns_proxy
}
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
index 3c26883fb122..d2ca352cd24f 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
@@ -20,12 +20,21 @@ HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-libs/libev
+RDEPEND="
+ dev-libs/libev
net-dns/c-ares
net-misc/curl[http2,ssl]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_GTest=ON
+ -DCLANG_TIDY_EXE=OFF
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install
- dobin "${S}_build/https_dns_proxy"
+ dobin "${BUILD_DIR}"/https_dns_proxy
}