summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/linuxptp/Manifest1
-rw-r--r--net-misc/linuxptp/linuxptp-1.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/linuxptp/Manifest b/net-misc/linuxptp/Manifest
index 36c7dcd4fe22..9b3d2d4a1d0a 100644
--- a/net-misc/linuxptp/Manifest
+++ b/net-misc/linuxptp/Manifest
@@ -1,2 +1,3 @@
DIST linuxptp-1.5.tgz 139127 SHA256 ecebc8503a9fd2340299f8015e520527c32cf3760d34849fa0e855bbbf4b1090 SHA512 03ec0c3a283e08f9e62dfa7d059326887db541aa53b5c65e03534079083f39666a441a4303f428f3b972976483e683e603bdc2ec232495ccab46153531124974 WHIRLPOOL e5fb5398cf239221f08ec52830252aa4eeaabcef6341cc9c04a9ff3794d4d93f18247323b0a1fd26a088e00d6816087d7149e8625e7b25d91882be9dc034dec1
DIST linuxptp-1.6.tgz 144842 SHA256 e7fd16a9f235b059be527bd512e86f0c1d9f2e7c36736e6d6d9727a4427ac14c SHA512 f7e237f2afc0a53254cd56c3121c44dd633947eadf3c76bd3cb1e9488281e582d7d80dd33a681f5b4aef336cb3cfefe274783cf3b4a6f6e4bf98488996d81883 WHIRLPOOL fbd9492330d5fe6cfb5732778c3d3384d41250c1a0709e64cd2b19c1c050a9d5c02daa0ec14d4e68ee5356a77bd088d8cb6cffe9fee464354c3e128b2d532892
+DIST linuxptp-1.7.tgz 145856 SHA256 cc52610c5e6ec81cbbd392dc434040e99cb7fc661215d32a9d30b8008c499c26 SHA512 65cd509d098b9a12af469cab76aea7a1aeeca7b3d1db04d1538ed0979025f65a832b27d46fef9e262cc77e3787830eb33535068740def61dfa0e99569bce714b WHIRLPOOL 62a8d2f1ee689288e127b151105ff9ee251df0d1449e463cfb80aab7d2cc807ec7a762f4b287d7b4dddc4e776623949e6edeee2d68c4df6cf405daf87bb61ef9
diff --git a/net-misc/linuxptp/linuxptp-1.7.ebuild b/net-misc/linuxptp/linuxptp-1.7.ebuild
new file mode 100644
index 000000000000..82b21f3bead8
--- /dev/null
+++ b/net-misc/linuxptp/linuxptp-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="The Linux Precision Time Protocol (PTP) implementation"
+HOMEPAGE="http://linuxptp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/v${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="PPS NETWORK_PHY_TIMESTAMPING PTP_1588_CLOCK"
+
+src_compile() {
+ export EXTRA_CFLAGS=${CFLAGS}
+ emake prefix=/usr mandir=/usr/share/man
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ libdir="${D}"/usr/$(get_libdir) \
+ install
+
+ dodoc README.org
+}