summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
index 61beea784bb8..31371ded6b6a 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
@@ -5,8 +5,10 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
+
inherit cmake-utils git-r3 python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
@@ -43,6 +45,9 @@ DEPEND="${RDEPEND}
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
python_check_deps() {
! use test \
|| has_version "dev-python/lit[${PYTHON_USEDEP}]"