summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/six/six-1.10.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 810d8156f5fe..b5384b870c64 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -33,7 +33,8 @@ PATCHES=(
pkg_pretend() {
six_dir_check() {
type -p "${PYTHON}" > /dev/null || return 0
- local dir="${ROOT}"/$(python_get_sitedir)/six
+ local dir="${ROOT%/}$(python_get_sitedir)"/six
+ echo "${dir}"
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}
@@ -42,7 +43,7 @@ pkg_pretend() {
pkg_setup() {
six_dir_check() {
- local dir="${ROOT}"/$(python_get_sitedir)/six
+ local dir="${ROOT%/}$(python_get_sitedir)"/six
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}