summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyscard/Manifest2
-rw-r--r--dev-python/pyscard/pyscard-2.0.10.ebuild46
-rw-r--r--dev-python/pyscard/pyscard-2.1.0.ebuild46
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 4049481a75b3..42255814f31f 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1,3 +1 @@
-DIST pyscard-2.0.10.tar.gz 153351 BLAKE2B fb600032321ac0bd372c7aa8fcdd82273af9edcfb51eb5d455296a2a685a291e442209d5c59d60b81cdd8cb3b0699f733e41528fe06ed827558146ba4085c97d SHA512 231d5abc0ad31ae7f0e394f928045346323f1040b313394a3d235282feb79bfec0d124ebde84017178dfa1983beadfb245a33bfa6a75b4fab9e65c3090b9e9cb
-DIST pyscard-2.1.0.tar.gz 153511 BLAKE2B 072fb49ab17bdb32cf3381b9e769125b1c934f5830af6e33547a083025019c01cf61e077a1b4c5883572aa6db1e006f4a320fe07e097e6687dca45996aa1c6a2 SHA512 de0c26108751cc2b674968982f7982ad971c93890c32a0731394074dabe72805399755ed9f042aa4bc019e95b705d4394e0ac844699bbf8192ab5e779e43f2fe
DIST pyscard-2.1.1.tar.gz 153537 BLAKE2B 60c6d8acae5f707f84f8dfa775b2bfc74e4c6075b10a64c5ba1854b7c4e6cd03e2fa8db337b48ec5a167b834a4b22f5ae182ec4e78463b549aa8f4980295dbfd SHA512 854d52fde447e972545761ce8f2c1262d5e454c942fc68f2be09d0b62cc453aa5ef793e899f283fe5f53db59ef0714252090b8f5335dcd1b40ed28506965f371
diff --git a/dev-python/pyscard/pyscard-2.0.10.ebuild b/dev-python/pyscard/pyscard-2.0.10.ebuild
deleted file mode 100644
index 6c140610329e..000000000000
--- a/dev-python/pyscard/pyscard-2.0.10.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Smart card support in python"
-HOMEPAGE="
- https://pyscard.sourceforge.io/
- https://github.com/LudovicRousseau/pyscard/
- https://pypi.org/project/pyscard/
-"
-SRC_URI="
- https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-DEPEND="
- sys-apps/pcsc-lite
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-lang/swig
-"
-
-distutils_enable_tests unittest
-
-pkg_postinst() {
- optfeature "Gui support" dev-python/wxpython
- optfeature "Support of remote readers with Pyro" dev-python/Pyro4
-}
-
-python_test() {
- cd test || die
- eunittest
-}
diff --git a/dev-python/pyscard/pyscard-2.1.0.ebuild b/dev-python/pyscard/pyscard-2.1.0.ebuild
deleted file mode 100644
index 2efc6e371faa..000000000000
--- a/dev-python/pyscard/pyscard-2.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Smart card support in python"
-HOMEPAGE="
- https://pyscard.sourceforge.io/
- https://github.com/LudovicRousseau/pyscard/
- https://pypi.org/project/pyscard/
-"
-SRC_URI="
- https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-DEPEND="
- sys-apps/pcsc-lite
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-lang/swig
-"
-
-distutils_enable_tests unittest
-
-pkg_postinst() {
- optfeature "Gui support" dev-python/wxpython
- optfeature "Support of remote readers with Pyro" dev-python/Pyro4
-}
-
-python_test() {
- cd test || die
- eunittest
-}