summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/async_sinatra/async_sinatra-1.3.0.ebuild41
-rw-r--r--dev-ruby/crack/Manifest1
-rw-r--r--dev-ruby/crack/crack-0.4.3-r2.ebuild33
-rw-r--r--dev-ruby/faraday_middleware-multi_json/faraday_middleware-multi_json-0.0.6-r1.ebuild35
-rw-r--r--dev-ruby/hiredis/hiredis-0.6.3-r1.ebuild41
-rw-r--r--dev-ruby/launchy/Manifest1
-rw-r--r--dev-ruby/launchy/launchy-2.4.3-r2.ebuild36
-rw-r--r--dev-ruby/launchy/launchy-2.5.0.ebuild2
-rw-r--r--dev-ruby/net-http-persistent/Manifest2
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild31
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild29
-rw-r--r--eclass/ruby-fakegem.eclass1
-rw-r--r--profiles/package.mask5
-rw-r--r--x11-wm/subtle/subtle-0.11.3244.ebuild89
14 files changed, 48 insertions, 299 deletions
diff --git a/dev-ruby/async_sinatra/async_sinatra-1.3.0.ebuild b/dev-ruby/async_sinatra/async_sinatra-1.3.0.ebuild
deleted file mode 100644
index ba6570972e51..000000000000
--- a/dev-ruby/async_sinatra/async_sinatra-1.3.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Asynchronous response API for Sinatra and Thin"
-HOMEPAGE="https://github.com/raggi/async_sinatra"
-SRC_URI="https://github.com/raggi/async_sinatra/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/hoe-3.13
- >=dev-ruby/minitest-5.6:5
- >=dev-ruby/eventmachine-0.12.11
- dev-ruby/rake
- dev-ruby/rack-test
- )"
-
-ruby_add_rdepend ">=dev-ruby/sinatra-1.3.2
- >=dev-ruby/rack-1.4.1:*"
-
-each_ruby_test() {
- MT_NO_PLUGINS=true ${RUBY} -S rake test || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}/
- doins -r examples
-}
diff --git a/dev-ruby/crack/Manifest b/dev-ruby/crack/Manifest
index 3bcf68e1f3a1..18047808bdc6 100644
--- a/dev-ruby/crack/Manifest
+++ b/dev-ruby/crack/Manifest
@@ -1,2 +1 @@
-DIST crack-0.4.3.gem 574976 BLAKE2B 4b6f23277ec17a516d06e6e6785889996172b3ec077f022d1a52ab4b8e938b2735abbaecc71288b55654ff09a428c33eb944b627cfdc827ea1f4ddc6289461d9 SHA512 c6577bd86fe2e36b2a37693729da9fc35c5d4deb860ac1873265ccb6fb38056fd76d8c17bb4f779b39f4bc13b9db37c1768433f518c17090ccbb0872a103b386
DIST crack-0.4.4.tar.gz 586633 BLAKE2B 26e2cda6e9447fb3c9fe02092a6e9d6a8097c7bca6a483a3af42aa8ba491b737bc0dc3ae1936ef8ffb5c5d5cbbed3fde69c9641f05b9e3eb3beab87c375f68fd SHA512 3f86c76718a3c2a65ee11b15434035396c2355a8562bdb642432a659b52c3e811e930318e0dc2df3ff06bd53ac14d0694471e425420ae3b7971f5d4f818bba87
diff --git a/dev-ruby/crack/crack-0.4.3-r2.ebuild b/dev-ruby/crack/crack-0.4.3-r2.ebuild
deleted file mode 100644
index 23441eda7a0a..000000000000
--- a/dev-ruby/crack/crack-0.4.3-r2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails"
-HOMEPAGE="https://github.com/jnunemaker/crack"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/minitest )"
-ruby_add_rdepend ">=dev-ruby/safe_yaml-1.0.4-r4"
-
-each_ruby_prepare() {
- # Remove tests which fail when run by portage but pass when run by hand
- sed -i -e '/{"regex": \/foo.*\/}/d' test/json_test.rb || die
- sed -i -e '/{"regex": \/foo.*\/i}/d' test/json_test.rb || die
- sed -i -e '/{"regex": \/foo.*\/mix}/d' test/json_test.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Itest -Ilib -e 'Dir["test/*_test.rb"].each { |f| load f }' || die
-}
diff --git a/dev-ruby/faraday_middleware-multi_json/faraday_middleware-multi_json-0.0.6-r1.ebuild b/dev-ruby/faraday_middleware-multi_json/faraday_middleware-multi_json-0.0.6-r1.ebuild
deleted file mode 100644
index 8a361475fdc2..000000000000
--- a/dev-ruby/faraday_middleware-multi_json/faraday_middleware-multi_json-0.0.6-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Response JSON parser using MultiJson and FaradayMiddleware"
-HOMEPAGE="https://github.com/denro/faraday_middleware-multi_json"
-SRC_URI="https://github.com/denro/faraday_middleware-multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- dev-ruby/faraday_middleware:*
- dev-ruby/multi_json"
-
-all_ruby_prepare() {
- # Remove bundler support.
- rm -f Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Avoid unneeded dependency on git.
- sed -i -e '/files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
diff --git a/dev-ruby/hiredis/hiredis-0.6.3-r1.ebuild b/dev-ruby/hiredis/hiredis-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..96c59d55486e
--- /dev/null
+++ b/dev-ruby/hiredis/hiredis-0.6.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+MY_P="hiredis-rb-${PV}"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/hiredis_ext/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/hiredis/ext"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for hiredis (protocol serialization/deserialization and blocking I/O)"
+HOMEPAGE="https://github.com/redis/hiredis-rb"
+SRC_URI="https://github.com/redis/hiredis-rb/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" =dev-libs/hiredis-0.14*:="
+DEPEND+=" dev-libs/hiredis test? ( dev-ruby/test-unit:2 )"
+DEPEND+=" virtual/pkgconfig"
+
+RUBY_S="${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.6.1-unvendor-hiredis.patch" )
+
+all_ruby_prepare() {
+ sed -i -e 's:/tmp/:'${T}'/:' test/connection_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/launchy/Manifest b/dev-ruby/launchy/Manifest
index b85aeb88b089..13c172ce9c99 100644
--- a/dev-ruby/launchy/Manifest
+++ b/dev-ruby/launchy/Manifest
@@ -1,2 +1 @@
-DIST launchy-2.4.3.gem 29184 BLAKE2B d6e8e26f37a811fc994ee762791ea9ddb424dc99d23790905f80416734677535aa8b2087eab233dc1535556c240f260c5995185e10642cd682bbe508e3e30654 SHA512 7c3e0377c9a310b2e7a4d1544b4790f6f959d24b6aba91660e979eb943f4bee641e0b5a44687b693ffe99304ceb96a9a6cf9fed142e231af01135bd2b73321d6
DIST launchy-2.5.0.gem 30208 BLAKE2B 30719f97fdf1bca8a66eb113992c8714103a7fe87262c3677a0fa64b58070593bcbdba7357b81e5bada9e8a143e6601e28ef2d2730f0028fdaecefad23156fd8 SHA512 d80811009155d9cea6a2e69b5f7482aaec7d0bf23ecca4cbe72e440fb4eae1c38bc5904e863998f1966c7a99b98bad1f4456cec1cb076f96f5a99b835448b39f
diff --git a/dev-ruby/launchy/launchy-2.4.3-r2.ebuild b/dev-ruby/launchy/launchy-2.4.3-r2.ebuild
deleted file mode 100644
index 061b8cfc357f..000000000000
--- a/dev-ruby/launchy/launchy-2.4.3-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Helper class for launching cross-platform applications"
-HOMEPAGE="https://github.com/copiousfreetime/launchy"
-
-LICENSE="ISC"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-IUSE=""
-
-# File collision conflict with x11-misc/launchy, bug 545170
-ruby_add_rdepend ">=dev-ruby/addressable-2.3 !!x11-misc/launchy"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"
-
-# This test is expected to fail on linux, drop it
-RUBY_PATCHES=( "${FILESDIR}"/${PN}-2.4.2-drop-failing-test.patch )
-
-all_ruby_prepare() {
- sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die
-
- # Avoid tests depending on the current user's desktop environment.
- sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
- -i spec/detect/nix_desktop_environment_spec.rb || die
- sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
- -i spec/launchy_spec.rb || die
-}
diff --git a/dev-ruby/launchy/launchy-2.5.0.ebuild b/dev-ruby/launchy/launchy-2.5.0.ebuild
index 4ec867d948c5..ab526694d306 100644
--- a/dev-ruby/launchy/launchy-2.5.0.ebuild
+++ b/dev-ruby/launchy/launchy-2.5.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index 649bef0cf9a5..6cef2d4de01a 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1,4 +1,2 @@
-DIST net-http-persistent-3.0.0.gem 30208 BLAKE2B 2bbd87d66e65081c76bc9cddaeb38f3ffd8a92b5b64f7717f77c7a927e2032fa732c2e82e220a75a63ddc10dfaa6a0f24e4fa7e0964e2ebd3d0729127f1fb452 SHA512 a601d3abde43b196406e3cdd6b704796ed70db67dfb67c9b510e0164ce7355cc925cac37fbf4c5889f41b069890ba2e2c15440fb40294ed21891fd08d9f87894
DIST net-http-persistent-3.1.0.gem 31744 BLAKE2B fdd9c36ab5216c1cd1fe358207a689276e109845ac374ea16011469b6cb2b165115e78e701cce98c280e7f878c23d8016e75cac4508c7e579209012671b64101 SHA512 65b5afc4ad0729ec14b642e0e36363cecfff3dc25b26308d632866e93fed3eccfb83ce85da78f631553c6a1fe3ee834fcbc9d3681c85db6387463abbc30e60fa
-DIST net-http-persistent-4.0.0.gem 30720 BLAKE2B 5955cd60c86ae74c1f9d3415bf0257542718fc83d2b82cbc6ce31b5013edd1c0c3202757ccaf23a33c70d90fcb04e6bdfd2cdddfb82a45733ae3d15a5c526301 SHA512 eccc6cacfdd1dfb99bd0dcb7fe1c13cb1c21eae0104357156888bd0a5b2ee0b0d8ed5687860670c2dc54ccc1cfc7a090592bee160458427f44c255c1b99938d2
DIST net-http-persistent-4.0.1.gem 27136 BLAKE2B b88151498c401cc20983c86859d7ef7ae3688ee12a5fcc69544d9716c3aeed55f4339d35ec08e9c0a6a16b4b4ab807d7155425c3056b9634185c255472ad93c5 SHA512 d3c86c9c58affac8cde1513dd899527406c0baafd3a620b80011e3babf51a4bfd6fb2bd8998fd9c4696d49aad2d014bdf666b9626e06fe4413cb4010f94e5e91
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild
deleted file mode 100644
index 1a3b0067b692..000000000000
--- a/dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
-HOMEPAGE="https://github.com/drbrain/net-http-persistent"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
-
-ruby_add_bdepend "
- test? ( dev-ruby/hoe dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # avoid test with implicit dependency on net-http-pipeline which
- # fails and is not tested upstream
- sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
-}
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild
deleted file mode 100644
index 7fd3e977522e..000000000000
--- a/dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
-HOMEPAGE="https://github.com/drbrain/net-http-persistent"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
-
-ruby_add_bdepend "
- test? ( dev-ruby/hoe dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # avoid test with implicit dependency on net-http-pipeline which
- # fails and is not tested upstream
- sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
-}
diff --git a/eclass/ruby-fakegem.eclass b/eclass/ruby-fakegem.eclass
index d999ace34286..573e3511daf7 100644
--- a/eclass/ruby-fakegem.eclass
+++ b/eclass/ruby-fakegem.eclass
@@ -402,6 +402,7 @@ EOF
# @DESCRIPTION:
# Configure extensions defined in RUBY_FAKEGEM_EXTENSIONS, if any.
each_fakegem_configure() {
+ tc-export PKG_CONFIG
for extension in "${RUBY_FAKEGEM_EXTENSIONS[@]}" ; do
${RUBY} --disable=did_you_mean -C ${extension%/*} ${extension##*/} || die
done
diff --git a/profiles/package.mask b/profiles/package.mask
index 037eb2060abb..6828638e1bb7 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -33,6 +33,11 @@
#--- END OF EXAMPLES ---
+# Hans de Graaff <graaff@gentoo.org> (2021-10-17)
+# Obsolete package, replaced by dev-ruby/minitar.
+# No reverse dependencies left. Masked for removal in 30 days.
+dev-ruby/archive-tar-minitar
+
# Sam James <sam@gentoo.org> (2021-10-17)
# Fails to build with glibc 2.34 and no reverse dependencies.
# bug #806508
diff --git a/x11-wm/subtle/subtle-0.11.3244.ebuild b/x11-wm/subtle/subtle-0.11.3244.ebuild
deleted file mode 100644
index ef71c3fce45f..000000000000
--- a/x11-wm/subtle/subtle-0.11.3244.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-USE_RUBY="ruby24 ruby25 ruby26"
-
-inherit ruby-ng toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
- EHG_REPO_URI="https://hg.subforge.org/subtle"
- EHG_CHECKOUT_DIR=${S}/all
- inherit mercurial
-else
- SRC_URI="https://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A manual tiling window manager"
-HOMEPAGE="https://subforge.org/projects/subtle/wiki"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
-RESTRICT="!test? ( test )"
-
-RDEPEND="x11-libs/libX11
- xft? ( x11-libs/libXft )
- xinerama? ( x11-libs/libXinerama )
- xpm? ( x11-libs/libXpm )
- xtest? ( x11-libs/libXtst )
- xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-ruby_add_rdepend "dev-ruby/archive-tar-minitar"
-ruby_add_bdepend "dev-ruby/rake doc? ( dev-ruby/rdoc )"
-
-all_ruby_unpack() {
- if [[ ${PV} == "9999" ]]; then
- mercurial_src_unpack
- else
- default
- fi
-}
-
-each_ruby_configure() {
- local myconf
- use debug && myconf+=" debug=yes" || myconf+=" debug=no"
- use xft && myconf+=" xft=yes" || myconf+=" xft=no"
- use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
- use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
- use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
- use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
-
- ${RUBY} -S rake -v CC="$(tc-getCC)" destdir="${D}" ${myconf} config || die
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake -v build || die
-}
-
-all_ruby_compile() {
- use doc && { rake rdoc || die ; }
-}
-
-each_ruby_install() {
- ${RUBY} -S rake -v install || die
-}
-
-all_ruby_install() {
- dodir /etc/X11/Sessions
- cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
- #!/bin/sh
- exec /usr/bin/subtle
- EOF
- fperms a+x /etc/X11/Sessions/${PN}
-
- insinto /usr/share/xsessions
- doins data/${PN}.desktop
-
- dodoc AUTHORS NEWS
-
- use doc && dodoc -r html
-}
-
-pkg_postinst() {
- elog "Note that surserver will currently not work since dev-ruby/datamapper"
- elog "is not in the tree."
-}