summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/bert/Manifest1
-rw-r--r--dev-python/bert/bert-2.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/bert/Manifest b/dev-python/bert/Manifest
index 5f94ef5e4f46..fdf72f151e7b 100644
--- a/dev-python/bert/Manifest
+++ b/dev-python/bert/Manifest
@@ -1 +1,2 @@
DIST bert-2.0.0.tar.gz 3503 BLAKE2B 6435177493a822166e2f5e2c461f17deb9553aa3aec8893d15e057da9907ae4949246fb19299a1263905e648e0483d2e4cfeddbd2915f2c0d147a0a2bc62daf0 SHA512 643392ab1f8f0cecad9773846a52d5207f3dfeb431c6934b7cdfa523319c1c2aca4b9f8139d0a52ea759df03163b820adb963e4a21284e579a9d139da9acbeb3
+DIST bert-2.2.0.tar.gz 3541 BLAKE2B 3f1f87d5205e1098f7d170da5a4e331f9421151af536c106ce2de925082c48bc739df4bbe2294a2dbe8f65d2ccc24a1d5bb944ad90e80e558cb5032e4fd7c639 SHA512 417c9752362c6dc7ade8078f259d1674fcddd09b6af595694a9c31e886dbb523460413d4bf041db29afd4d67a9d639ef8f9254077c31d1593657ad52f8ef45a8
diff --git a/dev-python/bert/bert-2.2.0.ebuild b/dev-python/bert/bert-2.2.0.ebuild
new file mode 100644
index 000000000000..db1627e24731
--- /dev/null
+++ b/dev-python/bert/bert-2.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="BERT Serialization Library"
+HOMEPAGE="https://pypi.org/project/bert/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/basho-erlastic[${PYTHON_USEDEP}]"
+
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.0-remove-basestring-fix.patch" )