summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/ksh/ksh-1.0.8.ebuild2
-rw-r--r--app-text/crwx-ng/crwx-ng-0.3.1-r2.ebuild26
-rw-r--r--dev-libs/foma/foma-0.10.0_p20220612-r2.ebuild2
-rw-r--r--dev-util/bear/Manifest4
-rw-r--r--dev-util/bear/bear-3.0.20-r1.ebuild91
-rw-r--r--dev-util/bear/bear-3.1.2.ebuild95
-rw-r--r--dev-util/bear/bear-3.1.4.ebuild (renamed from dev-util/bear/bear-3.0.21.ebuild)25
-rw-r--r--dev-util/bear/files/bear-3.0.21-clang16-tests.patch32
-rw-r--r--dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch26
-rw-r--r--eclass/vdr-plugin-2.eclass2
-rw-r--r--net-fs/s3backer/Manifest2
-rw-r--r--net-fs/s3backer/s3backer-2.1.3.ebuild (renamed from net-fs/s3backer/s3backer-1.6.3.ebuild)29
12 files changed, 65 insertions, 271 deletions
diff --git a/app-shells/ksh/ksh-1.0.8.ebuild b/app-shells/ksh/ksh-1.0.8.ebuild
index 5d18e29dc3ca..1d31302e6655 100644
--- a/app-shells/ksh/ksh-1.0.8.ebuild
+++ b/app-shells/ksh/ksh-1.0.8.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ksh93/ksh"
else
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ~ppc64 ~riscv ~s390 ~sparc x86"
MY_PV=$(ver_rs 3 - 4 .)
SRC_URI="https://github.com/ksh93/${PN}/archive/v${MY_PV}/ksh-v${MY_PV}.tar.gz"
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/app-text/crwx-ng/crwx-ng-0.3.1-r2.ebuild b/app-text/crwx-ng/crwx-ng-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..b92868a5f3c6
--- /dev/null
+++ b/app-text/crwx-ng/crwx-ng-0.3.1-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+inherit cmake wxwidgets xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crwx-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ virtual/ttf-fonts"
+
+src_configure() {
+ setup-wxwidgets
+ cmake_src_configure
+}
diff --git a/dev-libs/foma/foma-0.10.0_p20220612-r2.ebuild b/dev-libs/foma/foma-0.10.0_p20220612-r2.ebuild
index c6d32f53c35d..070bf16a2140 100644
--- a/dev-libs/foma/foma-0.10.0_p20220612-r2.ebuild
+++ b/dev-libs/foma/foma-0.10.0_p20220612-r2.ebuild
@@ -14,7 +14,7 @@ S="${WORKDIR}/foma-${MY_COMMIT}"
LICENSE="Apache-2.0"
SLOT="0/0.10"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
BDEPEND="app-alternatives/yacc
app-alternatives/lex"
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
index 9425105b679e..80708b32dbc4 100644
--- a/dev-util/bear/Manifest
+++ b/dev-util/bear/Manifest
@@ -1,4 +1,2 @@
-DIST bear-3.0.20.tar.gz 125393 BLAKE2B 826a774beeb0596038f69b345a3659fe58f897bdb1a63f5faeac1d4242ae3cf4bf346ab82d2f87934d0786e5c0d4e835837b838a62f5a92c28ffe5e6a3d6a900 SHA512 4cf0e648b73fd4c0ac109c4a853e203efccb34ac7373d6c2f3ee3d5089853b791008990df768871dfd1268324bcce97c44657b4c3a2d1383134cba3eaec40bdd
-DIST bear-3.0.21.tar.gz 125827 BLAKE2B f7dcd383f27c370edb2fa0225e8337b2abe086df25a0272f61051600c017527b4079750328cb811b6967ad6fab51647909333eb1d084e24060fe56ca1036e40d SHA512 9fe43a52fb30b7b413244576c6ea0d493bb720e54d0b6263280224efef4b0432dee46697df160ba7e76bc1a5c8735fe814e0eb686ed797658b563bcb8c5bb7e5
-DIST bear-3.1.2.tar.gz 127197 BLAKE2B b9ef373aab194f0e7330c5f457b88e3c11bb3b202940eff65ecbae79b123254df9629c06f4781570b19675834be80fba041b070820663a6b9a747fc6d269be25 SHA512 02701e8a53b9d776ca838248f5b5d149d7ded6e024ce65bd1ca3b440ab1bf95691dc3d36bb28f043ce24bc1da6e666fb022ff92fa9df7c3142451742de16ca3e
DIST bear-3.1.3.tar.gz 127766 BLAKE2B 8fdb5b9bf8e1e026df2296b0d45f23ce1a9157dda28b2656d36c0799e2f02965711ecdf09780d075e18965afc6a771dbf26501e9e1e3b26f4784d4191e168748 SHA512 34039b51a7cd636bdb7fb716f69d6c70de3e7bfc5e2c83a3040942010fb7effe49b0afa0d29be182eb550d57b024fbe5bea779a7fda5f86201865bf491ba1672
+DIST bear-3.1.4.tar.gz 127672 BLAKE2B 18deb1172fcd8afdf4721a04b5d72b182190afd92d645841023033d187c812a0a30805af2bfb67b794ab8a8f0ca42965bebab6d035e95e2a25c5fccfe48a1afd SHA512 c63da7586d25a64dd8b3ff82f37505b36071dd064deb973c012840bc52ff6aec861fca21422b86b11629e86dc43d156b233d21b01e689369f0726799083afa98
diff --git a/dev-util/bear/bear-3.0.20-r1.ebuild b/dev-util/bear/bear-3.0.20-r1.ebuild
deleted file mode 100644
index 05332355b211..000000000000
--- a/dev-util/bear/bear-3.0.20-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.7.3:=
- >=dev-db/sqlite-3.14:=
- dev-libs/libfmt:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.5:=
- >=net-libs/grpc-1.26:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.10
- )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-build/libtool
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test)"
- -DENABLE_FUNC_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}
diff --git a/dev-util/bear/bear-3.1.2.ebuild b/dev-util/bear/bear-3.1.2.ebuild
deleted file mode 100644
index 9c75a5f7010e..000000000000
--- a/dev-util/bear/bear-3.1.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.11.2:=
- >=dev-db/sqlite-3.14:=
- >=dev-libs/libfmt-9.1.0:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.11.0:=
- >=net-libs/grpc-1.49.2:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.13
- )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-build/libtool
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.21-libfmt-10.0.0.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test)"
- -DENABLE_FUNC_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}
diff --git a/dev-util/bear/bear-3.0.21.ebuild b/dev-util/bear/bear-3.1.4.ebuild
index 3dbde5dce6df..6abba52decd6 100644
--- a/dev-util/bear/bear-3.0.21.ebuild
+++ b/dev-util/bear/bear-3.1.4.ebuild
@@ -3,31 +3,34 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake python-any-r1
+inherit cmake multiprocessing python-any-r1
DESCRIPTION="Build EAR generates a compilation database for clang tooling"
HOMEPAGE="https://github.com/rizsotto/Bear"
SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
+ dev-cpp/abseil-cpp:=
>=dev-cpp/nlohmann_json-3.11.2:=
- >=dev-db/sqlite-3.14:=
>=dev-libs/libfmt-9.1.0:=
dev-libs/protobuf:=
>=dev-libs/spdlog-1.11.0:=
>=net-libs/grpc-1.49.2:=
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
test? (
- >=dev-cpp/gtest-1.10
+ >=dev-cpp/gtest-1.13
)
"
@@ -41,15 +44,6 @@ BDEPEND="
)
"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.21-clang16-tests.patch
- "${FILESDIR}"/${PN}-3.0.21-libfmt-10.0.0.patch
-)
-
pkg_setup() {
use test && python-any-r1_pkg_setup
}
@@ -61,6 +55,9 @@ src_prepare() {
}
src_configure() {
+ # TODO: remove this when https://bugs.gentoo.org/928346 is fixed
+ export CMAKE_BUILD_PARALLEL_LEVEL=$(makeopts_jobs)
+
local mycmakeargs=(
-DENABLE_UNIT_TESTS="$(usex test)"
-DENABLE_FUNC_TESTS="$(usex test)"
diff --git a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch b/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
deleted file mode 100644
index 19c63ba60849..000000000000
--- a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://github.com/rizsotto/Bear/pull/521
-
-From 472cbed312444cdcef9102e924c79070ea1d3ab2 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Sat, 15 Apr 2023 19:37:41 +0200
-Subject: [PATCH] Avoid implicit function declarations in tests, for C99
- compatibility
-
-Include <stdio.h> for printf and define _GNU_SOURCE for execvpe.
-
-Future compilers will not support implicit function declartions by
-default, causing these tests to fail to build.
---- a/test/cases/intercept/preload/errno_reset.c
-+++ b/test/cases/intercept/preload/errno_reset.c
-@@ -5,6 +5,7 @@
- #include <stdlib.h>
- #include <errno.h>
- #include <string.h>
-+#include <stdio.h>
-
- int main()
- {
---- a/test/cases/intercept/preload/posix/execvpe/success.c
-+++ b/test/cases/intercept/preload/posix/execvpe/success.c
-@@ -8,6 +8,7 @@
- #include "config.h"
-
- #if defined HAVE_UNISTD_H
-+#define _GNU_SOURCE
- #include <unistd.h>
- #endif
-
diff --git a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch b/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
deleted file mode 100644
index 7c8425e46ede..000000000000
--- a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-BUG: https://bugs.gentoo.org/906082
-UPSTREAM: https://github.com/rizsotto/Bear/pull/526
-
-From 46a032fa0fc8131779ece13f26735ec84be891e8 Mon Sep 17 00:00:00 2001
-From: jinqiang zhang <peeweep@0x0.ee>
-Date: Thu, 11 May 2023 03:33:17 +0800
-Subject: [PATCH] dependency: fix fmt 10.0.0 incompatibilities (#526)
-
-Signed-off-by: jinqiang zhang <peeweep@0x0.ee>
----
- source/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
-index 6da1131f..fe6b710b 100644
---- a/source/CMakeLists.txt
-+++ b/source/CMakeLists.txt
-@@ -29,7 +29,7 @@ find_package(spdlog REQUIRED)
- find_package(PkgConfig REQUIRED)
- pkg_check_modules(gRPC REQUIRED IMPORTED_TARGET protobuf grpc++)
-
--if (fmt_VERSION_MAJOR EQUAL 9)
-+if (fmt_VERSION_MAJOR GREATER_EQUAL 9)
- set(FMT_NEEDS_OSTREAM_FORMATTER 1)
- set(HAVE_FMT_STD_H 1) # FIXME: this should be done with `check_include_file`
- endif ()
diff --git a/eclass/vdr-plugin-2.eclass b/eclass/vdr-plugin-2.eclass
index 289c3d1a624a..dc70ca7c5761 100644
--- a/eclass/vdr-plugin-2.eclass
+++ b/eclass/vdr-plugin-2.eclass
@@ -286,7 +286,7 @@ vdr_linguas_support() {
|| die "sed failed for Linguas"
done
- strip-linguas ${PLUGIN_LINGUAS} en
+ strip-linguas ${PLUGIN_LINGUAS}
}
# @FUNCTION: vdr_i18n
diff --git a/net-fs/s3backer/Manifest b/net-fs/s3backer/Manifest
index 4456927cf5a7..0e8d7048a913 100644
--- a/net-fs/s3backer/Manifest
+++ b/net-fs/s3backer/Manifest
@@ -1,2 +1,2 @@
-DIST s3backer-1.6.3.tar.gz 129742 BLAKE2B 05f8b94e9b5e6ffd11b20d5945a9705f1830f3f358c2777695d0c5066bb044bd314d65259ecde299a51288908fcd869b8c516b30b0fbf66975b46a021d4d5bd6 SHA512 f7db1d733a0426df22c1b7d9c1150f8dbfedd0ba2e9120bd61026a481ed52a16f7f09e9e4fcd072cb656da0536cf98472f369eec0195a03b3f105fb3c9a8ba99
DIST s3backer-2.1.2.tar.gz 156281 BLAKE2B 5891dbcecbd08b73d69218894d29ec56323d53ff9b594a853d42d6a621787392061895ae3168d6671b65db1b62cdca26959a122250e8878d740c2d806c9d305f SHA512 58e8bd5909b5f714ead7add9dcfe798d626628519e75f4f4347175c92fdf652e08f6ae00c2d9bf34fa859d46c111b846047ee4e613b94e81b7a7cdfc8e26fd9a
+DIST s3backer-2.1.3.tar.gz 156859 BLAKE2B 0a28f739f29e2d63a6626247a16d437696a0b3ce2a2b83ae5875f40005ca7f61a3117cf4ecd4646006372cf3eb0afd7a423dca8dfe3db7041c53fc9fffce6b2b SHA512 14e892e3b327ba1c1c164aec30689c0a63e9ede162d4e4a99f9b4fcc0a4a3ef9c81fbacf775cb78f3830ab504e1759bc162af30d1b09a761e97de7191c3e60c8
diff --git a/net-fs/s3backer/s3backer-1.6.3.ebuild b/net-fs/s3backer/s3backer-2.1.3.ebuild
index 5795b7fcbfd6..c24a5f9d506d 100644
--- a/net-fs/s3backer/s3backer-1.6.3.ebuild
+++ b/net-fs/s3backer/s3backer-2.1.3.ebuild
@@ -5,21 +5,30 @@ EAPI=8
inherit autotools
-DESCRIPTION="FUSE-based single file backing store via Amazon S3"
+DESCRIPTION="A filesystem that contains a single file backed by Amazon S3"
HOMEPAGE="https://github.com/archiecobbs/s3backer"
SRC_URI="https://github.com/archiecobbs/s3backer/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="nbd"
-RDEPEND="dev-libs/expat
+RDEPEND="
+ app-arch/zstd:=
+ dev-libs/expat
dev-libs/openssl:0=
net-misc/curl
sys-fs/fuse:0
- sys-libs/zlib"
+ sys-libs/zlib
+ nbd? ( sys-block/nbd sys-block/nbdkit )
+"
DEPEND="${RDEPEND}
- elibc_musl? ( sys-libs/queue-standalone )"
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
src_prepare() {
default
@@ -31,6 +40,14 @@ src_prepare() {
eautoreconf
}
-src_compile() {
- emake CFLAGS="${CFLAGS}"
+src_configure() {
+ econf $(use_enable nbd)
+}
+
+src_install() {
+ default
+
+ if use nbd ; then
+ rm "${ED}/usr/$(get_libdir)/nbdkit/plugins/nbdkit-s3backer-plugin.la" || die
+ fi
}