summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pdm/Manifest3
-rw-r--r--dev-python/pdm/pdm-2.8.0.ebuild69
-rw-r--r--dev-python/pdm/pdm-2.8.1.ebuild67
-rw-r--r--dev-python/pdm/pdm-2.9.0.ebuild68
4 files changed, 0 insertions, 207 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index c2939776490a..518feb578f26 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,6 +1,3 @@
-DIST pdm-2.8.0.tar.gz 3069029 BLAKE2B 3fc3246c7bf26953be96def58d8249c981def96e1607b82b35f1b8347dc5246dd6b4613e4f2093e2e6453724e8709951d2fff38a1f02f2dcc5e85fe6e8c678da SHA512 95cc0a4cb032fa39281aea5ab2f31da7f503c6444a9c41d88ac9bf9ab650654a3f154506f2ed822e70266046c4b6a111518ed68aa7ab75aa31c096e071859bcd
-DIST pdm-2.8.1.tar.gz 3014347 BLAKE2B 0dde8e2376065ac6241e06c24a7b1b241e5653f6e2cb7fd529cc8dfd3d0f6c6fc4c6a43208551594a7d837d11dbaff02612d944a9077cb132d3eee3c23559ee7 SHA512 f18fddd533cf0b72f9ff376c865bc5df6a58c248f4c9737404eb1d62f5d9a233f22b7a76db3b2f9b7a321c8d1e3aa2ea395d2dd3ffe29834ccc09c8272410b82
DIST pdm-2.8.2.tar.gz 3014401 BLAKE2B a541339582944988b7a30d2991066287e0293845d4f15c7f6cb2fef7a8709dba537f190e5493bd3b06e7ef86fca601a9d1aab7af6ca6ae55269b374a7464ca17 SHA512 396e27902f74773070cf49c3857d93702e6678a46221b54dc03e84e2b8ccf211cbba9d24eba6bfc47ff36cbd4eb504ada5bf82071c884347026ba85c123058e9
-DIST pdm-2.9.0.tar.gz 3017672 BLAKE2B f0fe08da3fcc3d72e707d11d217b1482b06351eeae47cef3b696100589d0acd15dd860d61c60004d68decafe277d7afd1c79ae5826689be6781120ef8cf3c969 SHA512 1d7f8b6a4403779730117179a4bfd5884afeeff3f6d7f083e5ed50835b3764b19f54dd8509db04968c66e176a34aef8b6a26f1a9423cd23b94a4eb1255962467
DIST pdm-2.9.1.tar.gz 3017895 BLAKE2B 944a1cd9571f7ad2ec6b4212b29db7b6c7c5e8b12591c73dae19f099f9d511f0db3f0698d48e2e42fc81f30c876caa7c9e43467d23eee26876595e6fd6ff197e SHA512 979bf9d078747c7b8dd56555d499053b978ddf289af4bf889b2f2805255049c24bf48607b3704509d914eec59904cbdb9983af396c68ff7211cc216fd4b40118
DIST pdm-2.9.2.tar.gz 3018730 BLAKE2B 83eeab7b70efe61a515ed262e8bd1de911f111aaa22704fcce2e46824a236be663ba831cce8bb440e612e711b8cf0627b1a416e966b06b51dc6e25feb2e856b0 SHA512 1d3193dc31065a05989e9dc36518fac0d45f86945d68ff2b5e03473b97c70b0f9586849a1e2208e740921927857733c76c44b512213cb17fc6608f9d0d7bcbd9
diff --git a/dev-python/pdm/pdm-2.8.0.ebuild b/dev-python/pdm/pdm-2.8.0.ebuild
deleted file mode 100644
index af490a26b277..000000000000
--- a/dev-python/pdm/pdm-2.8.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/unearth[${PYTHON_USEDEP}]
- dev-python/findpython[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -a disable_tests=(
- # tests that try to reach out to the internet
- basic_integration
- build_with_no_isolation
- search_package
- show_package_on_pypi
- show_update_hint
- build_single_module
- project_packages_path
- build_package
- build_src_package
- build_with_config_settings
- cli_build_with_config_settings
- build_ignoring_pip_environment
- publish_and_build_in_one_run
- )
-
- local textexpr
- testexpr=$(printf 'not %s and ' "${disable_tests[@]}")
- epytest -m "not network and not integration and not path" -k "${testexpr%and }" -x
-}
diff --git a/dev-python/pdm/pdm-2.8.1.ebuild b/dev-python/pdm/pdm-2.8.1.ebuild
deleted file mode 100644
index 281812e00468..000000000000
--- a/dev-python/pdm/pdm-2.8.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- >=dev-python/unearth-0.10.0[${PYTHON_USEDEP}]
- <dev-python/findpython-1[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
- tests/test_project.py::test_access_index_with_auth
- tests/cli/test_others.py::test_build_distributions
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
- # hangs on interactive keyring prompts
- tests/cli/test_config.py::test_repository_overwrite_default
- tests/cli/test_config.py::test_hide_password_in_output_repository
- tests/cli/test_config.py::test_hide_password_in_output_pypi
- # junk output, sigh
- tests/cli/test_others.py::test_info_command_json
- # why does it try to use python 2.7?!
- tests/cli/test_run.py::test_import_another_sitecustomize
- )
-
- epytest -m "not network and not integration and not path"
-}
diff --git a/dev-python/pdm/pdm-2.9.0.ebuild b/dev-python/pdm/pdm-2.9.0.ebuild
deleted file mode 100644
index 4d236116e9d1..000000000000
--- a/dev-python/pdm/pdm-2.9.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/truststore[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- >=dev-python/unearth-0.10.0[${PYTHON_USEDEP}]
- <dev-python/findpython-1[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
- tests/test_project.py::test_access_index_with_auth
- tests/cli/test_others.py::test_build_distributions
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
- # hangs on interactive keyring prompts
- tests/cli/test_config.py::test_repository_overwrite_default
- tests/cli/test_config.py::test_hide_password_in_output_repository
- tests/cli/test_config.py::test_hide_password_in_output_pypi
- # junk output, sigh
- tests/cli/test_others.py::test_info_command_json
- # why does it try to use python 2.7?!
- tests/cli/test_run.py::test_import_another_sitecustomize
- )
-
- epytest -m "not network and not integration and not path"
-}