summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/eldev/Manifest1
-rw-r--r--app-emacs/eldev/eldev-1.11.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/eldev/Manifest b/app-emacs/eldev/Manifest
index 37454809780c..4f5f23ab653d 100644
--- a/app-emacs/eldev/Manifest
+++ b/app-emacs/eldev/Manifest
@@ -1 +1,2 @@
DIST eldev-1.10.3.tar.gz 308020 BLAKE2B 9beddf08b817fb37d785e40054a2e202334f7b68d5671dc503f6af8508a4f97946338806ef6cb2e08b2969cfb030a20a0358cfab4543c63e79beadf9e2930f59 SHA512 081073cdcabd5582962e5511992bf70ab90870572914be5e49f213723d62f4e7e08c745188ee5cfce1634f41f36bf2aed089a618cb4d1e56e30e0fed0d42acc6
+DIST eldev-1.11.gh.tar.gz 318724 BLAKE2B a3818e244cdbd6a07a10cb962cb4b219380dc7efd8b8e563e4c455c3fcdb4351318f702b2cd5eec82ddb120702492ac864a87539eb5ed58a02d192ce20475bfb SHA512 9415c524484963b10d78e4b510174a3e836c5a4b8ff835ad18c27ec34e0e45b756810876267b32153111e8309571de00f8d9034a9c8a1f016d7950371dc094d0
diff --git a/app-emacs/eldev/eldev-1.11.ebuild b/app-emacs/eldev/eldev-1.11.ebuild
new file mode 100644
index 000000000000..7251e88d76f6
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://emacs-eldev.github.io/eldev/
+ https://github.com/emacs-eldev/eldev/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/doublep/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-eldev/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+ELISP_REMOVE="
+ test/doctor.el
+"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ local -x ELDEV_LOCAL="${S}"
+
+ edo "./bin/${PN}" test
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin
+ doexe "./bin/${PN}"
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}/99${PN}" || die
+ doenvd "${T}/99${PN}"
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}