summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/angstrom/Manifest1
-rw-r--r--dev-ml/angstrom/angstrom-0.5.1.ebuild36
-rw-r--r--dev-ml/angstrom/metadata.xml15
-rw-r--r--dev-ml/ocaml-doc/Manifest1
-rw-r--r--dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild24
-rw-r--r--eclass/bsdmk.eclass2
-rw-r--r--sys-apps/systemd/files/233-format-warnings.patch84
-rw-r--r--sys-apps/systemd/systemd-233-r3.ebuild1
8 files changed, 163 insertions, 1 deletions
diff --git a/dev-ml/angstrom/Manifest b/dev-ml/angstrom/Manifest
new file mode 100644
index 000000000000..b5a1799d0854
--- /dev/null
+++ b/dev-ml/angstrom/Manifest
@@ -0,0 +1 @@
+DIST angstrom-0.5.1.tar.gz 131214 SHA256 f9ae1834f5d89469b37c0f7a1a9c21a71c1085703ad34570791dbe7522889492 SHA512 e79c11333b11e2fb25f7a6667f9c6498a55ead7d9517c9b0e0b4e9cab1a220e65017a105e146f82688c54a6abf0f7a269ed163460f8fa83f95bec6bec61b8d5f WHIRLPOOL dd7382046338d615409d0af216db482072719580f5a96b6c6dd16b85d03dd125af834433fd4f3ef6de008319764aa76b2575edd698e9313ead931304cd45fdd0
diff --git a/dev-ml/angstrom/angstrom-0.5.1.ebuild b/dev-ml/angstrom/angstrom-0.5.1.ebuild
new file mode 100644
index 000000000000..f5d25f5dc761
--- /dev/null
+++ b/dev-ml/angstrom/angstrom-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Parser combinators built for speed and memory efficiency"
+HOMEPAGE="https://github.com/inhabitedtype/angstrom"
+SRC_URI="https://github.com/inhabitedtype/angstrom/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt async"
+
+RDEPEND="
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocplib-endian:=
+ dev-ml/result:=
+ lwt? ( dev-ml/lwt:= )
+ async? ( dev-ml/async:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/alcotest )"
+
+# needs old alcotest...
+RESTRICT="test"
+
+DOCS=( README.md )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt) $(use_enable async)" oasis_src_configure
+}
diff --git a/dev-ml/angstrom/metadata.xml b/dev-ml/angstrom/metadata.xml
new file mode 100644
index 000000000000..4e11ac5a6965
--- /dev/null
+++ b/dev-ml/angstrom/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <use>
+ <flag name="async">Enable <pkg>dev-ml/async</pkg> bindings for asynchronous API.</flag>
+ <flag name="lwt">Enable <pkg>dev-ml/lwt</pkg> bindings for asynchronous API.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">inhabitedtype/angstrom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-doc/Manifest b/dev-ml/ocaml-doc/Manifest
index 4aa9e10156aa..2e2410e25994 100644
--- a/dev-ml/ocaml-doc/Manifest
+++ b/dev-ml/ocaml-doc/Manifest
@@ -1 +1,2 @@
DIST ocaml-4.04-refman-html.tar.gz 833166 SHA256 1cb4afcdb64359eea2501c63085f62eda4bbac51fd89b7d5dbf56670ec1b88ba SHA512 027ad5ea08488beb5ce65ec97a8aaf04197317d7d3194de771a4170dea9f8b90fc4309fd917b4176cd930dd0835c84448771b84fa92a735cfc60668ef0a6a413 WHIRLPOOL 4b4c405f4ea2dd314ff76dd2c0e01ed749909a781395d5a9be2ef16613b930aa570e09f266fa789ac6460cff7946204bcbb20d907caba28ff6c208b9e111671e
+DIST ocaml-4.05-refman-html.tar.gz 882419 SHA256 ddf1d1b29ebadd625e6c677b7820033c82d590f593ffc352627b7deeaf40ca8a SHA512 84688b06e61904345bc961d7244a74427025879c8e7365073887d76a560e5a373227d75c9f645f7bc16adbd05ea6a58918738beb13b5001cedc6b8289ed70bde WHIRLPOOL d4bf6e7b36a1048d5ea3d691e03ef3b4f3aed632f3fc0d01ae87e11eb276c52a9654fc00f94094645f534bb9e2203c5862d22f54678bbc3f2a7cfe98eae576fa
diff --git a/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild b/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild
new file mode 100644
index 000000000000..198cd811e65f
--- /dev/null
+++ b/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Ocaml reference manual (html)"
+HOMEPAGE="http://caml.inria.fr/pub/docs/manual-ocaml/"
+SRC_URI="http://caml.inria.fr/pub/distrib/ocaml-${PV}/ocaml-${PV}-refman-html.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/htmlman
+
+src_install() {
+ dohtml -r *
+}
+
+pkg_postinst() {
+ elog "This manual is available online at http://caml.inria.fr/pub/docs/manual-ocaml/"
+}
diff --git a/eclass/bsdmk.eclass b/eclass/bsdmk.eclass
index 9416b9ac9982..ed5870b61653 100644
--- a/eclass/bsdmk.eclass
+++ b/eclass/bsdmk.eclass
@@ -3,7 +3,7 @@
# @ECLASS: bsdmk.eclass
# @MAINTAINER:
-# maintainer-needed@gentoo.org
+# bsd@gentoo.org
# @BLURB: Some functions for BSDmake
inherit toolchain-funcs portability flag-o-matic
diff --git a/sys-apps/systemd/files/233-format-warnings.patch b/sys-apps/systemd/files/233-format-warnings.patch
new file mode 100644
index 000000000000..7bb08f0a3201
--- /dev/null
+++ b/sys-apps/systemd/files/233-format-warnings.patch
@@ -0,0 +1,84 @@
+From 3e7d14d78c4d15ec7789299216cbf5c58e61547b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Sat, 3 Jun 2017 05:41:17 -0400
+Subject: [PATCH] sd-bus: silence format warnings in kdbus code (#6072)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The code is mostly correct, but gcc is trying to outsmart us, and emits a
+warning for a "llu vs lu" mismatch, even though they are the same size (on alpha):
+
+src/libsystemd/sd-bus/bus-control.c: In function ‘kernel_get_list’:
+src/libsystemd/sd-bus/bus-control.c:267:42: error: format ‘%llu’ expects argument of type ‘long long unsigned int’, but argument 3 has type ‘__u64 {aka long unsigned int}’ [-Werror=format=]
+ if (asprintf(&n, ":1.%llu", name->id) < 0) {
+ ^
+src/libsystemd/sd-bus/bus-control.c: In function ‘bus_get_name_creds_kdbus’:
+src/libsystemd/sd-bus/bus-control.c:714:47: error: format ‘%llu’ expects argument of type ‘long long unsigned int’, but argument 3 has type ‘__u64 {aka long unsigned int}’ [-Werror=format=]
+ if (asprintf(&c->unique_name, ":1.%llu", conn_info->id) < 0) {
+ ^
+This is hard to work around properly, because kdbus.h uses __u64 which is
+defined-differently-despite-being-the-same-size then uint64_t. Thus the simple
+solution of using %PRIu64 fails on amd64:
+
+src/libsystemd/sd-bus/bus-control.c:714:47: error: format ‘%lu’ expects argument of type ‘long unsigned int’, but argument 3 has type ‘__u64 {aka long long unsigned int}’ [-Werror=format=]
+ if (asprintf(&c->unique_name, ":1.%"PRIu64, conn_info->id) < 0) {
+ ^~~~~~
+
+Let's just avoid the whole issue for now by silencing the warning.
+After the next release, we should just get rid of the kdbus code.
+
+Fixes #5561.
+---
+ src/libsystemd/sd-bus/bus-control.c | 6 ++++++
+ src/libsystemd/sd-bus/bus-kernel.c | 2 ++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/src/libsystemd/sd-bus/bus-control.c b/src/libsystemd/sd-bus/bus-control.c
+index 9e58ffbd8..303ae0f23 100644
+--- a/src/libsystemd/sd-bus/bus-control.c
++++ b/src/libsystemd/sd-bus/bus-control.c
+@@ -264,10 +264,13 @@ static int kernel_get_list(sd_bus *bus, uint64_t flags, char ***x) {
+ if ((flags & KDBUS_LIST_UNIQUE) && name->id != previous_id && !(name->flags & KDBUS_HELLO_ACTIVATOR)) {
+ char *n;
+
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat"
+ if (asprintf(&n, ":1.%llu", name->id) < 0) {
+ r = -ENOMEM;
+ goto fail;
+ }
++#pragma GCC diagnostic pop
+
+ r = strv_consume(x, n);
+ if (r < 0)
+@@ -711,10 +714,13 @@ int bus_get_name_creds_kdbus(
+ }
+
+ if (mask & SD_BUS_CREDS_UNIQUE_NAME) {
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat"
+ if (asprintf(&c->unique_name, ":1.%llu", conn_info->id) < 0) {
+ r = -ENOMEM;
+ goto fail;
+ }
++#pragma GCC diagnostic pop
+
+ c->mask |= SD_BUS_CREDS_UNIQUE_NAME;
+ }
+diff --git a/src/libsystemd/sd-bus/bus-kernel.c b/src/libsystemd/sd-bus/bus-kernel.c
+index c82caeb3f..ca6aee7c0 100644
+--- a/src/libsystemd/sd-bus/bus-kernel.c
++++ b/src/libsystemd/sd-bus/bus-kernel.c
+@@ -51,6 +51,8 @@
+ #include "user-util.h"
+ #include "util.h"
+
++#pragma GCC diagnostic ignored "-Wformat"
++
+ #define UNIQUE_NAME_MAX (3+DECIMAL_STR_MAX(uint64_t))
+
+ int bus_kernel_parse_unique_name(const char *s, uint64_t *id) {
+--
+2.13.2
+
diff --git a/sys-apps/systemd/systemd-233-r3.ebuild b/sys-apps/systemd/systemd-233-r3.ebuild
index 8210bd8a2f90..ab19c28efc04 100644
--- a/sys-apps/systemd/systemd-233-r3.ebuild
+++ b/sys-apps/systemd/systemd-233-r3.ebuild
@@ -155,6 +155,7 @@ src_prepare() {
local PATCHES=(
"${FILESDIR}/233-0001-Avoid-strict-DM-interface-version-dependencies-5519.patch"
"${FILESDIR}/233-CVE-2017-9445.patch"
+ "${FILESDIR}/233-format-warnings.patch"
)
if ! use vanilla; then