summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/portspoof/portspoof-1.3-r1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-misc/portspoof/portspoof-1.3-r1.ebuild b/net-misc/portspoof/portspoof-1.3-r1.ebuild
index ad443ee320fb..d0fed28eeb2b 100644
--- a/net-misc/portspoof/portspoof-1.3-r1.ebuild
+++ b/net-misc/portspoof/portspoof-1.3-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="return SYN+ACK for every port connection attempt"
HOMEPAGE="http://portspoof.org/"
LICENSE="GPL-2+"
@@ -29,6 +31,18 @@ src_prepare() {
sed -i '/#include <sys\/sysctl.h>/d' src/connection.h || die
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861698
+ # https://github.com/drk1wi/portspoof/issues/48
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default_src_install
newsbin system_files/init.d/portspoof.sh portspoof-runner