summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/sublime-text/Manifest2
-rw-r--r--app-editors/sublime-text/sublime-text-3_p3176.ebuild64
-rw-r--r--dev-embedded/arduino/arduino-1.8.5-r2.ebuild1
-rw-r--r--dev-ros/cv_bridge/Manifest1
-rw-r--r--dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild23
-rw-r--r--dev-ros/geometric_shapes/Manifest2
-rw-r--r--dev-ros/geometric_shapes/files/logging.patch213
-rw-r--r--dev-ros/geometric_shapes/geometric_shapes-0.6.0.ebuild (renamed from dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild)3
-rw-r--r--dev-ros/image_geometry/Manifest1
-rw-r--r--dev-ros/image_geometry/image_geometry-1.13.0.ebuild22
-rw-r--r--dev-ros/opencv_tests/Manifest1
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild32
-rw-r--r--ros-meta/vision_opencv/Manifest1
-rw-r--r--ros-meta/vision_opencv/vision_opencv-1.13.0.ebuild21
-rw-r--r--sys-process/procps/procps-3.3.15-r1.ebuild (renamed from sys-process/procps/procps-3.3.15.ebuild)2
15 files changed, 172 insertions, 217 deletions
diff --git a/app-editors/sublime-text/Manifest b/app-editors/sublime-text/Manifest
index e0dcb8faeed2..09174baba174 100644
--- a/app-editors/sublime-text/Manifest
+++ b/app-editors/sublime-text/Manifest
@@ -1,2 +1,4 @@
DIST sublime_text_3_build_3143_x32.tar.bz2 9847438 BLAKE2B bca62736e3dbaae5aa5318af5aca4c78c5abff1189a58b354205351f21ba1caa8a6b479e9a7e01fdb4a56dec68d50e0e43522918b461463cdada7e6dbda6441c SHA512 471716815a171f786ad5f12b743ec3c17dcde2fc165522e523d338c9184af7789095e2de41e89d0c4b0dc58bfe409f116662016e7014c528650ce074c101084b
DIST sublime_text_3_build_3143_x64.tar.bz2 9857381 BLAKE2B bf69810574eda5bb3afaa82dcbf8b68f9bef1db19af2382e0ee4b93cb87f08caa3f7bdc754419284b3902e0e715a97d211adcd234f35d8038071818368b3fb54 SHA512 db6375cbcaf1cb6e1d583aa043abeaeecf0236e1d2e23b965b6c2dd616ec2277d73786d2a9c273329c1a94890edc7ddce1551292b5170dc5b558cd7246c5093f
+DIST sublime_text_3_build_3176_x32.tar.bz2 10352060 BLAKE2B 97d6e7bcc838ecac53ffa68cc3d355b01d06ea1903fd92b9894f27cf402d0506728be69f27d91dccbcba1bab876f94fd619bcf4877a9d935fb5517e91d2be4ac SHA512 640920a92995aac4af711cb4eb58d142d1afe2cbcbc485a111bc407ce464e81b984cd2110074072cc3805ed8656a4a60acce6f1a014f8a3f27f1b340222b0071
+DIST sublime_text_3_build_3176_x64.tar.bz2 10314226 BLAKE2B 98b0cda71b8a859614a1a6510afa073ca1aae6b9ac5d4b6db259723e8aa057a8b2bf22a0d26f0b6ccce31f39e047293ed84c4a63b8739a6d08c05af5791967bd SHA512 c37bd0d6d7fbbe2757f4244ae2803086d5fe1e25b32a1dd2de4241dc55f66f7c4588f3f9d56059c9d0ef7fe2ae69e76005f16dad60060f38fe10b92fd8eda969
diff --git a/app-editors/sublime-text/sublime-text-3_p3176.ebuild b/app-editors/sublime-text/sublime-text-3_p3176.ebuild
new file mode 100644
index 000000000000..89e271833a01
--- /dev/null
+++ b/app-editors/sublime-text/sublime-text-3_p3176.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils
+
+# get the major version from PV
+MV=${PV:0:1}
+MY_PV=${PV#*_p}
+
+DESCRIPTION="Sophisticated text editor for code, markup and prose"
+HOMEPAGE="https://www.sublimetext.com"
+SRC_URI="
+ amd64? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x64.tar.bz2 )
+ x86? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x32.tar.bz2 )"
+
+LICENSE="Sublime"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )"
+
+QA_PREBUILT="*"
+S="${WORKDIR}/sublime_text_${MV}"
+
+# Sublime bundles the kitchen sink, which includes python and other assorted
+# modules. Do not try to unbundle these because you are guaranteed to fail.
+
+src_install() {
+ insinto /opt/${PN}${MV}
+ doins -r Packages Icon
+ doins changelog.txt sublime_plugin.py sublime.py python3.3.zip
+
+ exeinto /opt/${PN}${MV}
+ doexe crash_reporter plugin_host sublime_text
+ dosym ../../opt/${PN}${MV}/sublime_text /usr/bin/subl
+
+ local size
+ for size in 32 48 128 256; do
+ dosym ../../../../../../opt/${PN}${MV}/Icon/${size}x${size}/sublime-text.png \
+ /usr/share/icons/hicolor/${size}x${size}/apps/subl.png
+ done
+
+ make_desktop_entry "subl" "Sublime Text ${MV}" "subl" \
+ "TextEditor;IDE;Development" "StartupNotify=true"
+
+ # needed to get WM_CLASS lookup right
+ mv "${ED%/}"/usr/share/applications/subl{-sublime-text,}.desktop || die
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
diff --git a/dev-embedded/arduino/arduino-1.8.5-r2.ebuild b/dev-embedded/arduino/arduino-1.8.5-r2.ebuild
index 9bb3d4462bf3..50b52632bde4 100644
--- a/dev-embedded/arduino/arduino-1.8.5-r2.ebuild
+++ b/dev-embedded/arduino/arduino-1.8.5-r2.ebuild
@@ -68,6 +68,7 @@ RDEPEND="${CDEPEND}
>=virtual/jre-1.8"
DEPEND="${CDEPEND}
+ app-arch/unzip
>=virtual/jdk-1.8"
EANT_BUILD_TARGET="build"
diff --git a/dev-ros/cv_bridge/Manifest b/dev-ros/cv_bridge/Manifest
index 799c29e08063..10be375a1b19 100644
--- a/dev-ros/cv_bridge/Manifest
+++ b/dev-ros/cv_bridge/Manifest
@@ -1,3 +1,4 @@
DIST vision_opencv-1.12.5.tar.gz 81739 BLAKE2B 5c135009f4e766b34c217b6de1dba836bf225b4cc7aca53b34c297f0c0986a79c3c629990464599da98fa32424a87467037caf3b51f3f6dcab2add615d613c08 SHA512 df3ad951262a692124eead5751f64c04fbf831486db8c000e23e2f0b10f645d830c38cf2d99d23b696b96cd0388c4d732ddda4e5d8e8b7cb88a3fd5909c62c71
DIST vision_opencv-1.12.7.tar.gz 81877 BLAKE2B 216a82ec377e0bc3d85866da3ed3b9e8e90f7615bfbf0e3cacc30cd2bc2aeeb3f822d8daa1f0be42dab45dbdfc69c043a3a4c29b8357561356a2f874b3f61552 SHA512 e02f9450183e8e927d947d2382859ed01aaa5dc7a8f299e5a39815c53ee726b96781e961b1cf0f5cc3ac16699d162d4ed80678de4b6517e5139a5a8bd592e39c
DIST vision_opencv-1.12.8.tar.gz 82043 BLAKE2B 9eb18ea9a4d3ddf6d2103ab3a2e53557349880ea665f8089d64319e8c99fb4ea922e8de1ab04fb749bed5c2503041d27d8e9b773d6142a5b5366aae937ca2514 SHA512 fadd84bb5e9586a5b04833100d9e1267ce8d153ca95a3257e1c3e6fe825dae524e25b2cc7deebb48d326cce8ef04523c5803eeecd88362cf6ff0384c52557608
+DIST vision_opencv-1.13.0.tar.gz 82177 BLAKE2B 1c863f3c9e6b856d61a0e879f958f0f1fd184f088e208023a504cf5bb982c5496b71e1f2b4761e4456ca76348e51bc2bc760b2c43e1a35b02fa5c23c8e444502 SHA512 a20ec2f41a0c94dde51b19f902ae078cbf5449a2aadbeacbc49bbfc2ab52c39878e63448a3137591f7e1b2f6025baef616579463cf32274e7838157137d214bc
diff --git a/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild b/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild
new file mode 100644
index 000000000000..781df6ff0219
--- /dev/null
+++ b/dev-ros/cv_bridge/cv_bridge-1.13.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ >=media-libs/opencv-3:=[contrib(+)]
+ dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/geometric_shapes/Manifest b/dev-ros/geometric_shapes/Manifest
index 7fc11382864f..971ee47f032e 100644
--- a/dev-ros/geometric_shapes/Manifest
+++ b/dev-ros/geometric_shapes/Manifest
@@ -1,2 +1,2 @@
-DIST geometric_shapes-0.5.3.tar.gz 60799 BLAKE2B 77bfde8f7b1f3e11bd4bb12c82374e34ca0efc0f75125a1c5a58d4ce797feb70b70803526f4b8cbdf651d762082a4bbcb03df5e6ace2bdc69ed84be20a963731 SHA512 13c1b85cab4d0d5d35bd010927a5fd789312b4c11667ee73295722067968504054a8f24628db2f78782078ff3cbcd6878bd403979c29526b2183c3ae2414b2b1
DIST geometric_shapes-0.5.4.tar.gz 62028 BLAKE2B 6873019c54872077ec88ad6107bdf1a69092d73bd1f73b38dbbdcd88a3e5da9cfffd0782ec2e01f87fd90082ed856e3a2f5161dec606ba08c0510752a813359c SHA512 bd0909fb0feeddebf65793aa77a6803217e39e782767cd2d58b26266ff79018ebb352c77385e20043a069caaa7e00ba63366a703d52605562e8535f1d3af2dac
+DIST geometric_shapes-0.6.0.tar.gz 62152 BLAKE2B ebd2b6260a212e1ba3513d064d69af91fe2141e2ee696b6781829c83a5df44c9de9a9ee68c0c9354adbfc954350cde6c339529955c506e3e2c45e7eaa2a54d52 SHA512 b580f2e2acf864d3d03dd67d088d5c0d04cf8f28c1db8ebb3f4155ff9cf77af92cc268aecc41ad3d983d9e021044404af03309fb94d99162ea84d2d16681b562
diff --git a/dev-ros/geometric_shapes/files/logging.patch b/dev-ros/geometric_shapes/files/logging.patch
deleted file mode 100644
index 06036ad5dcee..000000000000
--- a/dev-ros/geometric_shapes/files/logging.patch
+++ /dev/null
@@ -1,213 +0,0 @@
-https://github.com/ros-planning/geometric_shapes/issues/71
-
-Index: geometric_shapes-0.5.3/src/bodies.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/bodies.cpp
-+++ geometric_shapes-0.5.3/src/bodies.cpp
-@@ -788,7 +788,7 @@ void bodies::ConvexMesh::useDimensions(c
-
- if (exitcode != 0)
- {
-- logWarn("Convex hull creation failed");
-+ CONSOLE_BRIDGE_logWarn("Convex hull creation failed");
- qh_freeqhull (!qh_ALL);
- int curlong, totlong;
- qh_memfreeshort (&curlong, &totlong);
-@@ -1174,7 +1174,7 @@ void bodies::BodyVector::setPose(unsigne
- {
- if (i >= bodies_.size())
- {
-- logError("There is no body at index %u", i);
-+ CONSOLE_BRIDGE_logError("There is no body at index %u", i);
- return;
- }
-
-@@ -1185,7 +1185,7 @@ const bodies::Body* bodies::BodyVector::
- {
- if (i >= bodies_.size())
- {
-- logError("There is no body at index %u", i);
-+ CONSOLE_BRIDGE_logError("There is no body at index %u", i);
- return NULL;
- }
- else
-Index: geometric_shapes-0.5.3/src/body_operations.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/body_operations.cpp
-+++ geometric_shapes-0.5.3/src/body_operations.cpp
-@@ -59,7 +59,7 @@ bodies::Body* bodies::createBodyFromShap
- body = new bodies::ConvexMesh(shape);
- break;
- default:
-- logError("Creating body from shape: Unknown shape type %d", (int)shape->type);
-+ CONSOLE_BRIDGE_logError("Creating body from shape: Unknown shape type %d", (int)shape->type);
- break;
- }
-
-@@ -112,7 +112,7 @@ Body* constructBodyFromMsgHelper(const T
- Eigen::Quaterniond q(pose.orientation.w, pose.orientation.x, pose.orientation.y, pose.orientation.z);
- if (fabs(q.squaredNorm() - 1.0) > 1e-3)
- {
-- logError("Quaternion is not normalized. Assuming identity.");
-+ CONSOLE_BRIDGE_logError("Quaternion is not normalized. Assuming identity.");
- q = Eigen::Quaterniond(1.0, 0.0, 0.0, 0.0);
- }
- Eigen::Affine3d af(Eigen::Translation3d(pose.position.x, pose.position.y, pose.position.z) * q.toRotationMatrix());
-Index: geometric_shapes-0.5.3/src/mesh_operations.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/mesh_operations.cpp
-+++ geometric_shapes-0.5.3/src/mesh_operations.cpp
-@@ -133,7 +133,7 @@ Mesh* createMeshFromVertices(const Eigen
- return NULL;
-
- if (source.size() % 3 != 0)
-- logError("The number of vertices to construct a mesh from is not divisible by 3. Probably constructed triangles will not make sense.");
-+ CONSOLE_BRIDGE_logError("The number of vertices to construct a mesh from is not divisible by 3. Probably constructed triangles will not make sense.");
-
- std::set<detail::LocalVertexType, detail::ltLocalVertexValue> vertices;
- std::vector<unsigned int> triangles;
-@@ -220,7 +220,7 @@ Mesh* createMeshFromBinary(const char *b
- {
- if (!buffer || size < 1)
- {
-- logWarn("Cannot construct mesh from empty binary buffer");
-+ CONSOLE_BRIDGE_logWarn("Cannot construct mesh from empty binary buffer");
- return NULL;
- }
-
-@@ -285,21 +285,21 @@ Mesh* createMeshFromResource(const std::
- }
- catch (resource_retriever::Exception& e)
- {
-- logError("%s", e.what());
-+ CONSOLE_BRIDGE_logError("%s", e.what());
- return NULL;
- }
-
- if (res.size == 0)
- {
-- logWarn("Retrieved empty mesh for resource '%s'", resource.c_str());
-+ CONSOLE_BRIDGE_logWarn("Retrieved empty mesh for resource '%s'", resource.c_str());
- return NULL;
- }
-
- Mesh *m = createMeshFromBinary(reinterpret_cast<const char*>(res.data.get()), res.size, scale, resource);
- if (!m)
- {
-- logWarn("Assimp reports no scene in %s.", resource.c_str());
-- logWarn("This could be because of a resource filename that is too long for the Assimp library, a known bug. As a workaround shorten the filename/path.");
-+ CONSOLE_BRIDGE_logWarn("Assimp reports no scene in %s.", resource.c_str());
-+ CONSOLE_BRIDGE_logWarn("This could be because of a resource filename that is too long for the Assimp library, a known bug. As a workaround shorten the filename/path.");
- }
- return m;
- }
-@@ -344,7 +344,7 @@ Mesh* createMeshFromAsset(const aiScene*
- {
- if (!scene->HasMeshes())
- {
-- logWarn("Assimp reports scene in %s has no meshes", resource_name.c_str());
-+ CONSOLE_BRIDGE_logWarn("Assimp reports scene in %s has no meshes", resource_name.c_str());
- return NULL;
- }
- EigenSTL::vector_Vector3d vertices;
-@@ -352,12 +352,12 @@ Mesh* createMeshFromAsset(const aiScene*
- extractMeshData(scene, scene->mRootNode, aiMatrix4x4(), scale, vertices, triangles);
- if (vertices.empty())
- {
-- logWarn("There are no vertices in the scene %s", resource_name.c_str());
-+ CONSOLE_BRIDGE_logWarn("There are no vertices in the scene %s", resource_name.c_str());
- return NULL;
- }
- if (triangles.empty())
- {
-- logWarn("There are no triangles in the scene %s", resource_name.c_str());
-+ CONSOLE_BRIDGE_logWarn("There are no triangles in the scene %s", resource_name.c_str());
- return NULL;
- }
-
-@@ -378,7 +378,7 @@ Mesh* createMeshFromShape(const Shape *s
- if (shape->type == shapes::CONE)
- return shapes::createMeshFromShape(static_cast<const shapes::Cone&>(*shape));
- else
-- logError("Conversion of shape of type '%s' to a mesh is not known", shapeStringName(shape).c_str());
-+ CONSOLE_BRIDGE_logError("Conversion of shape of type '%s' to a mesh is not known", shapeStringName(shape).c_str());
- return NULL;
- }
-
-Index: geometric_shapes-0.5.3/src/shape_operations.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/shape_operations.cpp
-+++ geometric_shapes-0.5.3/src/shape_operations.cpp
-@@ -62,7 +62,7 @@ Shape* constructShapeFromMsg(const shape
- {
- if (shape_msg.triangles.empty() || shape_msg.vertices.empty())
- {
-- logWarn("Mesh definition is empty");
-+ CONSOLE_BRIDGE_logWarn("Mesh definition is empty");
- return NULL;
- }
- else
-@@ -117,7 +117,7 @@ Shape* constructShapeFromMsg(const shape
- shape_msg.dimensions[shape_msgs::SolidPrimitive::CONE_HEIGHT]);
- }
- if (shape == NULL)
-- logError("Unable to construct shape corresponding to shape_msg of type %d", (int)shape_msg.type);
-+ CONSOLE_BRIDGE_logError("Unable to construct shape corresponding to shape_msg of type %d", (int)shape_msg.type);
-
- return shape;
- }
-@@ -202,7 +202,7 @@ bool constructMarkerFromShape(const Shap
- }
- catch (std::runtime_error &ex)
- {
-- logError("%s", ex.what());
-+ CONSOLE_BRIDGE_logError("%s", ex.what());
- }
- if (ok)
- return true;
-@@ -451,7 +451,7 @@ bool constructMsgFromShape(const Shape*
- }
- else
- {
-- logError("Unable to construct shape message for shape of type %d", (int)shape->type);
-+ CONSOLE_BRIDGE_logError("Unable to construct shape message for shape of type %d", (int)shape->type);
- return false;
- }
-
-@@ -512,7 +512,7 @@ void saveAsText(const Shape *shape, std:
- }
- else
- {
-- logError("Unable to save shape of type %d", (int)shape->type);
-+ CONSOLE_BRIDGE_logError("Unable to save shape of type %d", (int)shape->type);
- }
- }
-
-@@ -580,7 +580,7 @@ Shape* constructShapeFromText(std::istre
- m->computeVertexNormals();
- }
- else
-- logError("Unknown shape type: '%s'", type.c_str());
-+ CONSOLE_BRIDGE_logError("Unknown shape type: '%s'", type.c_str());
- }
- }
- return result;
-Index: geometric_shapes-0.5.3/src/shapes.cpp
-===================================================================
---- geometric_shapes-0.5.3.orig/src/shapes.cpp
-+++ geometric_shapes-0.5.3/src/shapes.cpp
-@@ -224,12 +224,12 @@ shapes::Shape* shapes::OcTree::clone() c
-
- void shapes::OcTree::scaleAndPadd(double scale, double padd)
- {
-- logWarn("OcTrees cannot be scaled or padded");
-+ CONSOLE_BRIDGE_logWarn("OcTrees cannot be scaled or padded");
- }
-
- void shapes::Plane::scaleAndPadd(double scale, double padding)
- {
-- logWarn("Planes cannot be scaled or padded");
-+ CONSOLE_BRIDGE_logWarn("Planes cannot be scaled or padded");
- }
-
- void shapes::Shape::scale(double scale)
diff --git a/dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild b/dev-ros/geometric_shapes/geometric_shapes-0.6.0.ebuild
index 54b4e296f9f0..80708cfa63ea 100644
--- a/dev-ros/geometric_shapes/geometric_shapes-0.5.3-r1.ebuild
+++ b/dev-ros/geometric_shapes/geometric_shapes-0.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -28,4 +28,3 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest dev-ros/rosunit )
"
-PATCHES=( "${FILESDIR}/logging.patch" )
diff --git a/dev-ros/image_geometry/Manifest b/dev-ros/image_geometry/Manifest
index 0b947a86e1a2..b46ebf16004f 100644
--- a/dev-ros/image_geometry/Manifest
+++ b/dev-ros/image_geometry/Manifest
@@ -3,3 +3,4 @@ DIST vision_opencv-1.12.4.tar.gz 80675 BLAKE2B e07f89942f471e25ec76ae43b07dee79e
DIST vision_opencv-1.12.5.tar.gz 81739 BLAKE2B 5c135009f4e766b34c217b6de1dba836bf225b4cc7aca53b34c297f0c0986a79c3c629990464599da98fa32424a87467037caf3b51f3f6dcab2add615d613c08 SHA512 df3ad951262a692124eead5751f64c04fbf831486db8c000e23e2f0b10f645d830c38cf2d99d23b696b96cd0388c4d732ddda4e5d8e8b7cb88a3fd5909c62c71
DIST vision_opencv-1.12.7.tar.gz 81877 BLAKE2B 216a82ec377e0bc3d85866da3ed3b9e8e90f7615bfbf0e3cacc30cd2bc2aeeb3f822d8daa1f0be42dab45dbdfc69c043a3a4c29b8357561356a2f874b3f61552 SHA512 e02f9450183e8e927d947d2382859ed01aaa5dc7a8f299e5a39815c53ee726b96781e961b1cf0f5cc3ac16699d162d4ed80678de4b6517e5139a5a8bd592e39c
DIST vision_opencv-1.12.8.tar.gz 82043 BLAKE2B 9eb18ea9a4d3ddf6d2103ab3a2e53557349880ea665f8089d64319e8c99fb4ea922e8de1ab04fb749bed5c2503041d27d8e9b773d6142a5b5366aae937ca2514 SHA512 fadd84bb5e9586a5b04833100d9e1267ce8d153ca95a3257e1c3e6fe825dae524e25b2cc7deebb48d326cce8ef04523c5803eeecd88362cf6ff0384c52557608
+DIST vision_opencv-1.13.0.tar.gz 82177 BLAKE2B 1c863f3c9e6b856d61a0e879f958f0f1fd184f088e208023a504cf5bb982c5496b71e1f2b4761e4456ca76348e51bc2bc760b2c43e1a35b02fa5c23c8e444502 SHA512 a20ec2f41a0c94dde51b19f902ae078cbf5449a2aadbeacbc49bbfc2ab52c39878e63448a3137591f7e1b2f6025baef616579463cf32274e7838157137d214bc
diff --git a/dev-ros/image_geometry/image_geometry-1.13.0.ebuild b/dev-ros/image_geometry/image_geometry-1.13.0.ebuild
new file mode 100644
index 000000000000..25d882f4b84d
--- /dev/null
+++ b/dev-ros/image_geometry/image_geometry-1.13.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ and Python libraries for interpreting images geometrically"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ media-libs/opencv:=
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"
diff --git a/dev-ros/opencv_tests/Manifest b/dev-ros/opencv_tests/Manifest
index 48250f7b17a0..3b31db9e87b8 100644
--- a/dev-ros/opencv_tests/Manifest
+++ b/dev-ros/opencv_tests/Manifest
@@ -5,3 +5,4 @@ DIST vision_opencv-1.12.4.tar.gz 80675 BLAKE2B e07f89942f471e25ec76ae43b07dee79e
DIST vision_opencv-1.12.5.tar.gz 81739 BLAKE2B 5c135009f4e766b34c217b6de1dba836bf225b4cc7aca53b34c297f0c0986a79c3c629990464599da98fa32424a87467037caf3b51f3f6dcab2add615d613c08 SHA512 df3ad951262a692124eead5751f64c04fbf831486db8c000e23e2f0b10f645d830c38cf2d99d23b696b96cd0388c4d732ddda4e5d8e8b7cb88a3fd5909c62c71
DIST vision_opencv-1.12.7.tar.gz 81877 BLAKE2B 216a82ec377e0bc3d85866da3ed3b9e8e90f7615bfbf0e3cacc30cd2bc2aeeb3f822d8daa1f0be42dab45dbdfc69c043a3a4c29b8357561356a2f874b3f61552 SHA512 e02f9450183e8e927d947d2382859ed01aaa5dc7a8f299e5a39815c53ee726b96781e961b1cf0f5cc3ac16699d162d4ed80678de4b6517e5139a5a8bd592e39c
DIST vision_opencv-1.12.8.tar.gz 82043 BLAKE2B 9eb18ea9a4d3ddf6d2103ab3a2e53557349880ea665f8089d64319e8c99fb4ea922e8de1ab04fb749bed5c2503041d27d8e9b773d6142a5b5366aae937ca2514 SHA512 fadd84bb5e9586a5b04833100d9e1267ce8d153ca95a3257e1c3e6fe825dae524e25b2cc7deebb48d326cce8ef04523c5803eeecd88362cf6ff0384c52557608
+DIST vision_opencv-1.13.0.tar.gz 82177 BLAKE2B 1c863f3c9e6b856d61a0e879f958f0f1fd184f088e208023a504cf5bb982c5496b71e1f2b4761e4456ca76348e51bc2bc760b2c43e1a35b02fa5c23c8e444502 SHA512 a20ec2f41a0c94dde51b19f902ae078cbf5449a2aadbeacbc49bbfc2ab52c39878e63448a3137591f7e1b2f6025baef616579463cf32274e7838157137d214bc
diff --git a/dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild b/dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild
new file mode 100644
index 000000000000..83b23217853e
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}
diff --git a/ros-meta/vision_opencv/Manifest b/ros-meta/vision_opencv/Manifest
index 38c1152742a6..909cc9dadd40 100644
--- a/ros-meta/vision_opencv/Manifest
+++ b/ros-meta/vision_opencv/Manifest
@@ -2,3 +2,4 @@ DIST vision_opencv-1.12.4.tar.gz 80675 BLAKE2B e07f89942f471e25ec76ae43b07dee79e
DIST vision_opencv-1.12.5.tar.gz 81739 BLAKE2B 5c135009f4e766b34c217b6de1dba836bf225b4cc7aca53b34c297f0c0986a79c3c629990464599da98fa32424a87467037caf3b51f3f6dcab2add615d613c08 SHA512 df3ad951262a692124eead5751f64c04fbf831486db8c000e23e2f0b10f645d830c38cf2d99d23b696b96cd0388c4d732ddda4e5d8e8b7cb88a3fd5909c62c71
DIST vision_opencv-1.12.7.tar.gz 81877 BLAKE2B 216a82ec377e0bc3d85866da3ed3b9e8e90f7615bfbf0e3cacc30cd2bc2aeeb3f822d8daa1f0be42dab45dbdfc69c043a3a4c29b8357561356a2f874b3f61552 SHA512 e02f9450183e8e927d947d2382859ed01aaa5dc7a8f299e5a39815c53ee726b96781e961b1cf0f5cc3ac16699d162d4ed80678de4b6517e5139a5a8bd592e39c
DIST vision_opencv-1.12.8.tar.gz 82043 BLAKE2B 9eb18ea9a4d3ddf6d2103ab3a2e53557349880ea665f8089d64319e8c99fb4ea922e8de1ab04fb749bed5c2503041d27d8e9b773d6142a5b5366aae937ca2514 SHA512 fadd84bb5e9586a5b04833100d9e1267ce8d153ca95a3257e1c3e6fe825dae524e25b2cc7deebb48d326cce8ef04523c5803eeecd88362cf6ff0384c52557608
+DIST vision_opencv-1.13.0.tar.gz 82177 BLAKE2B 1c863f3c9e6b856d61a0e879f958f0f1fd184f088e208023a504cf5bb982c5496b71e1f2b4761e4456ca76348e51bc2bc760b2c43e1a35b02fa5c23c8e444502 SHA512 a20ec2f41a0c94dde51b19f902ae078cbf5449a2aadbeacbc49bbfc2ab52c39878e63448a3137591f7e1b2f6025baef616579463cf32274e7838157137d214bc
diff --git a/ros-meta/vision_opencv/vision_opencv-1.13.0.ebuild b/ros-meta/vision_opencv/vision_opencv-1.13.0.ebuild
new file mode 100644
index 000000000000..9818603983c8
--- /dev/null
+++ b/ros-meta/vision_opencv/vision_opencv-1.13.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/image_geometry
+ dev-ros/opencv_tests
+"
+DEPEND="${RDEPEND}"
diff --git a/sys-process/procps/procps-3.3.15.ebuild b/sys-process/procps/procps-3.3.15-r1.ebuild
index 3bf9a07f37ca..9fe2c96448bd 100644
--- a/sys-process/procps/procps-3.3.15.ebuild
+++ b/sys-process/procps/procps-3.3.15-r1.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
SRC_URI="mirror://sourceforge/${PN}-ng/${PN}-ng-${PV}.tar.xz"
LICENSE="GPL-2"
-SLOT="0/5" # libprocps.so
+SLOT="0/6" # libprocps.so
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"