summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 83a75c2e06b2..0521ea787be9 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=(python2_7)
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -47,11 +47,6 @@ DEPEND="
dev-python/wheel[${PYTHON_USEDEP}]
)"
-python_prepare_all() {
- sed -i -e "/'argparse',/d" setup.py || die
- distutils-r1_python_prepare_all
-}
-
python_test() {
nosetests -v ${PN} || die
}