summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/gnupg/files/gnupg-2.3.5-fix-buffering-hang.patch52
-rw-r--r--app-crypt/gnupg/gnupg-2.3.5-r2.ebuild162
-rw-r--r--app-misc/ca-certificates/ca-certificates-20210119.3.66.ebuild4
-rw-r--r--app-misc/ca-certificates/ca-certificates-20211016.3.77.ebuild2
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.1.0.ebuild37
-rw-r--r--dev-python/lark-parser/lark-parser-0.11.3.ebuild28
-rw-r--r--dev-python/pystache/metadata.xml3
-rw-r--r--dev-python/pystache/pystache-0.6.0.ebuild2
-rw-r--r--dev-util/meson/meson-0.59.4.ebuild4
-rw-r--r--dev-util/meson/meson-0.60.2-r1.ebuild4
-rw-r--r--dev-util/meson/meson-0.60.3.ebuild2
-rw-r--r--eclass/meson.eclass12
-rw-r--r--net-irc/hexchat/metadata.xml1
14 files changed, 272 insertions, 42 deletions
diff --git a/app-crypt/gnupg/files/gnupg-2.3.5-fix-buffering-hang.patch b/app-crypt/gnupg/files/gnupg-2.3.5-fix-buffering-hang.patch
new file mode 100644
index 000000000000..3ff8d2afcf6f
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-2.3.5-fix-buffering-hang.patch
@@ -0,0 +1,52 @@
+https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=2fc91e15c6bebb203162cc8445e68ee4ff934885;hp=2848fe4c84e5ee20ccd90f0ef4c9f78c6801e1f6
+https://bugs.gentoo.org/840746
+
+From: NIIBE Yutaka <gniibe@fsij.org>
+Date: Mon, 25 Apr 2022 17:37:32 +0900
+Subject: [PATCH 1/1] common:iobuf: Exclude cases with
+ IOBUF_INPUT_TEMP/IOBUF_OUTPUT_TEMP.
+
+* common/iobuf.c (iobuf_read): Handle a case with IOBUF_INPUT_TEMP.
+(iobuf_write): Handle a case with IOBUF_OUTPUT_TEMP.
+
+--
+
+GnuPG-bug-id: 5941
+Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
+--- a/common/iobuf.c
++++ b/common/iobuf.c
+@@ -2177,7 +2177,8 @@ iobuf_read (iobuf_t a, void *buffer, unsigned int buflen)
+ a->e_d.len = 0;
+
+ /* Hint for how full to fill iobuf internal drain buffer. */
+- a->e_d.preferred = (buf && buflen >= IOBUF_ZEROCOPY_THRESHOLD_SIZE);
++ a->e_d.preferred = (a->use != IOBUF_INPUT_TEMP)
++ && (buf && buflen >= IOBUF_ZEROCOPY_THRESHOLD_SIZE);
+
+ n = 0;
+ do
+@@ -2200,7 +2201,7 @@ iobuf_read (iobuf_t a, void *buffer, unsigned int buflen)
+ underflow to read more data into the filter's internal
+ buffer. */
+ {
+- if (buf && n < buflen)
++ if (a->use != IOBUF_INPUT_TEMP && buf && n < buflen)
+ {
+ /* Setup external drain buffer for faster moving of data
+ * (avoid memcpy). */
+@@ -2328,11 +2329,13 @@ iobuf_write (iobuf_t a, const void *buffer, unsigned int buflen)
+ a->e_d.len = 0;
+
+ /* Hint for how full to fill iobuf internal drain buffer. */
+- a->e_d.preferred = (buflen >= IOBUF_ZEROCOPY_THRESHOLD_SIZE);
++ a->e_d.preferred = (a->use != IOBUF_OUTPUT_TEMP)
++ && (buflen >= IOBUF_ZEROCOPY_THRESHOLD_SIZE);
+
+ do
+ {
+- if (a->d.len == 0 && buflen >= IOBUF_ZEROCOPY_THRESHOLD_SIZE)
++ if ((a->use != IOBUF_OUTPUT_TEMP)
++ && a->d.len == 0 && buflen >= IOBUF_ZEROCOPY_THRESHOLD_SIZE)
+ {
+ /* Setup external drain buffer for faster moving of data
+ * (avoid memcpy). */
diff --git a/app-crypt/gnupg/gnupg-2.3.5-r2.ebuild b/app-crypt/gnupg/gnupg-2.3.5-r2.ebuild
new file mode 100644
index 000000000000..d32419deb726
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-2.3.5-r2.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gnupg.asc
+inherit flag-o-matic systemd toolchain-funcs verify-sig
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
+HOMEPAGE="https://gnupg.org/"
+SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnupg/gnupg/${P}.tar.bz2.sig )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl test +tofu tpm tools usb user-socket wks-server"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( tofu )"
+
+# Existence of executables is checked during configuration.
+# Note: On each bump, update dep bounds on each version from configure.ac!
+DEPEND=">=dev-libs/libassuan-2.5.0
+ >=dev-libs/libgcrypt-1.9.1:=
+ >=dev-libs/libgpg-error-1.41
+ >=dev-libs/libksba-1.3.4
+ >=dev-libs/npth-1.2
+ >=net-misc/curl-7.10
+ bzip2? ( app-arch/bzip2 )
+ ldap? ( net-nds/openldap:= )
+ readline? ( sys-libs/readline:0= )
+ smartcard? ( usb? ( virtual/libusb:1 ) )
+ tofu? ( >=dev-db/sqlite-3.27 )
+ tpm? ( >=app-crypt/tpm2-tss-2.4.0:= )
+ ssl? ( >=net-libs/gnutls-3.0:0= )
+ sys-libs/zlib
+"
+
+RDEPEND="${DEPEND}
+ app-crypt/pinentry
+ nls? ( virtual/libintl )
+ selinux? ( sec-policy/selinux-gpg )
+ wks-server? ( virtual/mta )"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( sys-apps/texinfo )
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )"
+
+DOCS=(
+ ChangeLog NEWS README THANKS TODO VERSION
+ doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch
+ "${FILESDIR}"/${P}-fix-buffering-hang.patch
+)
+
+src_prepare() {
+ default
+
+ # Inject SSH_AUTH_SOCK into user's sessions after enabling gpg-agent-ssh.socket in systemctl --user mode,
+ # idea borrowed from libdbus, see
+ # https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/systemd-user/dbus.socket.in#L6
+ #
+ # This cannot be upstreamed, as it requires determining the exact prefix of 'systemctl',
+ # which in turn requires discovery in Autoconf, something that upstream deeply resents.
+ sed -e "/DirectoryMode=/a ExecStartPost=-${EPREFIX}/bin/systemctl --user set-environment SSH_AUTH_SOCK=%t/gnupg/S.gpg-agent.ssh" \
+ -i doc/examples/systemd-user/gpg-agent-ssh.socket || die
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable bzip2)
+ $(use_enable nls)
+ $(use_enable smartcard scdaemon)
+ $(use_enable ssl gnutls)
+ $(use_enable tofu)
+ $(use_enable tofu keyboxd)
+ $(use_enable tofu sqlite)
+ $(usex tpm '--with-tss=intel' '--disable-tpm2d')
+ $(use smartcard && use_enable usb ccid-driver || echo '--disable-ccid-driver')
+ $(use_enable wks-server wks-tools)
+ $(use_with ldap)
+ $(use_with readline)
+ --with-mailprog=/usr/libexec/sendmail
+ --disable-ntbtls
+ --enable-all-tests
+ --enable-gpgsm
+ --enable-large-secmem
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ GPG_ERROR_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpg-error-config"
+ KSBA_CONFIG="${ESYSROOT}/usr/bin/ksba-config"
+ LIBASSUAN_CONFIG="${ESYSROOT}/usr/bin/libassuan-config"
+ LIBGCRYPT_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-libgcrypt-config"
+ NPTH_CONFIG="${ESYSROOT}/usr/bin/npth-config"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+
+ if use prefix && use usb; then
+ # bug #649598
+ append-cppflags -I"${EPREFIX}/usr/include/libusb-1.0"
+ fi
+
+ #bug 663142
+ if use user-socket; then
+ myconf+=( --enable-run-gnupg-user-socket )
+ fi
+
+ # glib fails and picks up clang's internal stdint.h causing weird errors
+ [[ ${CC} == *clang ]] && \
+ export gl_cv_absolute_stdint_h=/usr/include/stdint.h
+
+ # Hardcode mailprog to /usr/libexec/sendmail even if it does not exist.
+ # As of GnuPG 2.3, the mailprog substitution is used for the binary called
+ # by wks-client & wks-server; and if it's autodetected but not not exist at
+ # build time, then then 'gpg-wks-client --send' functionality will not
+ # work. This has an unwanted side-effect in stage3 builds: there was a
+ # [R]DEPEND on virtual/mta, which also brought in virtual/logger, bloating
+ # the build where the install guide previously make the user chose the
+ # logger & mta early in the install.
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ #Bug: 638574
+ use tofu && export TESTFLAGS=--parallel
+ default
+}
+
+src_install() {
+ default
+
+ use tools &&
+ dobin \
+ tools/{convert-from-106,gpg-check-pattern} \
+ tools/{gpgconf,gpgsplit,lspgpot,mail-signed-keys} \
+ tools/make-dns-cert
+
+ dosym gpg /usr/bin/gpg2
+ dosym gpgv /usr/bin/gpgv2
+ echo ".so man1/gpg.1" > "${ED}"/usr/share/man/man1/gpg2.1 || die
+ echo ".so man1/gpgv.1" > "${ED}"/usr/share/man/man1/gpgv2.1 || die
+
+ dodir /etc/env.d
+ echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >> "${ED}"/etc/env.d/30gnupg || die
+
+ use doc && dodoc doc/gnupg.html/* doc/*.png
+
+ systemd_douserunit doc/examples/systemd-user/*.{service,socket}
+}
diff --git a/app-misc/ca-certificates/ca-certificates-20210119.3.66.ebuild b/app-misc/ca-certificates/ca-certificates-20210119.3.66.ebuild
index 08fedcfa8fe7..2e7b4998455b 100644
--- a/app-misc/ca-certificates/ca-certificates-20210119.3.66.ebuild
+++ b/app-misc/ca-certificates/ca-certificates-20210119.3.66.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# The Debian ca-certificates package merely takes the CA database as it exists
@@ -18,7 +18,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1
diff --git a/app-misc/ca-certificates/ca-certificates-20211016.3.77.ebuild b/app-misc/ca-certificates/ca-certificates-20211016.3.77.ebuild
index 864b59789c1f..fdcdec274b3b 100644
--- a/app-misc/ca-certificates/ca-certificates-20211016.3.77.ebuild
+++ b/app-misc/ca-certificates/ca-certificates-20211016.3.77.ebuild
@@ -18,7 +18,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index 84dfa532c658..0efe3fa9591f 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1 +1,2 @@
DIST jwcrypto-1.0.0.tar.gz 87000 BLAKE2B 6e85d52c26447b07c3d06387ac9e3b7adf585d5dc320c633e80ca2bc1e327f01ac95cec9a0fe2b92f7f8ed7f5650d5ad1a95de500d328b33763d604aaba1bd62 SHA512 12d270219d289041098f875f5b2b0773ffbf9044996a6189b827cafbf3e5dccfc103915275b1a11dce2d50e3510510eea476b024d19cf97fd7c66c25de5b3dbf
+DIST jwcrypto-1.1.0.gh.tar.gz 87344 BLAKE2B 4bc72c01e6d49d68ff8e3c89a09758a5e8a634c308926ed2b750fdc373006b30710a841df4e26e1ce3287be6e4b509674887a0b01cc3b225bc87d97588f5b7a6 SHA512 c7530f68d74247f23ad2d76def257f4f0091203a22d39f248f4a15363b17bdf79699b96775cfb7f909b5b0a99ed1dd73ff5ae30ca8bc41662f1be38933c9f3c1
diff --git a/dev-python/jwcrypto/jwcrypto-1.1.0.ebuild b/dev-python/jwcrypto/jwcrypto-1.1.0.ebuild
new file mode 100644
index 000000000000..b57976ef02c6
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -i "/data_files/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/lark-parser/lark-parser-0.11.3.ebuild b/dev-python/lark-parser/lark-parser-0.11.3.ebuild
deleted file mode 100644
index b5d7c689cbf8..000000000000
--- a/dev-python/lark-parser/lark-parser-0.11.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
-HOMEPAGE="https://github.com/lark-parser/lark"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- "${EPYTHON}" -m tests -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pystache/metadata.xml b/dev-python/pystache/metadata.xml
index dab46bcdc6d0..a2179cb0df58 100644
--- a/dev-python/pystache/metadata.xml
+++ b/dev-python/pystache/metadata.xml
@@ -5,9 +5,6 @@
<email>nerdboy@gentoo.org</email>
<name>Steve Arnold</name>
</maintainer>
-<longdescription lang="en">
- Updated Python implementation of Mustache templating framework.
-</longdescription>
<upstream>
<remote-id type="github">PennyDreadfulMTG/pystache</remote-id>
</upstream>
diff --git a/dev-python/pystache/pystache-0.6.0.ebuild b/dev-python/pystache/pystache-0.6.0.ebuild
index bf1f4437fd2d..df23e888f31c 100644
--- a/dev-python/pystache/pystache-0.6.0.ebuild
+++ b/dev-python/pystache/pystache-0.6.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
inherit distutils-r1
-DESCRIPTION="Python implementation of Mustache"
+DESCRIPTION="Updated Python implementation of Mustache templating framework"
HOMEPAGE="https://github.com/PennyDreadfulMTG/pystache"
if [[ ${PV} = 9999* ]]; then
diff --git a/dev-util/meson/meson-0.59.4.ebuild b/dev-util/meson/meson-0.59.4.ebuild
index 0b7b12ebfbb7..5cdd6345facf 100644
--- a/dev-util/meson/meson-0.59.4.ebuild
+++ b/dev-util/meson/meson-0.59.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2016-2021 Gentoo Authors
+# Copyright 2016-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8,9,10} )
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/mesonbuild/meson"
diff --git a/dev-util/meson/meson-0.60.2-r1.ebuild b/dev-util/meson/meson-0.60.2-r1.ebuild
index dae5370ccd0e..40eae30c4d71 100644
--- a/dev-util/meson/meson-0.60.2-r1.ebuild
+++ b/dev-util/meson/meson-0.60.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2016-2021 Gentoo Authors
+# Copyright 2016-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8,9,10} )
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/mesonbuild/meson"
diff --git a/dev-util/meson/meson-0.60.3.ebuild b/dev-util/meson/meson-0.60.3.ebuild
index 55dd71fc8240..72eb2e56f912 100644
--- a/dev-util/meson/meson-0.60.3.ebuild
+++ b/dev-util/meson/meson-0.60.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8,9,10} )
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/mesonbuild/meson"
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index c094f4683913..f2f7173f5a9a 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -1,4 +1,4 @@
-# Copyright 2017-2021 Gentoo Authors
+# Copyright 2017-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: meson.eclass
@@ -323,6 +323,16 @@ meson_src_configure() {
--build.pkg-config-path "${BUILD_PKG_CONFIG_PATH}${BUILD_PKG_CONFIG_PATH:+:}${EPREFIX}/usr/share/pkgconfig"
--pkg-config-path "${PKG_CONFIG_PATH}${PKG_CONFIG_PATH:+:}${EPREFIX}/usr/share/pkgconfig"
--native-file "$(_meson_create_native_file)"
+
+ # gcc[pch] is masked in profiles due to consistent bugginess
+ # without forcing this off, some packages may fail too (like gjs,
+ # bug #839549), but in any case, we don't want to bother attempting
+ # this.
+ -Db_pch=false
+
+ # It's Gentoo policy to not have builds die on blanket -Werror, as it's
+ # an upstream development matter. bug #754279.
+ -Dwerror=false
)
if [[ -n ${EMESON_BUILDTYPE} ]]; then
diff --git a/net-irc/hexchat/metadata.xml b/net-irc/hexchat/metadata.xml
index 37c5ea55f06c..4151d1550643 100644
--- a/net-irc/hexchat/metadata.xml
+++ b/net-irc/hexchat/metadata.xml
@@ -8,7 +8,6 @@
<use>
<flag name="libcanberra">Enable sound event support using
<pkg>media-libs/libcanberra</pkg></flag>
- <flag name="libproxy">Enable proxy support.</flag>
<flag name="plugin-checksum">Build Checksum plugin
(needs plugins)</flag>
<flag name="plugin-fishlim">Build FiSHLiM plugin (needs plugins