summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2018-04-13 12:54:58 -0500
committerDenis Dupeyron <calchan@gentoo.org>2018-04-13 12:54:58 -0500
commitda435ad7c031bed8810a77859e05bb14b0db12f4 (patch)
treeccd12c59257d16bb73ac7ce1ff5fca4b8ad068cd /xfce-extra
parentmedia-libs/glm: Fix tests with GCC-7 (diff)
downloadgentoo-da435ad7c031bed8810a77859e05bb14b0db12f4.tar.gz
gentoo-da435ad7c031bed8810a77859e05bb14b0db12f4.tar.bz2
gentoo-da435ad7c031bed8810a77859e05bb14b0db12f4.zip
xfce4-linelight-plugin: remove obsolete xfconf.eclass, migrate to EAPI6
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..a6a273c7bb26
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools multilib
+
+DESCRIPTION="A simple locate based search plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2"
+#SRC_URI="http://svn.ganymede.ch/private/trunk/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.12:2
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfcegui4-4.8"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/mlocate"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}"/${P}-port-to-xfcerc.patch
+ default
+}
+
+src_configure() {
+ AT_M4DIR=${EPREFIX}/usr/share/xfce4/dev-tools/m4macros eautoreconf
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}