summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-25 08:53:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-25 08:53:44 +0100
commit465840d28dfce6fe0eeaa2394a2b453b9b03719b (patch)
tree1f7c118aa3d872466db39c5123db56917c01de21 /xfce-extra
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.11 (diff)
downloadgentoo-465840d28dfce6fe0eeaa2394a2b453b9b03719b.tar.gz
gentoo-465840d28dfce6fe0eeaa2394a2b453b9b03719b.tar.bz2
gentoo-465840d28dfce6fe0eeaa2394a2b453b9b03719b.zip
xfce-extra/xfce4-genmon-plugin: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-genmon-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.2.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-genmon-plugin/Manifest b/xfce-extra/xfce4-genmon-plugin/Manifest
index a132f815b187..c21fc724b9a1 100644
--- a/xfce-extra/xfce4-genmon-plugin/Manifest
+++ b/xfce-extra/xfce4-genmon-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-genmon-plugin-4.1.1.tar.bz2 400772 BLAKE2B 949f2012bd7037d50997e83c555a2d2b33269f233f676d8acc5a195ac194d435cf7f3f5bd1eac1352e57b0463af1f6302b602bedb6ef9c4e2582724c00b96159 SHA512 663dabcdfb9d85325be5bc000f44e6cd61f78143e6d49bc7c481d14eccc3601408e2a7bed1276de5fcb24e75af66d8765fd0dc373dc8b82c1118fb5da2673c03
+DIST xfce4-genmon-plugin-4.2.1.tar.bz2 484379 BLAKE2B 0897c2cf4598c3e6bf1253deee6d53d56eca2bfb8f2926044d650995d4a619e4c8596121a9d03c575bd66da60052c4d93ef8476e902defed88b80219ed422d58 SHA512 c961462b67fcf001147d7a930bc443cceaa0e4b52ac511a38885072e995b21e5a1e047ea1ed9f30399c73d4f4bc8feda88e1b19a94cd7ce3ae272153c4767af9
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.2.1.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.2.1.ebuild
new file mode 100644
index 000000000000..6b75f44c4263
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Cyclically spawned executable output on the panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-genmon-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-genmon-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}