summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-14 23:36:27 +0000
committerSam James <sam@gentoo.org>2021-12-14 23:36:32 +0000
commit1cfeef27953f5c1b66bfbb270ce8b7a444899850 (patch)
tree43156ca2cd6119dc4c10a441fb1abfeaba69485a /xfce-extra
parentdev-libs/boost: require patched boost-build for 1.78 (fix Python bindings) (diff)
downloadgentoo-1cfeef27953f5c1b66bfbb270ce8b7a444899850.tar.gz
gentoo-1cfeef27953f5c1b66bfbb270ce8b7a444899850.tar.bz2
gentoo-1cfeef27953f5c1b66bfbb270ce8b7a444899850.zip
xfce-extra/xfce4-wavelan-plugin: update EAPI 7 -> 8, add build patch
Revbumping for EAPI 8 + the build patch given that it could (but shouldn't) affect runtime behaviour. Closes: https://bugs.gentoo.org/799827 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch55
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild31
2 files changed, 86 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch b/xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch
new file mode 100644
index 000000000000..bc27e2c12afc
--- /dev/null
+++ b/xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch
@@ -0,0 +1,55 @@
+https://gitlab.xfce.org/panel-plugins/xfce4-wavelan-plugin/-/merge_requests/4
+https://bugs.gentoo.org/799827
+
+From: Olaf Hering <olaf@aepfle.de>
+Date: Fri, 25 Jun 2021 19:37:09 +0200
+Subject: [PATCH] remove bogus close function
+
+Just close the file descriptor, instead of doing shutdown.
+
+Not doing so was already wrong in 2006.
+
+wi_linux.c:83:1: error: conflicting types for 'close'
+ close(int fd)
+ ^~~~~
+In file included from /usr/include/glib-2.0/gio/gcredentials.h:32:0,
+ from /usr/include/glib-2.0/gio/gio.h:46,
+ from /usr/include/xfce4/libxfce4util/xfce-gio-extensions.h:28,
+ from /usr/include/xfce4/libxfce4util/libxfce4util.h:40,
+ from wi_linux.c:32:
+/usr/include/unistd.h:353:12: note: previous declaration of 'close' was here
+ extern int close (int __fd);
+ ^~~~~
+make[2]: *** [Makefile:525: libwavelan_la-wi_linux.lo] Error 1
+make[2]: Leaving directory '/home/abuild/rpmbuild/BUILD/xfce4-wavelan-plugin-20210505T194034.7ba466b/panel-plugin'
+
+Signed-off-by: Olaf Hering <olaf@aepfle.de>
+--- a/panel-plugin/wi_linux.c
++++ b/panel-plugin/wi_linux.c
+@@ -31,6 +31,7 @@
+
+ #include <libxfce4util/libxfce4util.h>
+
++#include <unistd.h>
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -79,17 +80,9 @@ wi_open(const char *interface)
+ return(device);
+ }
+
+-static void
+-close(int fd)
+-{
+- shutdown(fd, SHUT_RDWR);
+-}
+-
+ void
+ wi_close(struct wi_device *device)
+ {
+- g_return_if_fail(device != NULL);
+-
+ close(device->socket);
+ g_free(device);
+ }
+GitLab
diff --git a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..5931287d80d2
--- /dev/null
+++ b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A panel plug-in to display wireless interface statistics"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-wavelan-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux"
+
+DEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+RDEPEND="${DEPEND}
+ kernel_linux? ( sys-apps/net-tools )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-close-definition.patch
+)
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}