summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-28 22:00:31 +0100
committerMichał Górny <mgorny@gentoo.org>2015-10-28 22:00:31 +0100
commit6c8330e03645f18866a038e1df348ec1365dde3b (patch)
tree4cdc2d874eb41ada85bf9947a2875582c7d61d48 /xfce-extra/xfce4-pulseaudio-plugin
parentdev-perl/Pango: Add patch preventing failure at compile time. Fixes bug 562216. (diff)
downloadgentoo-6c8330e03645f18866a038e1df348ec1365dde3b.tar.gz
gentoo-6c8330e03645f18866a038e1df348ec1365dde3b.tar.bz2
gentoo-6c8330e03645f18866a038e1df348ec1365dde3b.zip
xfce-extra/xfce4-pulseaudio-plugin: bump to 0.2.4 (minor fixes)
Release notes for 0.2.4 ======================= * Added a configuration option "show-notifications". * Reconnect to the PA server when the connection is lost. * Fixes to the notification update mechanism.
Diffstat (limited to 'xfce-extra/xfce4-pulseaudio-plugin')
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/Manifest b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
index 1e0ed0f73e52..9b7620ab513f 100644
--- a/xfce-extra/xfce4-pulseaudio-plugin/Manifest
+++ b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-pulseaudio-plugin-0.2.2.tar.bz2 324250 SHA256 67c04ab9a3932d74480f42461aafe779b68de4388db3f7546966a3967376c6d8 SHA512 d7640637de7fb295bea0b1d29e8b75e854926aab96847018a60a86f6fdb6a408328688285767ee1b34109df06bd7fb1ee907798b7f60bcbb095294d743e1b32f WHIRLPOOL 10b5df905e7d3ff6beec9bc11c0d572ae38635fc18c114ad42a10e61e0a0e24c1bc2813b08926896f1f529a053c021e13a5af291158e989cf3ce4ef4579fbdbf
DIST xfce4-pulseaudio-plugin-0.2.3.tar.bz2 306349 SHA256 e82836bc8cf7d905b4e60d43dc630ba8e32dea785989700c71d4aeee9f583b33 SHA512 9440e68b81be0845be4da88154db6e407891d5cc7504e46bc5dd7deac36bfba7354b38b7658e099fdd40fe581bd6e549ae1c6655a2d05df1f297ec944db47cc6 WHIRLPOOL e1fef58d0a510b9121a36e131f72f5b8333bf86ee8c50ece978ca66697cd8fbf21903d35d67639b4ec2dd2493c18f8603efe14ebd51626168721807ad5091143
+DIST xfce4-pulseaudio-plugin-0.2.4.tar.bz2 307315 SHA256 8d9330ddf1d44a864a36d566cce4b76d4f859c5984bba7653d7dc39aa24d5c3e SHA512 b53ab48e282a506fc7fe91fa70520f0db32f2f73653a0210681bf7389f13441d5af8f855604b59817b1fe7a3f41e2d4fe52b052ac0c3479f3f4e37b2afedb193 WHIRLPOOL 8763a9422a7519b5603703306d968f9e020c1bd4b304be0d21bd6353c54e8fa979ef68c513d6e1c398ce6857ad88807a7cb7eefc29d6fba4f12a243eb7205e26
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild
new file mode 100644
index 000000000000..01b51235845b
--- /dev/null
+++ b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plug-in for PulseAudio volume control"
+HOMEPAGE="https://github.com/andrzej-r/xfce4-pulseaudio-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="debug keybinder libnotify"
+
+RDEPEND=">=dev-libs/glib-2.24.0:=
+ media-sound/pulseaudio:=
+ >=x11-libs/gtk+-3.6.0:3=
+ >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.9.0:=
+ >=xfce-base/xfce4-panel-4.11.0:=
+ >=xfce-base/xfconf-4.6.0:=
+ keybinder? ( dev-libs/keybinder:3= )
+ libnotify? ( x11-libs/libnotify:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable keybinder)
+ $(use_enable libnotify)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}