summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-27 05:46:18 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-27 05:46:18 +0200
commit968649d789dfc35e8e53a9df688bc76b07dc9562 (patch)
treece2ce6b7a241a1fe36191f514593ccd42c6e85b3 /xfce-base
parentapp-editors/retext: add 8.0.2 (diff)
downloadgentoo-968649d789dfc35e8e53a9df688bc76b07dc9562.tar.gz
gentoo-968649d789dfc35e8e53a9df688bc76b07dc9562.tar.bz2
gentoo-968649d789dfc35e8e53a9df688bc76b07dc9562.zip
xfce-base/xfdesktop: Fix segv with a followup backport
I am very sorry for messing this up and not including the other upstream fix. Closes: https://bugs.gentoo.org/904468 Closes: https://bugs.gentoo.org/930736 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch80
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.19.2-r2.ebuild (renamed from xfce-base/xfdesktop/xfdesktop-4.19.2-r1.ebuild)0
2 files changed, 67 insertions, 13 deletions
diff --git a/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch b/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch
index e384ef578a1d..4c31dbd777e2 100644
--- a/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch
+++ b/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch
@@ -1,25 +1,79 @@
-From 439bf8a8cd36796c33ae0b413641338417c9a911 Mon Sep 17 00:00:00 2001
+From e3807249480b48ad403f94d62c39afca9251b149 Mon Sep 17 00:00:00 2001
From: "Brian J. Tarricone" <brian@tarricone.org>
-Date: Thu, 25 Apr 2024 23:28:24 -0700
-Subject: [PATCH] Fix some default settings not being applied on startup
+Date: Fri, 26 Apr 2024 01:20:14 -0700
+Subject: [PATCH] Fix invalid param flags
-Closes #242.
---
- src/xfce-desktop.c | 1 +
- 1 file changed, 1 insertion(+)
+ src/xfce-desktop.c | 20 ++++++--------------
+ 1 file changed, 6 insertions(+), 14 deletions(-)
diff --git a/src/xfce-desktop.c b/src/xfce-desktop.c
-index e79e83305..b4f837ef5 100644
+index b4f837ef..37b4b277 100644
--- a/src/xfce-desktop.c
+++ b/src/xfce-desktop.c
-@@ -731,6 +731,7 @@ xfce_desktop_class_init(XfceDesktopClass *klass)
+@@ -730,31 +730,26 @@ xfce_desktop_class_init(XfceDesktopClass *klass)
+ widget_class->popup_menu = xfce_desktop_popup_menu;
widget_class->style_updated = xfce_desktop_style_updated;
- #define XFDESKTOP_PARAM_FLAGS (G_PARAM_READWRITE \
-+ | G_PARAM_CONSTRUCT \
- | G_PARAM_STATIC_NAME \
- | G_PARAM_STATIC_NICK \
- | G_PARAM_STATIC_BLURB)
+-#define XFDESKTOP_PARAM_FLAGS (G_PARAM_READWRITE \
+- | G_PARAM_STATIC_NAME \
+- | G_PARAM_STATIC_NICK \
+- | G_PARAM_STATIC_BLURB)
+-
+ g_object_class_install_property(gobject_class, PROP_SCREEN,
+ g_param_spec_object("screen",
+ "gdk screen",
+ "gdk screen",
+ GDK_TYPE_SCREEN,
+- XFDESKTOP_PARAM_FLAGS | G_PARAM_CONSTRUCT_ONLY));
++ G_PARAM_READWRITE | G_PARAM_CONSTRUCT_ONLY | G_PARAM_STATIC_STRINGS));
+
+ g_object_class_install_property(gobject_class, PROP_CHANNEL,
+ g_param_spec_object("channel",
+ "xfconf channel",
+ "xfconf channel",
+ XFCONF_TYPE_CHANNEL,
+- XFDESKTOP_PARAM_FLAGS | G_PARAM_CONSTRUCT_ONLY));
++ G_PARAM_READWRITE | G_PARAM_CONSTRUCT_ONLY | G_PARAM_STATIC_STRINGS));
+
+ g_object_class_install_property(gobject_class, PROP_PROPERTY_PREFIX,
+ g_param_spec_string("property-prefix",
+ "xfconf property prefix",
+ "xfconf property prefix",
+ "",
+- XFDESKTOP_PARAM_FLAGS | G_PARAM_CONSTRUCT_ONLY));
++ G_PARAM_READWRITE | G_PARAM_CONSTRUCT_ONLY | G_PARAM_STATIC_STRINGS));
+
+ #ifdef ENABLE_DESKTOP_ICONS
+ g_object_class_install_property(gobject_class, PROP_ICON_STYLE,
+@@ -768,7 +762,7 @@ xfce_desktop_class_init(XfceDesktopClass *klass)
+ #else
+ XFCE_DESKTOP_ICON_STYLE_WINDOWS,
+ #endif /* ENABLE_FILE_ICONS */
+- XFDESKTOP_PARAM_FLAGS));
++ G_PARAM_READWRITE | G_PARAM_CONSTRUCT | G_PARAM_STATIC_STRINGS));
+ #endif /* ENABLE_DESKTOP_ICONS */
+
+ g_object_class_install_property(gobject_class, PROP_SINGLE_WORKSPACE_MODE,
+@@ -776,16 +770,14 @@ xfce_desktop_class_init(XfceDesktopClass *klass)
+ "single-workspace-mode",
+ "single-workspace-mode",
+ TRUE,
+- XFDESKTOP_PARAM_FLAGS));
++ G_PARAM_READWRITE | G_PARAM_CONSTRUCT | G_PARAM_STATIC_STRINGS));
+
+ g_object_class_install_property(gobject_class, PROP_SINGLE_WORKSPACE_NUMBER,
+ g_param_spec_int("single-workspace-number",
+ "single-workspace-number",
+ "single-workspace-number",
+ 0, G_MAXINT16, 0,
+- XFDESKTOP_PARAM_FLAGS));
+-
+-#undef XFDESKTOP_PARAM_FLAGS
++ G_PARAM_READWRITE | G_PARAM_CONSTRUCT | G_PARAM_STATIC_STRINGS));
+
+ xfce_desktop_settings_bindings_init();
+ }
--
GitLab
diff --git a/xfce-base/xfdesktop/xfdesktop-4.19.2-r1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.19.2-r2.ebuild
index c5ec981ee642..c5ec981ee642 100644
--- a/xfce-base/xfdesktop/xfdesktop-4.19.2-r1.ebuild
+++ b/xfce-base/xfdesktop/xfdesktop-4.19.2-r2.ebuild