summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 17:36:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 19:57:50 +0200
commit4facf800aef58b30fbaabab910deae90223bf479 (patch)
tree70572efe35656160c7fd8887b606ae666cba1f22 /xfce-base
parentwww-client/microsoft-edge-beta: remove old (diff)
downloadgentoo-4facf800aef58b30fbaabab910deae90223bf479.tar.gz
gentoo-4facf800aef58b30fbaabab910deae90223bf479.tar.bz2
gentoo-4facf800aef58b30fbaabab910deae90223bf479.zip
xfce-base/thunar: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.19.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 95a71a6b35fe..214bdfdaa226 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1 +1,2 @@
DIST thunar-4.18.7.tar.bz2 2841751 BLAKE2B c5b2d60e4f94a172ed02a0999694a0a3dee57d9a335ec5da6bc4e608e1ce8d81c823b92dd32133054482351f24b47343664b1b1bb18b2e6836ff4463e764f1a4 SHA512 bbe567bad7c020489c3895109daf14edceef4d6301ac430f36c3036017a5d66d706aecd85471b9e41d25b7cbcfd86fefc4c14f904d4b38d19fb7ecea081f6eb9
+DIST thunar-4.19.0.tar.bz2 2924690 BLAKE2B 9d8cf10d3eae16c84489098b28020470b353f970ea561ff8dce2caccd7086ed39cae3796df26489b3a8586c0bd8d008a2d9953017b71cad2a760d498b60c1b15 SHA512 1db58776fe39f9f4c2f215b52a2209dac773e8b708e4796752630703531e1ddd9017e32e1fe779c5fcc5d543438bbebf14f510b9361fde22fe0045ac0fd3a87f
diff --git a/xfce-base/thunar/thunar-4.19.0.ebuild b/xfce-base/thunar/thunar-4.19.0.ebuild
new file mode 100644
index 000000000000..ac62186f4aa0
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.19.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/start
+ https://gitlab.xfce.org/xfce/thunar/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+DEPEND="
+ >=dev-libs/glib-2.70.0
+ >=x11-libs/gdk-pixbuf-2.40.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/exo-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.6:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre2-10.0:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? (
+ >=gnome-base/gvfs-1.18.3
+ )
+ udisks? (
+ >=gnome-base/gvfs-1.18.3[udisks,udev]
+ virtual/udev
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre pcre2)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}