summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/goomwwm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/goomwwm')
-rw-r--r--x11-wm/goomwwm/Manifest1
-rw-r--r--x11-wm/goomwwm/goomwwm-1.0.0.ebuild44
-rw-r--r--x11-wm/goomwwm/metadata.xml9
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/goomwwm/Manifest b/x11-wm/goomwwm/Manifest
new file mode 100644
index 000000000000..488ee85f6618
--- /dev/null
+++ b/x11-wm/goomwwm/Manifest
@@ -0,0 +1 @@
+DIST goomwwm-1.0.0.tar.gz 69967 SHA256 2c65c9002e8254bc51f86c8bdf8b1a04f24c2c6006bbe6244cc85e9e8b9679ae SHA512 a2d486e7b97ef3dd0c6eb0702a21e51853ed1456aee7c1d11c90561a62218a4970a61ebb9ba7551428d72035066d7be445a952083baf9c53957e351ad8f4b5de WHIRLPOOL 6b86018714f4752e3250d8bc495290142d723fbfaaf0e36a426f84f5c31ca2aab38409f84e543d5844c121265ce49137c01d5263d8090eb398d0ddb9564c5e4a
diff --git a/x11-wm/goomwwm/goomwwm-1.0.0.ebuild b/x11-wm/goomwwm/goomwwm-1.0.0.ebuild
new file mode 100644
index 000000000000..3274473731aa
--- /dev/null
+++ b/x11-wm/goomwwm/goomwwm-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Get out of my way, Window Manager!"
+HOMEPAGE="http://aerosuidae.net/goomwwm/"
+SRC_URI="http://aerosuidae.net/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libXft
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ sed -i -e 's|$(LDADD) $(LDFLAGS)|$(LDFLAGS) $(LDADD)|g' Makefile || die
+}
+
+src_configure() {
+ use debug && append-cflags -DDEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) proto normal
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/x11-wm/goomwwm/metadata.xml b/x11-wm/goomwwm/metadata.xml
new file mode 100644
index 000000000000..704d8f91190c
--- /dev/null
+++ b/x11-wm/goomwwm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
+