summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-22 04:37:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-22 05:38:26 +0100
commit9695119d8055dcdaa76dbe3df2d73e220f3270d8 (patch)
treef71617f736d51d8a36f00dfa999c5977e061278b /x11-themes
parentx11-themes/elementary-xfce-icon-theme: Remove old (diff)
downloadgentoo-9695119d8055dcdaa76dbe3df2d73e220f3270d8.tar.gz
gentoo-9695119d8055dcdaa76dbe3df2d73e220f3270d8.tar.bz2
gentoo-9695119d8055dcdaa76dbe3df2d73e220f3270d8.zip
x11-themes/elementary-xfce-icon-theme: Bump to 0.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/Manifest1
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.19.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/Manifest b/x11-themes/elementary-xfce-icon-theme/Manifest
index f341504842bc..eeb0f0ef20b1 100644
--- a/x11-themes/elementary-xfce-icon-theme/Manifest
+++ b/x11-themes/elementary-xfce-icon-theme/Manifest
@@ -1 +1,2 @@
DIST elementary-xfce-0.18.tar.gz 6915651 BLAKE2B b9d1674296c2648f6ad3f31cd5162c44b2c472761dd57811138d97cf42a1e52576fca9541bf63337fcf9208736845f982b9b71deb76f43d6114ac99ab095492d SHA512 50157429c1c702e3b167168d7f28de8b61439fb00b926326cea9ff1f60753134be79ce3685987f3875a6609b45697bac55b0d31920e47deb3ba8c39185d9ea39
+DIST elementary-xfce-0.19.tar.gz 7130377 BLAKE2B ee9d94b609fbd1537519f365030996eec2da2f4890380506a5a78ce138ca5174827d0c4ac98850911fe317bfaf64483cbcb06bf40de220493387855eec228a53 SHA512 e36482877e791bdd39a1e0c1e8d5de60865e5845036fb1e5436e62908a4c700adf01b394e5f99ce82abe834aac8dd4d71a17fe4a85de8b50b8a41a2afe3ebbf1
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.19.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.19.ebuild
new file mode 100644
index 000000000000..f5287635df60
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg toolchain-funcs
+
+MY_P="${PN%-icon-theme}-${PV}"
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/elementary-xfce/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ media-gfx/optipng
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+
+src_prepare() {
+ sed -i -e 's:-Werror -O0 -pipe:${CFLAGS} ${CPPFLAGS} ${LDFLAGS}:' \
+ svgtopng/Makefile || die
+ default
+}
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ # delete dangling doc links
+ find -L "${D}" -type l -delete || die
+}