summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-18 05:01:39 +0100
committerSam James <sam@gentoo.org>2021-07-18 05:02:17 +0100
commit505fd180e97562c9b68495ad0a6bd24d44e233cf (patch)
treea1eb9692654eb44fd2697afe96a59d59e0cab86a /x11-themes
parentx11-themes/gnome-colors-themes: update EAPI 6 -> 7 (diff)
downloadgentoo-505fd180e97562c9b68495ad0a6bd24d44e233cf.tar.gz
gentoo-505fd180e97562c9b68495ad0a6bd24d44e233cf.tar.bz2
gentoo-505fd180e97562c9b68495ad0a6bd24d44e233cf.zip
x11-themes/gnome-colors-common: update EAPI 6 -> 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r1.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r1.ebuild b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r1.ebuild
index 6d9348d2499c..2370f83c992f 100644
--- a/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r1.ebuild
+++ b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit gnome2-utils
DESCRIPTION="Colorized icons shared between all gnome-colors iconsets"
HOMEPAGE="https://code.google.com/p/gnome-colors/"
-
SRC_URI="https://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
- branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
-"
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+S="${WORKDIR}"
LICENSE="
GPL-2
@@ -20,33 +20,28 @@ KEYWORDS="amd64 x86"
IUSE="+branding"
RDEPEND="x11-themes/adwaita-icon-theme"
-DEPEND=""
RESTRICT="binchecks strip"
-S="${WORKDIR}"
-
src_prepare() {
default
+
if use branding; then
for i in 16 22 24 32 ; do
cp tango-gentoo-v1.1/${i}x${i}/gentoo.png \
- gnome-colors-common/${i}x${i}/places/start-here.png \
+ gnome-colors-common/${i}x${i}/places/start-here.png \
|| die "Copying gentoo logos failed"
done
+
cp tango-gentoo-v1.1/scalable/gentoo.svg \
- gnome-colors-common/scalable/places/start-here.svg \
+ gnome-colors-common/scalable/places/start-here.svg \
|| die "Copying scalable logo failed"
fi
}
-src_compile() {
- einfo "Nothing to compile"
-}
-
src_install() {
- dodir /usr/share/icons
insinto /usr/share/icons
doins -r "${WORKDIR}/${PN}"
+
einstalldocs
}