summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-03 01:05:26 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-08 20:22:58 +0200
commitc4031af5ccc64cc15bad17e4f30afea266675f03 (patch)
tree50823c2b0dca42fdc774c4197a56f2303d307ae9 /x11-themes/gnome-themes-standard
parentx11-themes/gtk-engines-adwaita: GTK+2 Adwaita theme engine (diff)
downloadgentoo-c4031af5ccc64cc15bad17e4f30afea266675f03.tar.gz
gentoo-c4031af5ccc64cc15bad17e4f30afea266675f03.tar.bz2
gentoo-c4031af5ccc64cc15bad17e4f30afea266675f03.zip
x11-themes/gnome-themes-standard: split theme engine out
To x11-themes/gtk-engines-adwaita Gentoo-bug: 569552 Package-Manager: portage-2.3.1
Diffstat (limited to 'x11-themes/gnome-themes-standard')
-rw-r--r--x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.20.2-exclude-engine.patch48
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2-r1.ebuild50
2 files changed, 98 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.20.2-exclude-engine.patch b/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.20.2-exclude-engine.patch
new file mode 100644
index 000000000000..fd48594f6a30
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.20.2-exclude-engine.patch
@@ -0,0 +1,48 @@
+From 15f99289cfa0d845cb8381b7151c938ca8531698 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 3 Oct 2016 00:38:57 +0200
+Subject: [PATCH] Control build of gtk+2 adwaita theme engine from configure
+
+Rather than whole gtk+-2 theme.
+
+This only makes sense in Gentoo as the theme engine has been split to
+a separate package to allow gtk+2 free systems.
+---
+ themes/Adwaita/Makefile.am | 6 +-----
+ themes/Adwaita/gtk-2.0/Makefile.am | 2 ++
+ 2 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/themes/Adwaita/Makefile.am b/themes/Adwaita/Makefile.am
+index 8583535..617b9a6 100644
+--- a/themes/Adwaita/Makefile.am
++++ b/themes/Adwaita/Makefile.am
+@@ -1,8 +1,4 @@
+-SUBDIRS = gtk-3.0
+-
+-if GTK2_ENGINE
+-SUBDIRS += gtk-2.0
+-endif
++SUBDIRS = gtk-2.0 gtk-3.0
+
+ THEME_NAME=Adwaita
+ THEME_IN_FILES=index.theme.in
+diff --git a/themes/Adwaita/gtk-2.0/Makefile.am b/themes/Adwaita/gtk-2.0/Makefile.am
+index b78f7dc..1c73e67 100644
+--- a/themes/Adwaita/gtk-2.0/Makefile.am
++++ b/themes/Adwaita/gtk-2.0/Makefile.am
+@@ -1,3 +1,4 @@
++if GTK2_ENGINE
+ enginedir = $(libdir)/gtk-2.0/$(GTK2_VERSION)/engines
+ engine_LTLIBRARIES = libadwaita.la
+
+@@ -5,6 +6,7 @@ libadwaita_la_CFLAGS = $(GTK2_ENGINE_CFLAGS)
+ libadwaita_la_SOURCES = adwaita_engine.c
+ libadwaita_la_LDFLAGS = -module -avoid-version -no-undefined
+ libadwaita_la_LIBADD = $(GTK2_ENGINE_LIBS)
++endif
+
+ themedir = $(datadir)/themes/Adwaita/gtk-2.0
+ theme_DATA = gtkrc main.rc apps.rc
+--
+2.10.0
+
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2-r1.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2-r1.ebuild
new file mode 100644
index 000000000000..149de2869113
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools gnome.org
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="
+ >=gnome-base/gsettings-desktop-schemas-3.4
+"
+DEPEND="
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=746920
+ "${FILESDIR}"/${PN}-3.14.2.3-srcdir.patch
+ # Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
+ "${FILESDIR}"/${PN}-3.20.2-exclude-engine.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --disable-gtk2-engine \
+ --disable-gtk3-engine \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+}