summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2019-03-08 08:14:43 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2019-03-08 08:35:23 +0300
commit68f5b8b148db1d98afa336086c9f3f07e6593cd1 (patch)
tree5dae5b05580652f1ce7653770d9b42aed339810a /x11-plugins
parentx11-wm/e16: Add E16 back to the tree (diff)
downloadgentoo-68f5b8b148db1d98afa336086c9f3f07e6593cd1.tar.gz
gentoo-68f5b8b148db1d98afa336086c9f3f07e6593cd1.tar.bz2
gentoo-68f5b8b148db1d98afa336086c9f3f07e6593cd1.zip
x11-plugins/e16-epplets: Re-add e16 epplets to the tree
Re-introduce E16 epplets to the tree. They was formely packaged as x11-plugins/epplets. The name is changed to conform upstream. USE flags are added, EAPI bumped to 7. Static libs are removed since they are useless. Bug: https://bugs.gentoo.org/658860 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/e16-epplets/Manifest1
-rw-r--r--x11-plugins/e16-epplets/e16-epplets-0.16.ebuild49
-rw-r--r--x11-plugins/e16-epplets/metadata.xml22
3 files changed, 72 insertions, 0 deletions
diff --git a/x11-plugins/e16-epplets/Manifest b/x11-plugins/e16-epplets/Manifest
new file mode 100644
index 000000000000..5fbf1f3995b3
--- /dev/null
+++ b/x11-plugins/e16-epplets/Manifest
@@ -0,0 +1 @@
+DIST e16-epplets-0.16.tar.xz 800796 BLAKE2B 70785fce2949bb5e3b0f950436e63246b576dc2dc13ac392e2d884f913e0f22e68b428b416e20807adfb47ca7a148bb3242efff6dbeac8c734ed645ff3f1c705 SHA512 2cc90dee741a50f54665078db6197d7736d5423419439e640d5170057b80111458dbf4b7c9a92898e96654b1af4a986e5cedb88a565616e70ed0fba6ec82cd9b
diff --git a/x11-plugins/e16-epplets/e16-epplets-0.16.ebuild b/x11-plugins/e16-epplets/e16-epplets-0.16.ebuild
new file mode 100644
index 000000000000..130edb033503
--- /dev/null
+++ b/x11-plugins/e16-epplets/e16-epplets-0.16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Enlightenment DR16 epplets"
+HOMEPAGE="https://www.enlightenment.org https://sourceforge.net/projects/enlightenment/"
+SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2+ BSD public-domain"
+SLOT="0"
+IUSE="cdaudio libgtop opengl"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ cdaudio? ( media-libs/libcdaudio )
+ libgtop? ( gnome-base/libgtop )
+ opengl? ( media-libs/glu media-libs/mesa )
+ >=media-libs/imlib2-1.2.0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-wm/e16
+"
+RDEPEND="${CDEPEND}
+ !x11-plugins/epplets
+"
+DEPEND="${CDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable cdaudio)
+ $(use_enable opengl glx)
+ $(use_with libgtop)
+ --disable-esd
+ --disable-static
+ --disable-werror
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}"/usr -name '*.la' -delete || die
+}
diff --git a/x11-plugins/e16-epplets/metadata.xml b/x11-plugins/e16-epplets/metadata.xml
new file mode 100644
index 000000000000..8f913313833b
--- /dev/null
+++ b/x11-plugins/e16-epplets/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <use>
+ <flag name="cdaudio">Enable CD Audio support using <pkg>media-libs/libcdaudio</pkg></flag>
+ <flag name="libgtop">Use <pkg>gnome-base/libgtop</pkg> to obtain system load information</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">enlightenment</remote-id>
+ </upstream>
+ <longdescription>
+ Epplets are small, handy Enlightenment applets, similar to "dockapps"
+ or "applets" for other packages. The epplets package contains the
+ base epplet API library and header files, as well as the core set of
+ epplets, including CPU monitors, clocks, a mail checker, mixers, a
+ slideshow, a URL grabber, a panel-like toolbar, and more.
+ </longdescription>
+</pkgmetadata>