summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 19:06:35 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:31 +0200
commit6e37f846bbe464203af798a18978ba1975d55d22 (patch)
tree53f460cac4161c83488c3f051251e5d292f0cc85 /x11-plugins/wmtop
parentx11-plugins/wmtimer: EAPI8 bump (diff)
downloadgentoo-6e37f846bbe464203af798a18978ba1975d55d22.tar.gz
gentoo-6e37f846bbe464203af798a18978ba1975d55d22.tar.bz2
gentoo-6e37f846bbe464203af798a18978ba1975d55d22.zip
x11-plugins/wmtop: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmtop')
-rw-r--r--x11-plugins/wmtop/wmtop-0.85-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/wmtop/wmtop-0.85-r1.ebuild b/x11-plugins/wmtop/wmtop-0.85-r1.ebuild
new file mode 100644
index 000000000000..395390c32b00
--- /dev/null
+++ b/x11-plugins/wmtop/wmtop-0.85-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dockapp for monitoring the top three processes using cpu or memory"
+HOMEPAGE="https://www.dockapps.net/wmtop"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+# Incorrect path in this tarball version
+S="${WORKDIR}/dockapps-be3f170"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}