summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmtimer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmtimer')
-rw-r--r--x11-plugins/wmtimer/Manifest1
-rw-r--r--x11-plugins/wmtimer/files/wmtimer-counter-fix.patch22
-rw-r--r--x11-plugins/wmtimer/metadata.xml11
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild43
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92.ebuild41
5 files changed, 118 insertions, 0 deletions
diff --git a/x11-plugins/wmtimer/Manifest b/x11-plugins/wmtimer/Manifest
new file mode 100644
index 000000000000..2f4408faa41e
--- /dev/null
+++ b/x11-plugins/wmtimer/Manifest
@@ -0,0 +1 @@
+DIST wmtimer-2.92.tar.gz 22091 SHA256 3726c0e0a0a95ce7c4c9dd8088b3f050d5268f70fef9341452f5449cef8c0cd4
diff --git a/x11-plugins/wmtimer/files/wmtimer-counter-fix.patch b/x11-plugins/wmtimer/files/wmtimer-counter-fix.patch
new file mode 100644
index 000000000000..62f2a5a82795
--- /dev/null
+++ b/x11-plugins/wmtimer/files/wmtimer-counter-fix.patch
@@ -0,0 +1,22 @@
+--- wmtimer.c.orig 2004-01-29 02:45:48.000000000 +0000
++++ wmtimer.c 2008-10-17 20:49:05.000000000 +0100
+@@ -128,7 +128,8 @@
+ switch (mode)
+ {
+ case TIMER:
+- if (prevSec < thisTime->tm_sec)
++ if ( (prevSec < thisTime->tm_sec)
++ || ((prevSec == 59) && (thisTime->tm_sec == 0)))
+ {
+ decrementTimer();
+ updateACT();
+@@ -138,7 +139,8 @@
+ prevSec = thisTime->tm_sec;
+ break;
+ case CHRONO:
+- if (prevSec < thisTime->tm_sec)
++ if ( (prevSec < thisTime->tm_sec)
++ || ((prevSec == 59) && (thisTime->tm_sec == 0)))
+ {
+ incrementTimer();
+ updateACT();
diff --git a/x11-plugins/wmtimer/metadata.xml b/x11-plugins/wmtimer/metadata.xml
new file mode 100644
index 000000000000..f35d31cbb343
--- /dev/null
+++ b/x11-plugins/wmtimer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+WMTimer is a dockable alarm clock for Windowmaker or Blackbox which can be run
+in alarm, countdown timer, or chronograph mode. In alarm or timer mode, you can
+either execute a command or sound the system bell when the time is reached.
+WMTimer is configurable through the command line or the GTK GUI.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild b/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
new file mode 100644
index 000000000000..f7b9d75bab0a
--- /dev/null
+++ b/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
+HOMEPAGE="http://www.darkops.net/wmtimer"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ sed -i -e "s:\$(CFLAGS)::" Makefile || die
+ sed -i -e "s:-g::g" Makefile || die
+ sed -i -e "s:-O2:\$(CFLAGS) ${CFLAGS}:" Makefile || die
+ sed -i -e "s:-o wmtimer:\$(LDFLAGS) -o wmtimer:" Makefile || die
+ epatch "${FILESDIR}"/${PN}-counter-fix.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="-L/usr/$(get_libdir)"
+}
+
+src_install() {
+ dobin wmtimer
+ dodoc ../{Changelog,CREDITS,README}
+}
diff --git a/x11-plugins/wmtimer/wmtimer-2.92.ebuild b/x11-plugins/wmtimer/wmtimer-2.92.ebuild
new file mode 100644
index 000000000000..5a98932b7587
--- /dev/null
+++ b/x11-plugins/wmtimer/wmtimer-2.92.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
+HOMEPAGE="http://www.darkops.net/wmtimer"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ sed -e "s:\$(CFLAGS)::" -i Makefile
+ sed -e "s:-g::g" -i Makefile
+ sed -e "s:-O2:\$(CFLAGS) ${CFLAGS}:" -i Makefile
+ sed -e "s:-o wmtimer:\$(LDFLAGS) -o wmtimer:" -i Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="-L/usr/$(get_libdir)"
+}
+
+src_install() {
+ dobin wmtimer
+ dodoc ../{Changelog,CREDITS,README}
+}