summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-11 22:18:06 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-14 11:01:07 +0200
commit47a454c11f02b22df1f95f6848bdde27dd6e24a7 (patch)
treedcfb161c32fd9762206996fd88e979e4a3aeae13 /x11-plugins/wmMatrix
parentx11-plugins/wmMatrix: use HTTPS (diff)
downloadgentoo-47a454c11f02b22df1f95f6848bdde27dd6e24a7.tar.gz
gentoo-47a454c11f02b22df1f95f6848bdde27dd6e24a7.tar.bz2
gentoo-47a454c11f02b22df1f95f6848bdde27dd6e24a7.zip
x11-plugins/wmMatrix: EAPI7, use HTTPS, improve ebuild
Diffstat (limited to 'x11-plugins/wmMatrix')
-rw-r--r--x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch4
-rw-r--r--x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild31
2 files changed, 33 insertions, 2 deletions
diff --git a/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch b/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
index 5225ad38f679..691ff7e424d7 100644
--- a/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
+++ b/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 1999-08-16 18:01:58.000000000 +0200
-+++ Makefile 2008-01-27 23:23:36.000000000 +0100
+--- a/Makefile 1999-08-16 18:01:58.000000000 +0200
++++ b/Makefile 2008-01-27 23:23:36.000000000 +0100
@@ -1,8 +1,8 @@
-CC = gcc
-CFLAGS = -O2 -Wall
diff --git a/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild b/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
new file mode 100644
index 000000000000..2b088ebf2f11
--- /dev/null
+++ b/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="WMaker DockApp: Slightly modified version of Jamie Zawinski's xmatrix screenhack"
+HOMEPAGE="https://www.dockapps.net/wmmatrix"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+CDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${CDEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${CDEPEND}
+ x11-misc/xscreensaver"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ # this version is distributed with compiled binaries!
+ make clean
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}