summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-led-notification
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-led-notification')
-rw-r--r--x11-plugins/pidgin-led-notification/Manifest1
-rw-r--r--x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch34
-rw-r--r--x11-plugins/pidgin-led-notification/metadata.xml9
-rw-r--r--x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild43
4 files changed, 87 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-led-notification/Manifest b/x11-plugins/pidgin-led-notification/Manifest
new file mode 100644
index 000000000000..4c45d4b9e5c5
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/Manifest
@@ -0,0 +1 @@
+DIST led-notification-0.1.tar.bz2 8848 SHA256 aed13cd45e6bbb89574d9eafe477adc7ef3f0a1768cb1f3c5f573e08186e1a16
diff --git a/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
new file mode 100644
index 000000000000..aaabada116db
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
@@ -0,0 +1,34 @@
+--- led-notification-0.1/led-notification.c
++++ led-notification-0.1/led-notification.c
+@@ -54,9 +54,9 @@
+ }
+
+ if(state) {
+- fputs("1", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_on"), file);
+ } else {
+- fputs("0", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_off"), file);
+ }
+
+ fclose(file);
+@@ -155,6 +155,10 @@
+
+ ent=pidgin_prefs_labeled_entry(vbox2,"File to control led:",
+ "/plugins/gtk/gtk-simom-lednot/filename",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led on:",
++ "/plugins/gtk/gtk-simom-lednot/led_on",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led off:",
++ "/plugins/gtk/gtk-simom-lednot/led_off",sg);
+
+ gtk_widget_show_all(frame);
+ return frame;
+@@ -166,6 +170,8 @@
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/chat", "nick");
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/filename",
+ "/proc/acpi/asus/mled");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_on", "1");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_off", "0");
+ }
+
+ static gboolean plugin_load(PurplePlugin *plugin) {
diff --git a/x11-plugins/pidgin-led-notification/metadata.xml b/x11-plugins/pidgin-led-notification/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
new file mode 100644
index 000000000000..bf9e7fb55fb6
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Pidgin plugin to notify by writing user defined strings to (led control) files"
+HOMEPAGE="http://sites.google.com/site/simohmattila/led-notification"
+MY_PN=${PN/pidgin-/}
+MY_P=${MY_PN}-${PV}
+SRC_URI="http://sites.google.com/site/simohmattila/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-hardware.patch
+}
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} -fpic $(pkg-config --cflags gtk+-2.0 pidgin) \
+ -shared ${MY_PN}.c -o ${MY_PN}.so \
+ ${LDFLAGS} $(pkg-config --libs gtk+-2.0 pidgin) || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/pidgin
+ insopts -m755
+ doins ${MY_PN}.so || die
+ dodoc README || die
+}